Skip to Content
Technical Articles
Author's profile photo Morten Wittrock

Apache Camel in CPI on Neo is getting updated

For a while now, SAP Cloud Integration in the Cloud Foundry environment has been running a newer version of the underlying Apache Camel integration framework than SAP Cloud Integration in the Neo environment. Specifically Apache Camel 2.24 in Cloud Foundry vs. 2.17 in Neo.

One consequence of this was that certain expressions in the Apache Camel Simple expression language would work in the Cloud Foundry environment, but fail in the Neo environment (thank you to my fellow SAP Mentor Daniel Graversen for pointing this out to me).

Luckily, CPI tenants in the Neo environment are now being updated to run the same version of Apache Camel as in the Cloud Foundry environment. This morning, the CPITracker feed informed me that its tenant has been updated:

 

(Please note, though, that these updates are not simultaneous across all CPI tenants. So your particular tenant might not have received it yet.)

With the newer version of Apache Camel in place on both Cloud Foundry and Neo, I took the opportunity to update my blog post introducing Camel’s Simple expression language in CPI. It now covers the date handling expressions, that up until now failed in the Neo environment, as well as more of the idiosyncrasies of CPI’s implementation of Simple.

Check it out and do let me know, if there’s anything you’d like to see added.

Assigned tags

      1 Comment
      You must be Logged on to comment or reply to a post.
      Author's profile photo Sriprasad Shivaram Bhat
      Sriprasad Shivaram Bhat

      Hello Morten,

      Good Info!..Simple Expression behaviors post update documented in below KBA and goot to have reference.

      KBA - 3014782

      Regards,

      Sriprasad Shivaram Bhat