Skip to Content
Technical Articles

SAP ABAP Platform 1909 Developer Edition: Wrapup&Tips of Installation on Windows 10

So exciting that SAP provides a Docker version of SAP ABAP Platform 1909, Developer Edition, guess many ABAPer already enjoy their own mini S4/HANA right now. I’m few days behind the cause of network limitation as it’s a really giant image of more than 20GB.

 

Thanks the SAP community already has many excellent articles that explain the features of the developer edition, how to install it, and troubleshooting, etc. which cover almost everything needed. The best sequence for me to understand the whole story and begin the explore is:

  1. SAP ABAP Platform 1909, Developer Edition: AVAILABLE NOW | SAP Blogs
  2. Requirements& Setup instructions of ABAP Platform Developer Edition
  3. SAP ABAP Platform 1909, Developer Edition – installation on WINDOWS OS | SAP Blogs
  4. SAP ABAP Platform 1909, Developer Edition: Day 1 Experience and Tips and Tricks | SAP Blogs
  5. Using multi-model capabilities of SAP HANA in the new ABAP 1909 Developer Edition – Part II – Spatial functions | SAP Blogs

I skip issues already mentioned in the above blogs and list my own below hope it can help if someone not very familiar with this installation at windows:

1. Windows Subsystem for Linux(WSL) Installation Guide for Windows 10

Even the Simplified install confused me a little, not even mention this article. I try to follow those steps and find out it’s not that complex at all, just download/install and restart will do.

For those steps need to input the command line:

wsl --set-default-version 2

at Powershell to set WSL 2 as your default version, it’s the default setting on my PC automatically after installation without running those commands line. Don’t know if it’s a common case or not. You can check this on the windows control panel to verify just in case:

 

2.The pull process for the biggest part: 687cfbdddf24

It cost me hours to download this giant file, sometimes I wonder if the download engine is suspended when no figure updates after minutes. At this time, please Don’t try to change the size of this command window during this pull~ Those texts will be totally mess up and show multiply times with updated status with disorder time sequence, and the more frustrating thing is it, no sign of Pull complete after hours of waiting. I monitor the network performance at task manager which falls from a cliff from 10M+ (which last hours) to 100Kbps (should be zero speed for this pull considering other basic network activities at Windows) but no sign of pull completion.

Then I have to rerun the pull command again. Maybe it’ll be no issue with the high speed of the network.

3. The message “Retrying in 1 second” during the pull process

A common error in the pull phase is that there is a message “Retrying in x seconds” message shown and nothing happens. In this case, it can be that you do not have enough space on your drive. Try to free up at least 100GB as a compressed image has 23.52GB and decompressed 62.4GB.”

Space is not the issue for me, I have 300+GB available at my only C driver. Then I suspect could be relevant to access authority cause C is the system root driver. Actually, it’s not, just keep patience it’ll keep retrying. After rerun the pull Command / saw those messages several times, it suddenly worked and carry on the following download.

4. The command for Docker run after the pull complete

May caused by various system environments, the command from Thomas Jung does not work for me. Just no response from the command line and stuck there.

docker run --stop-timeout 3600 -i --name a4h -h vhcala4hci -p 3200:3200 -p 3300:3300 -p 8443:8443 -p 30213:30213 -p 30215:30215 -p 50000:50000 -p 50001:50001 -p 50013:50013 -p 50014:50014 store/saplabs/abaptrial:1909 -skip-limits-check -agree-to-sap-license

Then I try the command from Martin Maruskin:

docker run --stop-timeout 3600 -i --name a4h -h vhcala4hci -p 3200:3200 -p 3300:3300 -p 8443:8443 -p 30213:30213 -p 50000:50000 -p 50001:50001 store/saplabs/abaptrial:1909

And I got the below error message: ‘The container name ‘/a4h’ is already in used by container’.

All commands recommended by different articles are using this ‘a4h’ as a container name. As suggested in this message, I rename ‘a4h’ as ‘as4h’ for the container name. Anyway, I got a success message finally and hope no dependency on this container name at any configuration places: P

My ultimate command for docker run:

docker run --stop-timeout 3600 -i --name as4h -h vhcala4hci -p 3200:3200 -p 3300:3300 -p 8443:8443 -p 30213:30213 -p 50000:50000 -p 50001:50001 store/saplabs/abaptrial:1909 -agree-to-sap-license -skip-limits-check

After my Docker ‘as4h’ is running, and I go back to the Docker desktop screen and surprisingly find out ‘a4h’ already existed with parameter(5). That’s why the container name ‘a4h’ is duplicated at my PC, must be caused by the pull/docker run command been executed several times after no response. Maybe it’s a better idea to check this after enter the docker running command and no rush to re-enter the docker run or the pull command which really costs a lot and causes duplicated issues.

 

5. Connection setting for SAP GUI

Haven’t set up Eclipse yet, using GUI with the below connection setting is workable for me with user name: DEVELOPER and password Ldtf5432.

Haven’t played a lot, but these input hints look great 🙂

 

Btw, this Developer Edition definitely not suitable for a functional purpose, only around 12,000 TCODEs existed compared with at least 100,000 TCODES that existed for the regular SAP system. TCODE like MM01/VA01 does not exist at this Developer Edition. SPRO is very limited as well.

As ABAPer, this Developer Edition is surely a gift 😀

Thanks, SAP,  and John Doe (You’re the master template, everyone will get your name as the default user name 🙂 )!

6 Comments
You must be Logged on to comment or reply to a post.
  • The issue with "/a4h already in use" is explained in Setup Instructions on the docker hub page (you must be logged in)

    https://hub.docker.com/_/sap-abap-trial/plans/ac8a4f9b-ae29-4afa-9b39-25aeea24b821?tab=instructions

    The document contains the section "Run troubleshooting" and an articl focused on this error:

    executing the run command again will most probably lead to a container name collision error with the following symptoms:

    Error response from daemon: Conflict. The container name "/a4h" is already in use by container XYZ. You have to remove (or rename) that container to be able to reuse that name..

    That's because the first command started a container named a4h which immediately exited but docker didn't remove it and now you are trying to start another container with the same name. Correct, that's what we advised you to do. However, to be able to start the container again you must remove the previous instance using the command docker rm -f a4h and only then you can issue the enhanced docker run command again.

     

    I hope this sheds some light on the misteriously not working command from Thomas Jung and I hope it will help you to understand why you had to use a different name than a4h.