Skip to Content
Product Information

⚙️ System Requirements for Integrations with SAP CPQ

Dear All,

This article will guide you on how SAP CPQ can be integrated with a number of other SAP solutions.

Before integrating SAP CPQ with another SAP application, please make sure that you meet all the necessary system requirements and own the required components.

 

🛠️ System Requirements for SAP Integrations

Application System Requirements Other Required Components
SAP ERP for simple products (without variant configuration)
  • SAP ERP 6.0 EHP 0 or higher
  • SAP Cloud Platform Integration
  • ERP C4 Integration Add-On CODERINT

 

SAP S/4HANA On-Premise

 

  • SAP S/4HANA version 1809 or higher
  • SAP Cloud Platform Integration
  • In case configurable products are in use: SAP Variant Configuration and Pricing

SAP ERP for Variant Configuration products

 

  • SAP Cloud Platform Integration
  • ERP C4 Integration Add-On CODERINT
  • SAP Variant Configuration and Pricing (comes with SAP CPQ, edition for variant configuration)

 

SAP Cloud for Customer

 

SAP Cloud for Customer version 1905 or higher

SAML 2.0 Single Sign On needs to be established so that users are authenticated in SAP CPQ when navigating from SAP Cloud for Customer.

  • ·SAP Cloud Platform Integration
  • SAP ERP or SAP S/4HANA as a source system of product master and customer master (out of the box, SAP CPQ and SAP Cloud for Customer do not share the same product (material) master)

 

SAP Commerce SAP Commerce (on premise) version 1811 or higher, or SAP Commerce Cloud version 1811 or higher
  • SAP Cloud Platform Integration
  • In case configurable products are in use in SAP ERP or SAP S/4HANA: SAP Variant Configuration and Pricing.
    Works with SAP Commerce Cloud only.
    SAP Commerce On-premise only supports simple products.

 

 

Be the first to leave a comment
You must be Logged on to comment or reply to a post.