Skip to Content
Technical Articles

Upcoming End of Mainstream Maintenance for SAP_UI 7.50 (SAPUI5 1.38) and SAP_UI 7.52 (SAPUI5 1.52)

Working with a complex system with different components and their respective versions is often a challenge. The respective information on SAPUI5 versions is provided by SAP, see the SAPUI5 versioning concept and e.g. my blog “Fresh UI5 innovations every month“. Also see the SAPUI5 version overview and SAPUI5 versions in the ABAP platform.

I want to make you aware of the fact that the SAPUI5 long-term maintenance versions 1.38 and 1.52 have their end of maintenance at the end of 2020.

  • For end of mainstream maintenance for SAP_UI 7.50 (SAPUI5 1.38) see note 2972680 (for general information on SAP Fiori FES 2.0 see note 221596).
  • For end of mainstream maintenance for SAP_UI 7.52 (SAPUI5 1.52) see note 2972656 (for general information on SAP Fiori FES 4.0 see note 2484979).

Most customers want to receive latest SAPUI5 innovations and at the same time ensure standard support. Therefore, SAP does not recommend starting new implementations with SAP_UI 7.50 / 7.52, but instead taking the required steps for an upgrade to a more recent version.

Specifically, we recommend an upgrade to SAP_UI 7.54, part of SAP Fiori Front-End Server 6.0 (note 2775163) with an end of mainstream maintenance at the end of 2027. SAP Fiori FES 6.0 contains the long-term maintenance version SAPUI5 1.71. which ensures a continuous maintenance coverage.

For upgrade information see SAP Maintenance StrategySAP Maintenance Planner and Software Logistics Tools. Before an upgrade, please check the target release information and notes referenced in note 2217489, and also check if the installed applications support the new target landscape.

5 Comments
You must be Logged on to comment or reply to a post.
  • Hello Oliver,

    Last week I upgraded a ERP 6 System to EHP8, latest support package stack. I wonder why the Maintenance Planner still suggests UI 7.50 as the recommened version if it is out of support soon?

    7.50%20recommended

    Best regards,
    Markus

    /
    7.50%20recommended
    • Hi Markus,

      right, this is a valid point.
      Here we have an improvement since mid September, as Maintenance Planner shows a warning ‘NOTE: The selected USER INTERFACE TECHNOLOGY 7.50 alternative version will be out of maintenance on 31.12.2020. For more details see …’ in a Warning dialog. As far as I understand it still shows ‘recommended’, but at least the user has an information on the end of maintenance.

      Best regards,
      Oliver

  • Hello Oliver,

    I just repeated the planning in the MP, but I did not get any warning about the end of maintenance when I selected UI 7.50. Where should it be displayed?

    Best regards,
    Markus

    /
    • Dear Markus,

      Thanks for the feedback. The general recommendation in maintenance planner is based on a minimum support-package change for such alternatives. So, if the system start state is having SAP USER INTERFACE TECHNOLOGY 7.50, then maintenance planner will show that as the recommendation.

      As Oliver pointed out, the warning in the maintenance planner to show the version going out of maintenance has been implemented. But, it looks to be the case that it’s only coming in combination of another warning message for missing selection or Kernel software component versions/IGS/SUM etc.

      This warning message has to be decoupled, so that it comes up when such alternative selections are used in the plan. We’ll address this change.

      Many Thanks,

      Anupam

  • Hello Anupam,

    Thanks for checking this! Yes, looks like this has to be decoupled.

    The system I am updating is based on NW 7.31 (ERP 6 with EHP 6), so it does not have UI 7.50 already installed. I would consider  UI 7.54 as a valid recommendation for this system to have a maintained version in place in case the customer wants to start using Fiori Apps.

    Best regards,
    Markus