Skip to Content
Product Information

Integration Advisor – Now GS1 EANCOM Library available

We are happy to announce that we now also provide the libraries for GS1 EANCOM. In this blog post we will give you a short overview.

GS1 EANCOM Library in Integration Advisor

GS1 EANCOM® is a GS1 subset of the UN/EDIFACT standard (United Nations Electronic Data Interchange for Administration, Commerce and Transport). It contains only the message elements required by business applications especially for domains supported by the GS1 organizations such as retail, consumer products, transport and logistics. Omitted are optional elements that are not relevant for the specific use cases.

Currently we support overall 10 versions (so called EANCOM Editions) from 1995 up to 2002 Edition 2016:

As EANCOM is a subset of UN/EDIFACT, the Integration Advisor content license for EANCOM is part of the license for UN/EDIFACT.

Message Standards versus Message Guidelines

EANCOM (like many other UN/EDIFACT subsets) distinguishes between two types of libraries:

  • Message Standards: The library of Messages, Segments, Data Elements and Codelists which are required for the EANCOM subset. This particularly includes EANCOM-specific code values which are not part of the UN/EDIFACT standard delivery.
  • Message Guidelines: Specific Guidelines for countries and business processes which are defined in the context of the EANCOM subset.

Integration Advisor currently provides the EANCOM Message Standards upon which you can build your own Message Implementation Guidelines (MIGs).

EANCOM Usage in SAP Cloud Platform Integration

In order to use EANCOM you should configure your Integration Flow in the same way as you would for UN/EDIFACT. Template Flows for UN/EDIFACT (and other supported Type Systems) can be found on the SAP API Business Hub (https://api.sap.com/package/ICAPrepackagedContent?section=Artifacts).

For EANCOM, there is one additional specific requirement:  In your Message Implementation Guideline (MIG) you need to enable node UNH > S009 > 0057 and you must select within the Codelist tab the correct EANCOM version code (such as EAN010) you want to work with. Please select only a single code value to ensure correct processing in the CPI Runtime.

(UPDATE 04-09-2020:

  • It is now optional and not longer mandatory to enable node UNH > S009 > 0057 in your MIG.
  • If you use this node and assign either a fixed value to it or select a single code value, Integration Advisor will create an XSD specifically named for this EANCOM version code (Example: UN-EDIFACT_ORDERS_D01B_EAN010.xsd).
  • Otherwise the XSD will follow a generic naming convention (Example: UN-EDIFACT_ORDERS_D01B.xsd).
  • Both variants will be accepted by CPI Design time and Runtime.)

EANCOM Usage in SAP Process Orchestration

SAP Process Integration B2B Add-On also supports EANCOM Message Standard. Currently all EANCOM versions up to 2002 Edition 2008 are supported. In order to define Message Implementation Guidelines (MIGs) for SAP PI / PO you would need to pick a supported EANCOM version and subversion.

Further reading

https://blogs.sap.com/2019/03/12/integration-content-advisor-overview-of-components-and-further-reading/

https://blogs.sap.com/2018/02/07/integration-content-advisor-display-and-review-b2ba2a-standard-libraries/

https://blogs.sap.com/2019/06/20/integration-advisor-latest-b2ba2a-libraries-for-creating-and-maintaining-your-customized-interfaces-and-apis/

1 Comment
You must be Logged on to comment or reply to a post.
  • Thank you for the information, Joerg!

    CPI gets better and more capable with each update. That really gives confidence to consultants & customers. Keep up the good work!

    Regards,
    Fatih