Skip to Content
Technical Articles

S/4HANA 1909 FPS00 Installation: Part 1 – Maintenance Planner

The installation procedure of S/4HANA 1909 FPS00 has not much changed when compared to last year’s S/4HANA 1809 FPS00 Installation (Part 1, Part 2 and Part 3). In this three series blog, I will pen down necessary steps and guidelines to perform the installation and highlights the errors that you might encounter.

References

Blogs should always be taken as a reference, you should always first refer to the latest documents or SAP Notes that are available by SAP. Below are few SAP Notes that can be useful when you plan installing S/4HANA 1909.

Product & Database Information

This section gives you an overview on the components for SAP S/4HANA 1909.

HANA Database

For HANA database, always use latest available version but the minimum required version for S/4HANA 1909 is HDB 2.0 SPS 04 Revision 42. In PAM, there is no mention of revision for HANA database, but you can find that information in SAP Note 2804060

IMPORTANT NOTE: In this blog, I won’t be installing new HANA database instead will be using existing database and upgrading to Revision 42. As my existing database has high isolation set up, there are some additional steps required in HANA database before you start installing S/4HANA.

SAP Fiori Deployment Recommendation

SAP Fiori Front End Server can be deployed in multiple ways, but the recommend method is to have embedded deployment for S/4HANA (highlighted in GREEN). The reason why embedded deployment is recommended is because of –

  • Strong dependencies between UI and backend software components and a missing version interoperability
  • An optimized runtime performance (no remote calls, caching of meta/business data)

SAP Fiori for SAP S/4HANA 1909 requires minimum SAP Fiori Front End Server 6.0 SPS00

Running SAP FIORI Fiori front-end server as an embedded deployment on your S/4HANA back-end will be based on SAP HANA Database.

Running SAP FIORI Fiori front-end server hub deployment, SAP MaxDB, Sybase ASE and SAP HANA Database are supported database systems.

For more information on SAP Fiori Front End Server for S/4HANA 1909, kindly refer below SAP Notes

Maintenance Planner

SAP recommends using Maintenance Planner to plan the installation. The Maintenance Planner creates a stack XML file with the support package stack information that you then hand over to the Software Provisioning Manager (the installer).

Maintenance Planner Link

Click on “Plan for SAP S/4HANA”.

Click on “Install New SAP S/4HANA System”

Enter SID for new system and select target version and stack.

You will see that SAP Predictive Integrator and SAP HANA Rules Framework gets selected automatically with S/4HANA 1909, that was not the case in S/4HANA 1809. If you check What’s New Viewer – S/4HANA 1909, there are many pre-configured Predictive scenarios that are included in S/4HANA 1909 which you can enable and consume directly. But in order to use that you need SAP Predictive Integrator.

You can find more information on Predictive Integrator in below SAP Notes

2631182 – Central Release Note Predictive Analytics integrator (PAi)

NOTE: Installation Procedure won’t install Predictive Integrator (PAi) and HANA Rule Framework (HRF) automatically in your HANA database. On selecting this two component in maintenance planner, it will only download the packages. Applying it on HANA needs to be manually done by user.

As Fiori Embedded Deployment is recommended option, I’m choosing above option. In target product instance, I have selected only “UI for SAP S/4HANA” because on selecting other product instance it was giving me below errors due to which I was not able to generated stack file.

UI for HCM: OCS package SAPK-200AGINUIX01CA1 does not match the current software component vector
UI for MDG: OCS package SAPK-200AGINUIMDG001 does not match the current software component vector
UI for TRV: OCS package SAPK-300AGINUITRV001 does not match the current software component vector

 

But now when I select other two component (don’t select obsolete only), it works fine. I’m not sure what is the issue earlier which has provided me this error. You can raise message to SAP to help you on this, if you really need this product instance apps in S/4HANA.

As of 10/01/2019, when I select UI for HCM (Fiori 2.0), it is giving me below error.

OCS package SAPK-100AGINUIHR002 does not match the current software component vector

IMPORTANT NOTE: I won’t be using HCM, MDG or TRV functionality in my S/4HANA, so I have skipped selecting above component and had just selected “UI for S/4HANA” and proceed further.

As I need this S/4HANA System to be connected to SAP Access Control 12.0 SP 03 (GRC System Foundation Version), I planned to install it’s plug-in in S/4HANA System.

Minimum Plug-In version required for S/4HANA 1909 is SAP Access Control 12.0 SP 05. But as my foundation system is on SAP AC 12.0 SP 03, I cannot install plugin with higher version.

As per attached excel in SAP Note 1352498 – Support Pack Numbering – GRC Access Control, it is mentioned that the foundation SP level of AC should always be higher than the plugin SP.

As this is not a show stopper, you can skip this step and later install plugin once your GRC foundation system is upgraded to SP05.

Select your OS/DB files. SUM is required to perform upgrade, so kindly select Software Update Manager 2.0 as well.

Check all files that are included in stack. All languages are selected by default, so make sure that you deselect other languages or select the one that are required.

English and German are default language. I need multiple languages in my landscape, so I have selected that languages and clicked next

Download “.xml” file and push files to download basket.

Once the download is completed. Transfer files to server.

Next Blog – S/4HANA 1909 FPS00 Installation: Part 2 – Installation and Upgrade

Regards,

Dennis Padia

8 Comments
You must be Logged on to comment or reply to a post.
  • Hello Dennis,

     

    I ran into the same issue with SAPK-100AGINUIHR002 when I tried to set this up last week.

    I sidestepped it at that time by downloading the “automatic install” package of S4 1909.
    However, trying to install any add-on or do any maintenance through the maintenance planner for this system, I now get that same error, which makes it impossible to plan any actions at all for the system.

     

    I’ve already logged a message with SAP as well, but wanted to check if you had taken any action about this issue yourself (or heard anything)?

     

    Thanks for any feedback!

    • Hello Gert,

      After installing S/4HANA Server and applying Fiori Add-On, I have not tried performing additional maintenance through maintenance planner. I will try to replicate this scenario in couple of days, by the time if you get any reply from SAP just let us know.

      Regards,
      Dennis Padia

  • Hi Dennis,

    Nice blog! Thanks for sharing this.

    I do have a question.

    We also need to install S/4Hana 1909 including PLM.

    • Is PLM an add on on 1909?
    • Can we select it during 1909 installation?
    • Or do we need to connect S/4Hana installation to a PLM installation in the SAP cloud?

    This is not clear for me and I cannot find any relevant information on this in the installation guides.

    Thank in advance.

    Raymond Bude

  • Hello Dennis,

    Another great blog by you, thanks a lot for writing it.

     

    Can you please check the below statement?

    “minimum required version for S/4HANA 1909 is HDB 2.0 SPS 04 Revision 42” – now minimum revision for 1909 should be 44.

    Thanks.

    • Hello Wajid

      SAP always suggest to use latest HANA version when installing new S/4HANA. Same can be found in below SAP Note, which keeps getting updated. As you can see, if you compare version 3 and version 8 of SAP Note, HANA revision has been changed from 42 to 44 now. So always try to refer latest available SAP Note.

      Regards,

      Dennis Padia

  • Hi Dennis,

    Which GRC plug-in we should download for installing on S/4HANA 1909 server? since I’ve come across the following two Access control add-on components which are compatible with S/4HANA 1909 and per your blog, I believe that you were trying to download “SAP Access Control 12.0” instead of “SAP AC 12.0 for S/4HANA” right?

    • SAP Access Control 12.0
    • SAP AC 12.0 for S/4HANA

    Regards,

    Dheeraj

    • Hello Dheeraj,

      As my GRC foundation (SAP Access Control 12) is installed on SAP Netweaver 7.52, I just needed plugin to be installed on my S/4HANA 1909 system for which I had chosen “SAP Access Control 12.0” and had selected the plugin for S/4HANA1610+ and it only gives me option to select plugin

      Whereas for “SAP AC 12.0 for S/4HANA”, it give me option to either make my S/4HANA 1909 as foundation of GRC as well as it is giving me option to download plugin for S/4HANA1610+

      If you want to choose just plugin of Access Control for your S/4HANA 1909, you can choose either of the two option and select “Plug-in on S/4HANA 1610+”, because ultimately it will download below packages

      SAP GRC PLUGIN NW 7.50 [ SAPK-V1205INGRCPINW ]
      SAP GRC PLUGIN S4HANA 1610+ [ SAPK-V1202INGRCPIERP ]

      NOTE: For S/4HANA 1909, minimum SP level of plugin required is SP 05 for Access Control 12.0. So your GRC foundation should be on minimum of SP05 for Access Control 12.0

      Regards,

      Dennis Padia