Skip to Content
Product Information

New Versions of SAP Cloud SDK: 2.18.0 for Java, 1.4.1 for JavaScript, and v20 of Continuous Delivery Toolkit

We have released new versions of the SAP Cloud SDK. In detail, the following components are now available in new versions:

In this blog post, we will walk you through the highlights of these releases. For a complete overview, visit our release notes for the Java libraries, for the JavaScript libraries, and for the continuous delivery toolkit. The release notes also include the change log of all our releases so far.
At the end of the article, you will find a set of instructions on how to update to the new versions.

Java Libraries: Release Highlights 2.18.0

You can update your dependencies of the SAP Cloud SDK for Java to version 2.18.0 and consume the new version from Maven Central.

Update of Message VDM to SAP S/4HANA Cloud 1905

After the newest release 1905 of SAP S/4HANA Cloud, version 2.18.0 updates the message virtual data model (VDM) that allows to consume messages from SAP S/4HANA Cloud in a type-safe manner.
This update includes 30 new message types to reflect the new event types added in SAP S/4HANA Cloud. With this, we support all business event types of SAP S/4HANA Cloud. The Java representations for these are available from package com.sap.cloud.sdk.s4hana.datamodel.messaging.api.message.

Further improvements

We have fixed an issue in the Multichain module where an exception was incorrectly thrown in listStreams when the result included non-subscribed streams.

Further improvements are listed in the full release notes.

JavaScript Libraries: Release Highlights 1.4.1

The JavaScript libraries of the SAP Cloud SDK are now available in version 1.4.1.

Release of OData client generator

Version 1.4.1 brings the initial release of the OData client generator for JavaScript and TypeScript. As already known from the SAP Cloud SDK for Java, the generator allows generating clients for custom OData services that simplify accessing OData services from JavaScript or TypeScript. The output of the generator offers a developer experience similar to the virtual data model for SAP S/4HANA Cloud OData services, but for custom OData v2 services. The generator is available in its own module @sap/cloud-sdk-generator.

To use the generator, first install it into your project that uses the SAP Cloud SDK for JavaScript as follows:

npm install --save-dev @sap/cloud-sdk-generator fast-xml-parser

 

Then, store the metadata document of the OData v2 service in question in a folder input and call the generator to create the TypeScript files for accessing this OData service:

npx generate-odata-client -i input/ -o src/odata-client/

 

For more information, take a look at the usage instructions and available options available via npx generate-odata-client --help.

New tutorial series on OData VDM

We have published a new tutorial series on using the OData client of the SAP Cloud SDK for JavaScript. This tutorial series uses the example of the business partner service in SAP S/4HANA Cloud, which is part of the pre-delivered virtual data model in the SDK. The concepts also apply to any client generated with the above-mentioned generator.

Further improvements

Version 1.4.1 fixes an issue where destinations with protocol HTTP (instead of HTTPS) led to an error like Protocol "http:" not supported. Expected "https:".

We have also fixed an issue where the deserialization of certain entities would fail due to cyclic dependencies across linked entities. This cyclic dependency caused entities to be undefined and led to error messages such as Cannot read property 'builder' of undefined.

As usual, the full release notes contain a list of all improvements in this release.

Continuous Delivery Toolkit: Release Highlights v20

We have also released version v20 of our out-of-the-box continuous delivery offering consisting of a ready-made Jenkins server and a complete delivery toolkit.

Version v20 runs the stages for frontend unit tests, Checkmarx, and Fortify on Java, Node.js and HTML5 modules of multi-target applications.

If the Checkmarx plugin reports a build failure, the pipeline now aborts the build so that the pipeline run is not marked as success when Checkmarx may actually hav severe findings. This is a potentially breaking change for projects above the threshold.

You can find further fixes and improvements in the complete release notes.

How to Update

Java libraries

To update the version of the SAP Cloud SDK Java libraries used in an existing project, proceed as follows:

  • Open the pom.xml file in the root folder of your project.
  • Locate the dependency management section and therein the sdk-bom dependency.
  • Update the version of that dependency to 2.18.0.

With this, you are already done thanks to the “bill of material” (BOM) approach. Your dependency should look like this:

<dependencyManagement>
    <dependencies>
        <dependency>
            <groupId>com.sap.cloud.s4hana</groupId>
            <artifactId>sdk-bom</artifactId>
            <version>2.18.0</version>
            <type>pom</type>
            <scope>import</scope>
        </dependency>
    </dependencies>
    <!-- possibly further managed dependencies ... -->
</dependencyManagement>

If you are using the SAP Cloud SDK in a project of the SAP Cloud Application Programming Model, replace sdk-bom with sdk-modules-bom to only update the version of SDK modules, not further dependencies.
You can now recompile your project (be aware of the compatibility notes, though) and leverage the new features of the SAP Cloud SDK in version 2.18.0.

Of course, you can also generate a new project that uses version 2.18.0 from the start by running the Maven archetypes for Neo or Cloud Foundry with -DarchetypeVersion=2.18.0 (or RELEASE).

JavaScript libraries

To update the version of the SAP Cloud SDK JavaScript libraries used in an existing project, use the command npm update in the root folder of your module. Note that this will also update other modules, unless you explicitly specify which packages to update. If you want to check beforehand what will change, use npm outdated.

Continuous Delivery Toolkit

If you are using the pipeline with a fixed version (as recommended since v7), update the continuous delivery toolkit with the following command, that you run on the server hosting the cx-server:

./cx-server update image
Be the first to leave a comment
You must be Logged on to comment or reply to a post.