Skip to Content

Apply S/4HANA 1709 FPS02 …

Since May 2018, the second Feature Pack for S/4HANA 1709 is available. As I already had a lot of fun with the Upgrade to S/4HANA 1709 FPS01, I wanted to apply the Support Packages via SPAM/SAINT

Note 2536585 – Upgrade: Missing SAP Notes in SPDD and SPAU
Note 2606986 – Upgrade: You cannot reset obsolete SAP Notes in transaction SPAU
Note 2649715 – Rescue of Add-Ons during an upgrade fails in phase JOB_RDDIT020 or CONFLICT_CHECK

So, updated SPAM/SAINT and created a valid stack.xml via the Maintenance Planer as already described in the Blog – Upgrade to S/4HANA 1709 FPS01 – fast trak.

Ok, so far so good. Downloaded 84 Packages (I ignored some of the Add-On’s to make sure, the MP will calculate the Core target system correctly) and increased the Parallel Import Value for SPAM.

The Import was running smoothly until the following error occurred:

Hmm, nothing found in the main SAP Note (however would be suitable …)
Note 2465159 – Known problems with Support Packages in SAP NW 7.52 AS ABAP

But reading the following SAP Note war more fruitful:

Note 2643245 – HDI Migration for Real-Time Consolidation in SAP S/4HANA 1709
(Udo Report Note 2641042)

However the Note says: After you upgrade to S/4HANA 1709 FSP02 or higher releases, the HANA Repository is replaced by HANA Deployment Infrastructure (HDI) Container. To use ZDO in your next system upgrade, all HANA Repository Views (excluding CDS views) in RTC should be migrated to SAP HANA Deployment Infrastructure Container Views (HDI Views). The affected HANA views include foundation views, generated consolidation views, and those views used by BW virtual InfoObjects.


Configure HDI Container Support

So, it was necessary to configure the HDI Container Support during the SP Import …
the following Reports were found in the SAP Note
Note 2569651 – Configure your ABAP Development System for Development of HDI Objects

Report SCTS_HTA_CHECK_CONFIGURATION
this Report allows you to check the HDI Configuration.
Please Note that not all Recommendations must be fulfilled to continue with the SP import at this time.



Report SCTS_HTA_CONFIGURATION
this Report shows the HDI Configuration.
If some of the values not filled by the configuration, you should maintain them accordingly.
Please Note that the Report differs between FPS01 and FPS02 for S/4HANA 1709

the first entry already indicated what to do now: you have to install the complete SAP Web IDE environment on the HANA 2.0 server, which is almost the same procedure as activating the native EDW environment. This will be explained in another Blog …

In the meantime see the comprehensive Blog from Denys van Kempen – SAP HANA 2.0 XS Advanced Installation

Configure SAP Web IDE Support

SAP Help 1 – SAP Web IDE for SAP HANA – Installation and Upgrade Guide

Note 2542391 – How to install SAP HANA XS Advanced
Note 2640631 – EXTENDED APP SERVICES 1 Patch Collection 44 (build 1.0.84 / PL 84)
Note 2458437 – SAPUI5 1.44 XSA upgrade/installation
Note 2510063 – SAP Web IDE for SAP HANA 2.0 SPS 03 – Central Release Note

Note 2326004 – How to uninstall SAP HANA XS advanced manually
Note 2451953 – Failed to Start XSController : Unable to start “authentication failed”

SAP Help 2 – Enabling HDI in the Database

Note 2569651 – Configure your ABAP Development System for Development of HDI Objects


Transaction SCTS_AMHC

Note 2643245 – HDI Migration for Real-Time Consolidation in SAP S/4HANA 1709
(Udo Report Note 2641042)
with this Transaction you can finally configure and activate the necessary HDI Containers

  • SAPS4H_RT
  • SAPS4H_RT_GEN



Transaction SCTS_HTA_DEPLOY

Note 2536195 – Unable to upgrade to S/4HANA 1709
with this Transaction you can deploy inconsistent objects into the created HDI Container Repositories which were not activated successfully during the SP import


And finally: the import of FPS02 for S/4HANA 1709 continues without any Problems …



Roland Kramer, PM EDW (BW/HANA/IQ), SAP SE
@RolandKramer

 

“I have no special talent, I am only passionately curious.”

To report this post you need to login first.

4 Comments

You must be Logged on to comment or reply to a post.

  1. Nicholas Chang

    Thanks Roland again for the excellent post! As always, from BW to S/4 😉

    Updating from FP01 to FP02 force to migrate HANA repo to HDI? If that’s the case, it would be the change of functionality, where all works done HANA Repo will switch and migrated to HDI? Consequently, developer need to pick up new HDI skillsets and force to work on HDI?

    Thanks,
    Nicholas Chang

     

    (0) 
  2. Roland Kramer Post author
    (0) 
  3. Markus Ganser

    Hi Roland,

    thanks, great stuff!
    One question: Is the functionality of HTA-for-HDI also planned for BW4/HANA and SAP-BW (7.50)?

    Thanks and best regards Markus

     

    (0) 

Leave a Reply