Skip to Content

Dear community,

to give a short answer to the question “How to setup SAP Business One in a HANA multipe tenant DB environment”: not to setup πŸ™

As far as my testing has shown to me: currently, SBO4HANA does not support being installed in a multiple tenant HANA DB.

I have done a “regular” setup with a single DB HANA System, installing SBO and got it as expected to work without any issue.

Afterwards, I converted the HANA system to a multiple tenant DB system. Proceeding like this has the advantage that in the remaining HANA tenant DB, where SBO has been installed, the HANA scriptserver as well as the HANA nameserver are still present.
And the port for accessing SQL will remain as it has been.
So no problem to connect after converting to the existing SBO DB’s, except an error when starting FIORI menu (instead of main menu an error “not authorized”) but other style menu worked fine, same with using menu bar.

So now trying to get SBO working in the 2ndΒ  and new tenant DB:
– for every new tenant DB, a new port range is used, starting with 3xx41 – 3xx43 for the first new created tenant DB, 3xx44 – 3xx46 for the second tenant DB and so on.
– SQL server in my new tenant DB is reachable using port 30041
– Successfully adding a new DB Instance <Server>:30041 in SLD: DB instances and Companies
– Starting SBO: choose company: I can select between “old” HANA DB instance <Server>:30015 and new <Server>:30041 πŸ™‚
– unfortunately, with selection of port 30041 an error occurs in status bar. Button “Create new Company is inactive.

OK, I don’t mind, no problem to copy company DB from old instance 30015 into new instance 30041.

Starting SBO, selecting 30041 instance: no DB πŸ™

OK, same with SBOCOMMON, and SLDDATA: starting SBO, selecting 30041 instance: no DB πŸ™

Reason: the SAP Server installation on Linux is asking to specify a DB server with port nr – so it is binded to one port, and can not handle two ports.

Of course I have tried to install SBO Server Linux part on a second Linux server and connect it to the 2nd HANA tenant DB: unfortunately, in the new tenant DB nameserver and scriptserver are missing and I could not get them installed.

So my final conclusion: no way to use multiple tenant DB’s in HANA environment with SAP Business One:
– SBO Server does not work with two DB instances in same HANA system
– setup new SBO Server for a new tenant DB not possible; nameserver and scriptserver missing.

 

Sorry not to have good news about that point; I would be very happy if someone could show me that I am wrong πŸ™‚

 

kind regards to all

Stefan

 

 

To report this post you need to login first.

Be the first to leave a comment

You must be Logged on to comment or reply to a post.

Leave a Reply