Skip to Content

As announced in the SAP Cloud Platform release notes, from 18th January 2018, Java 6 (SAP JVM6) will not be supported in the Neo environment. You will not be able to deploy applications with Java 6 using any of the existing deploy methods. In addition, SAP JVM6 is removed for download from the SAP Development Tools Web site.

Most probably, your application has already been migrated to a higher Java version. However, your application may still be using Java 6/SAP JVM 6 if:

  • You have deployed specifying explicitly Java version 6 or
  • You have deployed specifying explicitly a runtime version released earlier than March 2017 or
  • You have deployed your application before March 2017 using runtime Java Web or Java EE 6 Web Profile

You can check the Java version/JVM used by your application using the display-application-properties command in the console client for the Neo environment. For more information, see display-application-properties.

If you have an application that is running with SAP JVM 6 you must redeploy it. This will automatically switch to SAP JVM 7.

Recommendation: We highly recommend that you switch to one of our latest runtimes in the Neo environment – Java Web Tomcat 8 and Java EE 7 Web Profile TomEE 7

Tip: If you have an application compiled with Java 6 you will be able to run it with Java 7, as Java 7 is backwards compatible.

The supported Java versions for the different runtimes are as follows:

Profile Provides support for Supported Java versions Use
Java Web Tomcat 8 Some of the standard Java EE 7 APIs (Servlet, JSP, EL, Websocket) 8 (default); 7 If you need a simplified Java Web application runtime container based on Apache Tomcat 8.
Java Web Tomcat 7 Some of the standard Java EE 6 APIs (Servlet, JSP, EL, Websocket) 7 (default); 8 If you need a simplified Java Web application runtime container based on Apache Tomcat 7.
Java EE 7 Web Profile TomEE 7 Java EE 7 Web Profile APIs 8 (default); 7 If you need an application runtime container together with all containers defined by the Java EE 7 Web Profile specification.
Java EE 6 Web Profile Java EE 6 Web Profile APIs 7 (default) If you need an application runtime container together with all containers defined by the Java EE 6 Web Profile specification.
Java Web Some of the standard Java EE 6 APIs (Servlet, JSP, EL, Websocket) 7 (default)

Restriction

This runtime is deprecated. Support will be discontinued after 31th December 2017. We recommend using Java Web Tomcat 8. For more information, see Java Web (Migrating to Java Web Tomcat section).

If you have concerns, please create a ticket in component BC-NEO-RT-JAV.

If you need a small standalone Java Web container.

 

To report this post you need to login first.

Be the first to leave a comment

You must be Logged on to comment or reply to a post.

Leave a Reply