Skip to Content

There are lots of threads and blogposts regarding appcrashes of “Universe Design Tool” as part of SAP BusinessObjects Business Intelligence platform.

This blogpost should be a summary of steps for troubleshooting.

Problem:

Universe Design Tool crashes by defining a new connection and clicking “Next” in the “New Connection Wizard”:

Solution(s):

1.) Try to define a new connection in “Quick Design Wizard”

In our case the solution was trying to create a connection in “Quick Design Wizard” (that opens at first time application startup).

Through this way, Universe Design Tool did not crash and we reached the “Database Middleware Selection” Screen.

After that we also were able to define the connection through the way as shown in the “Problem” part.

So try to use “Quick Design Wizard” instead of “New Connection Wizard”. That should be done only once, then both ways are working (Bug?).

 

  • Use “Tools – Options” to reactivate “Welcome Wizard”:

 

  • After restarting the “Universe Design Tool” the “Quick Design Wizard” opens:

2.) Check communication ports

Regarding “Business Intelligence Platform Administrator Guide”, for communication 4 ports are necessary:

  • CMS Name Server Port
  • CMS Request Port
  • Input FRS Request Port
  • Connection Server Port

Not mentioned in Admin Guide:

  • Adaptive Processing Server Ports

-> Check the communication of all ports (including the Adaptive Processing Server Ports)

e.g.

telnet [BI Platform Server IP] 6400

-> If there is no communication, check your OS- and network-Firewall rules.

 

Note:

If you did not change the settings, request ports are auto assigned.

It is recommended to use fixed ports, as you can configure them in Central Management Console (CMC) server list:

 

You are welcome to expand the list in the Comment part.

To report this post you need to login first.

Be the first to leave a comment

You must be Logged on to comment or reply to a post.

Leave a Reply