Skip to Content

Oie Pessoal!

No final de 2017 está planejado o final da Mainstream Maintenance do Application Server Java do NetWeaver 7.0 ( incluindo EhP’s 1,2 e 3 do NW 7.0 ).

Devido a não existência de manutenção ( correções, patches, support packages ) e atualizações para novas tecnologias é recomendado o upgrade antes da data final de manutenção a fim de garantir estabilidade e segurança para o sistema.

Abaixo segue uma tabela especificando a manutenção do NW 7.0. Vale ressaltar que o NW 7.0 AS ABAP continua em manutenção até 2025, apenas o NW AS JAVA que tem a manutenção limitada em 31.12.2017.

Essa informação acima está disponível na SAP Note “1648480 – Maintenance for SAP Business Suite 7 Software”.

Mas o que tem isso a ver com a Nota Fiscal?

O NW 7.0 foi lançado em 2006 e a sua última versão (Ehp 3) foi lançado em 2012, período no qual a Nota Fiscal Eletrônica passou de projeto piloto a obrigatoriedade nacional para praticamente todas as empresas.

Nesse intervalo de tempo uma arquitetura muito comum por parte dos clientes foi Netweaver 7.0 Dual-Stack ( ABAP e JAVA ) junto com o PI e o GRC NFE ( que depois virou SAP NFE ) conforme a imagem abaixo:

Agora com o fim da manutenção do NetWeaver AS JAVA 7.0 esse tipo de arquitetura não teria mais respaldo por parte da SAP caso apareçam novos bugs no AS JAVA ou caso sejam necessários updates para novas tecnologias.

A recomendação para quem está rodando SAP NetWeaver 7.0x Java stack é planejar a sua migração antes do final da manuntenção em Dezembro de 2017. Além disso clientes com SAP NetWeaver 7.0x dual stack (ABAP e JAVA) precisam planejar também um split do ambiente dual stack caso desejem fazer upgrade para o NW 7.5, pois a partir desta versão os sistemas dual stack não são mais suportados.

Neste caso a principal opção de upgrade seria o uso do SAP PI/NW 7.5 Dual Usage com a seguinte arquitetura:

Existem outras possibilidades de upgrade, porém elas não trazem as mesmas vantagens da atualização para um ambiente mais novo. Um exemplo de outra possibilidade é a utilização do SAP PI/NW 7.4 Dual Stack com a seguinte arquitetura:

Mais detalhes sobre upgrades e funcionalidades possíveis em cada versão do PI estão disponíveis na SAP Note “1515223 – SAP Process Integration and SAP Process Orchestration: Release Recommendation”.

 

FAQ:

Existem outras possibilidades de deploy além das mencionadas no post?

Sim, existem várias possibilidades como por exemplo criar uma instalação nova de PI do zero, conectar o SAP NFE com um PI corporativo que já esteja atualizado.  Na nota abaixo existem alguns detalhes importantes sobre interoperabilidade entre sistemas que devem ser levadas em consideração no planejamento da arquitetura a ser utilizada, SAP Note “2200904 – Version Interoperability for Business Suite 7i2016“.

 

Tenho um SAP NFE em um NW 7.0 ABAP e tenho uma instalação de PI separada, preciso fazer upgrade do SAP NFE ou do NW do SAP NFE?

A manutenção da Stack ABAP do NW 7.0 continua até 2025, então não é obrigatório o upgrade do NW 7.0 ABAP embora seja recomendado.

 

Preciso subir o Support Package do SAP NFE durante esse upgrade?

Não, mas é recomendado para atualizar o sistema em relação a novas mudanças legais e melhorias de processos desenvolvidos.

 

Preciso testar a NFE 4.0 neste ano, preciso fazer upgrade do NW 7.0 do PI para ter suporte ao TLS 1.2?

Para ter suporte ao TLS 1.2 não é necessário o upgrade, pois o NW AS JAVA 7.0x oferece suporte ao TLS 1.2 utilizando um workaround, basta utilizar o arquivo SCA da “SAP note 2284059” e extrair ambos os jars iaik_ssl.jar e w3c_http.jar do DEPLOYARCHIVES-sap.com~mail_activation_iaik.sda (sda e sca são zip zip), copiar para o diretorio ./j2ee/cluster/server0/bin/ext/tc~sec~ssl/ do seu servidor 7.0x . Sem considerar este workaround o TLS 1.2 só estará incluído nos patches de 2017 (ainda a serem lançados) do NW AS JAVA 7.0x.

Porém este workaround não é suficiente para a implementação da NFe 4.00 pois os PI contents entregues este ano serão criados somente para versões mais novas do NW ( NW AS JAVA 7.10 e superiores).

 

Tenho um PI Dual Stack 7.0 e gostaria de transformá-lo em um PI 7.5 AEX, é possível?

Conforme informado na SAP Note  “2190371 – Configuration Wizard: PI Split” no tópico 7 esse processo não é possível via upgrade, o sistema após o Split terá o ABAP conectado ao JAVA  e desta forma não é possível descartar a stack ABAP.

 

Sou funcional e não sei como olha a versão do PI, o que eu faço? 

Chama o BASIS!

Ou então acessa o sistema PI e faz o seguinte passo a passo:

1- Clica em system e depois em status:

2- Procura a versão do produto:

3- Pode confirmar os detalhes de SP da release olhando na “lupa” o seguinte componente:

4- Depois disso, se o release for 700, 701, 702 ou 703 então chama o BASIS e mostra esse blog post.

 

att,

Renan Correa

To report this post you need to login first.

10 Comments

You must be Logged on to comment or reply to a post.

  1. Marcus Farias

    Renan.

    Posso atualizar toda a minha estrutura de portal, NFe e continuar com meu ECC6 normalmente, ou terei que migrar o ECC6 para alguma versão mais nova (EHPX ou até mesmo Hana)?

    Sabe de algum caso desses?

    abraços e obrigado.

    Marcus Farias.

    (0) 
    1. Renan Correa Post author

      Oi Marcus,

       

      Em relação ao Portal vou ficar devendo, pois realmente não sei. A comunicação do NFE com o ERP ocorre entre RFC’s no ABAP, então do lado da NFe não tem incompatibilidade nenhuma.

       

      Sei de vários clientes que atualizaram o ambiente PI ou instalaram PI JAVA e continuam comunicando normalmente com ECC antigo.

       

      att,

      Renan Correa

       

      att,

      Renan Correa

      (0) 
  2. Luiz Horta

    Com relação a licença, temos que fazer um upgrande também ou podemos seguir com a atualização normalmente!?

     

     

     

    (0) 
    1. Renan Correa Post author

      Oi Luiz,

      Em relação aos tópicos comerciais não sei te confirmar isso. Precisaria entrar em contato com o executivo comercial que atende a sua empresa para esclarecer este ponto.

      att,

      Renan Correa

      (0) 
  3. Clerio Rios

    Renan,

     

    Fiquei com uma duvida, em relação ao desenho que vc colocou  SAP PI/NW 7.5 Dual Usage , vai existir ainda a instancia ABAP, pois pelo que fiquei sabendo só precisaria da instancia JAVA.

     

    Att

     

    Cléo

    (0) 
    1. Renan Correa Post author

      Oi Cléo,

       

      Se você possui um PI Dual Stack e decidir por upgrade os caminhos possíveis são 7.4 Dual Stack ou o 7.5 Dual Usage. Não é possível partir de um PI Dual Stack e via upgrade chegar em um PI somente Java.

       

      Se você decidir por uma instalação nova então é possível usar um PI somente JAVA, pois a NFE possui cenários AEX, que não utilizam ccBPM, e portanto não precisam de um NW ABAP.

       

      Outro detalhe, mesmo que você tenha um PI 7.4 Dual Stack ou 7.5 Dual Usage é possível usar os cenários AEX e utilizar somente a parte java para a emissão de NFe.

       

      att,

      Renan Correa

      (0) 

Leave a Reply