Skip to Content

With the HANA Rules Framework (HRF) in my bag, I was wondering whether I could elevate my HANA, express edition to the next level and enable Operational Process Intelligence (OPI) that needs HRF as a prerequisite.

As it turned out, this was again quite straight forward:

  1. Download and install the delivery units
  2. Configure OPI
  3. Install Eclipse Business Scenario and Workflow Editor plugins
  4. Model Business Scenario

To start with, I download the software:

  1. PROCESS WORKSPACE 1.0
  2. TASK MANAGEMENT ON HANA 1.0
  3. WORKFLOW ON HANA 1.0

Please ensure to check SAP Note 2029252 – Compatibility information for SAP HANA and SAP Operational Process Intelligence for the correct SPS and Patch Level. For my upgraded HANA, express edition, I need SPS 13 PL 1 but for the out of the box version, I would have needed SPS 13 PL 0:

The installation can take a few minutes:

But eventually finishes successfully:

I then assign my HRF SYSTEM user the sap.opi.pv.roles:OPINTADMIN role:

To launch the administration cockpit at http://<host>:<port>/sap/opi/pv/workspace/#/administrationcockpit:

Of course, my Configuration is incomplete yet:

But the Administration Cockpit, this is easy to correct:

At least to a Minimally configured state:

To enable modelling in Eclipse, I install the OPI plugins:

Again, ensure to check SAP Note 2029252 – Compatibility information for SAP HANA and SAP Operational Process Intelligence for the correct HANA Studio version and confirm the installation details:

The download and installation can take a while:

Once finished, I model my first Business Scenario:

To report this post you need to login first.

1 Comment

You must be Logged on to comment or reply to a post.

  1. Former Member

    Hi Frank,

    Thanks for nice post .

    Need help in setting up Eclipse-HANA Studio for SAP operational intelligence development.

    Our HANA system Revision level is SPS12 , 122.11 and OPINT is SPS13 Patch level 5 .

    Also Eclispe version I am using is oxygen 2 release (4.7.2)

    As per this note 2029252 , we are using the HANA studio and the version is 2.3.25 .

    But when we try to add the operational intelligence plugins using the Update site URL, business scenario editor is not getting installed and we are getting the below error. Could you please help me to solve this issue.

    Cannot complete the install because of a conflicting dependency. Software being installed: Business Scenario Editor 1.13.0 (com.sap.pv.opm.hdb.modeler.feature.feature.group 1.13.0) Software currently installed: Eclipse Platform 4.7.2.v20171130-0510 (org.eclipse.platform.feature.group 4.7.2.v20171130-0510) Only one of the following can be installed at once: File Buffers 3.6.100.v20170203-1130 (org.eclipse.core.filebuffers 3.6.100.v20170203-1130) File Buffers 3.5.500.v20140723-1040 (org.eclipse.core.filebuffers 3.5.500.v20140723-1040) Cannot satisfy dependency: From: Business Scenario Editor 1.13.0 (com.sap.pv.opm.hdb.modeler.feature.feature.group 1.13.0) To: org.eclipse.core.filebuffers [3.5.500.v20140723-1040] Cannot satisfy dependency: From: Eclipse Platform 4.7.2.v20171130-0510 (org.eclipse.platform.feature.group 4.7.2.v20171130-0510) To: org.eclipse.core.filebuffers [3.6.100.v20170203-1130]

    Thanks in Advance.

    Regards,

    Siva Kumar

    (0) 

Leave a Reply