Skip to Content

Now that I’m back from TechEd Vegas and getting thrown by the bull, I finally was able to spend some time getting to know HANA Express.

 

I’m super impressed with how snappy my XS-Advanced development now feels on my Macbook 16GB running VMWare Fusion.

 

The VM seems to about 12GB of my Mac so there is still enough for basic OSX function while my HANA VM is up and running.

 

One of the first things I wanted to do was test some sample MTAs which led me to wanting to pull some Git repos.

 

Alas, the git client doesn’t seem to be on the system(correct me if I’m wrong here) so I went about getting it.

 

Since the base OS of HANA Express is Enterprise SuSe 12 SP 1, I went to use trusty zypper package manger to get my git.

 

I then quickly discovered that no zypper repos were set up either.  The following steps got me to git nirvana.

 

Hope this post is helpful, but YMMV!

 

-Andrew

 

 

// Get a root console

sudo /bin/bash

 

// Using the new SuSe LEAP Repos
// (Note that this is a closer match to the base OS and should be more stable.)

zypper addrepo -f http://download.opensuse.org/distribution/leap/42.1/repo/oss/ oss
zypper addrepo -f http://download.opensuse.org/distribution/leap/42.1/repo/non-oss/ non-oss
zypper addrepo -f http://packman.inode.at/suse/openSUSE_Leap_42.1/ packman
zypper install git-core

 

// Using the OpenSuSe repos
// (More experimental so be careful)
zypper ar -f http://download.opensuse.org/distribution/12.1/repo/oss/ oss
zypper ar -f http://download.opensuse.org/distribution/12.1/repo/non-oss/ non-oss
zypper ar -f http://download.opensuse.org/update/12.1/ update
zypper ar -f http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_12.1/ packman
zypper update
zypper addrepo http://download.opensuse.org/repositories/devel:/tools:/scm/SLE_12_SP1/devel:tools:scm.repo
zypper addrepo http://download.opensuse.org/repositories/devel:languages:perl/SLE_12_SP1/devel:languages:perl.repo
zypper refresh
zypper install perl-Error
zypper install git-core
To report this post you need to login first.

1 Comment

You must be Logged on to comment or reply to a post.

Leave a Reply