Skip to Content

While deploying the extension on Cloud, you find that the add-on stays in ‘To Install’ status in Cloud Control Center. Below are the possible solution and troubleshooting steps:

  1. Restart SAP Business One Client Agent service on presentation server.
  2. If this add-on was deployed before, then clear this add-on from Cloud Control Center and presentation server. (CCC)

Recommended steps:

  1. Unassign add-on from the Tenants.
  2. Undeploy add-on from service units times.
  3. Remove extension from CCC.
  4. Clear add-on from presentation server:
  5. Delete add-on folder from “C:\Program Files (x86)\SAP\SAP Business One\AddOns”
  6. Delete add-on relevant information in “C:\Program Files (x86)\SAP\SAP Business One\AddOnsLocalRegistration.sbo”. If you have only one add-on, you can just delete it. It will be created again.
  7. Put the extension in incoming\provider folder.
  8. Sync extension.
  9. Deploy service unit.
  10. Assign Tenants.
  11. Restart Client Agent service on presentation server if showing To install status.
To report this post you need to login first.

5 Comments

You must be Logged on to comment or reply to a post.

  1. 景璐 韩

    hi Ankit,

    I follow your recommendation, but I got now installation failure after several times. And I cannot open the SBO client on presentation server, it tells no company, then stopped.

    I m logging as an cloud operator, which is defined as a local administrator.

    many thanks,

     

    Jinglu Han

     

    (0) 

Leave a Reply