Skip to Content

Error in DTW- Could not load file or assembly ‘ADODB’ on B1 cloud 9.1PL8/9.2PL3

Dear All

 

Today, SAP support and I solve the topic issue.

 

I would like to share for yours.

 

Here are some steps that we solve the DTW issue.

1.download .net framework 4.6.1 https://www.microsoft.com/en-us/download/details.aspx?id=49982

2.download Microsoft Office 2010: Primary Interop Assemblies Redistributable https://www.microsoft.com/en-us/download/details.aspx?id=3508

3. uninstall .net framework, diapi & dtw

4. install the above .net framework 4.6.1

5. install the above Microsoft Office 2010: Primary Interop Assemblies Redistributable

6. check the adobe.dll in C:\Program Files (x86)\Microsoft.NET\Primary Interop Assemblies\

7. install diapi 32 bit/64bit

8. install dtw 32 bit/64bit

Regards

Edmund

1 Comment
You must be Logged on to comment or reply to a post.
  • I also experienced this same challenge. It was caused by the fact that the “full” version of Excel was not installed. Instead, the Excel Viewer Only was installed.

    We solved this by executing the above steps, 2 and 5 only.