Hello,

Below are the step we have took to upgrade the Ariba Adapter.

Firstly Ariba adapter has its own components in the ABAP stack. Hence it can be upgrade more regularly independent of SAP upgrades. SAP recommends us to upgrade at least once every year.

1) Read the release document to identify what release level you would need to upgrade to or prefer to upgrade. The release information can be found on the What’s New – Release Notes section on the link below Know what are the new feature that are added and if there are newer version of xCML.

2) Read the Installation and Upgrade Information that is relevant for you. (SRM or ECC). Basis upgrade the ARBFNDI1, ARBFNDI2, ARBERPI1 by downloading the package using Solman or similar tools.

3) Follow the Administration guide which provides information about the configuration required. Once technical upgrade is complete. Validate new config that are added or changed.

Note: Be careful when changing mapping version.

e.g for cXML type ORDR the mapping version V002 doesn’t support subcontracting and you get the below error.

Mapping version.JPG

But if you change it to V003, then it will transmit Subcontracting PO without any other config needed.

Output.JPG

Once you upgrade and done necessary config done, test and move to changes to production. Unlike SAP upgrade which is a major work, Ariba Adapter upgrade is far simpler.

Reference portal Ariba Network Integration 1.0 for SAP Business Suite – SAP Help Portal Page

Happy upgrading. Like it, rate it, share it.

To report this post you need to login first.

Be the first to leave a comment

You must be Logged on to comment or reply to a post.

Leave a Reply