Skip to Content

SAP_UI 750 on top of SAP_UI 740

SAP_UI 750 on top of SAP NW 7.40

I had to upgrade my current SAP_UI which was on 740 to SAP_UI 750.

The reason I had to upgrade is because of the HR Renewal 2.0.

From the note 1976498 – HRSP Information for HR Renewal 2.0, http://service.sap.com/sap/support/notes/1976498 SAP suggested that the UI dependencies changes with HRSP 28 from SAP_UI 740 to SAP_UI 750.

See note 2217489 Maintenance and Upgrade Strategy for UI Add-On and User Interface Technology.

So here is the simple upgrade process of the SAP_UI.

From the MOPZ, It is visible from OS/DB Dependent files:

/wp-content/uploads/2016/05/1_954301.jpg

Download the XML file

Use SAINT to perform the Upgrade.

/wp-content/uploads/2016/05/2_954308.jpg

Hope this help, the catch is SAP suggested that the UI dependencies changes with HRSP 28 from SAP_UI 740 to SAP_UI 750. so if you are on SP 28, some functionalities that UI services may not work the way they should, so the upgrade is suggested.

Regards,

Sebastian

5 Comments
You must be Logged on to comment or reply to a post.
  • Good information Sebastian.

    Just one question: In MOPZ, step 2 (Select files) which option did you choose to select only SAP_UI? Support Package Stacks or Add-On products?

  • Hi Sebastian,

    having the same challenge here: NW740/ERP6 and SPAM says I will need SAP_UI 750 to upgrade the HR components.

    Unfortunately MOpz is no longer supported and Maintenance Planner wont let me choose to Upgrade SAP_UI by itself: I chose to upgrade ERP-Stack or NW-Stack Upgrade than added the SAP_UI 750 like you did. After calculation MP shows “OCS-Package SAPK-750BHINSAPUI passt nicht zum aktuellen Softwarekomponentenvektor” (OCS-Package … does not fit the current software component vector).

    Any hints on that?

    Regards and Thanks
    Daniel

  • Hello Daniel,

    We have got the same error message when we tried to update NW740 to latest SPS 17 in Maintenance Planner.

    The error is the same as in SAP_BASIS 740 SP16 to SP17 update.

    It requires  SAP_UI 740 SP18, but SAP_UI 740 SP18 has no equivalent SP for SAP_UI 750.

    Equivalent SP of SAP_UI 740 SP18 is SAP_UI 750 SP08 and it is unreachable now.

     

    Br.,

    Les

    • Hi Les,

      I’m facing the same issue. Were you abel to get it resolved?

      On my SolMan SAP_UI 750 SP 0007 is installed but the update of SAP_BASIS 740 SP16 to SP17 is looking for depended SAPK-74018INSAPUI

      Cedric