Skip to Content

Supported IDEs

Currently supported IDEs for the last 3 major versions of SAP Advantage Database Server are below:


IDEs 10.1 (A) 11.1
12.0
Delphi 6.7 (TDataSet) Y N N
Delphi 2006 Y N N
Delphi 2007, 2009 Y Y Y
Delphi Prism Y Y Y
Delphi 2010 Y Y Y
Delphi XE Y Y Y
Delphi XE2 Y (B) Y Y
Delphi XE3 Y (C) Y Y
Delphi XE4 Y (D) Y (E) Y
Delphi XE5 Y (F) Y (G) Y
Delphi XE6 N Y (H) Y
Delphi XE7 N Y (I) Y
Delphi XE8 N Y (O) Y
Delphi 10 Seattle N Y (P) Y (Q)
CBuilder 2007 & Newer Y Y Y
Lazarus Y (J) Y (J) Y (K)
Visual Studio 2005 Y Y N
Visual Studio 2008 Y Y N
Visual Studio 2010 Y Y Y
Visual Studio 2012 N Y Y
Visual Studio 2013 N Y (O) Y
Visual Studio 2015 N Y (P) Y (Q)
Visual Objects 2.7 Y Y Y
Visual Objects 2.8 Y Y Y
Vulcan.NET 3.0 Y Y Y
Vulcan.NET 4.0 N Y (P) Y (Q)
Clipper (L) Y Y N
Visual FoxPro 9 (M) Y Y Y
Servoy13 Y Y Y
Phyton/Django Y (N) Y Y
Ruby Y (N) Y Y
Crystal Reports 6 – 10 Y N N
Crystal Reports 11 & 2008 Y Y Y

Key:      
Y – Supported                     
N – Not Supported             

(A) End of life version
(B) Version 10.10.0.28 or newer

(C) Version 10.10.0.44 or newer

(D) Version 10.10.0.49 or newer

(E) Version 11.10.0.10 or newer

(F) Version 10.10.0.51 or newer

(G) Version 11.10.0.14 or newer

(H) Version 11.10.0.20 or newer

(I) Version 11.10.0.22 or newer

(J) Lazarus 0.9.28.2 or newer

(K) Lazarus 1.0 or newer

(L) The Clipper RDD has not been changed since version 7.0

(M) Support for all data types

(N) Version 10.10.0.6 or newer

(O) Version 11.10.0.24 or newer

(P) Version 11.10.0.30 or newer

(Q) Version 12.0.0.1 or newer

3 Comments
You must be Logged on to comment or reply to a post.