OS: Windows 7 Professional

System Type: 32-bit operating system

Restrictions:

1. Cannot use SAP Web IDE on HANA Cloud Platform due to a highly secured network. Cloud technology or connection to internet not allowed

2. Cannot use SAP Web IDE on-premise (local installation) due to system type: 32-bit operating system


Solution: Use Eclipse Luna for Fiori, SAPUI5 and OData service development

Installation procedure

1. Download Java version 7

2. Remove other version of Java and Instal Java version 7 (1.7)

3. Perform a new Eclipse installation in your system – Eclipse Java EE Luna SR2

Note: If the installation is not completely new, the toolkit installation will fail because of clashing Graphiti versions.  Add an additional update site for the Graphiti plugin before starting the installation.

4. Download Eclipse Graphiti for Juno release 0.9.1

5. From the menu bar, choose Help > Install new software. The Available Software page is displayed.

6. Click Add. The Add Repository page is displayed.

7. In the Name field, enter a name for the Graphiti plugin.

8. In the Location field, enter http://archive.eclipse.org/graphiti/updates/0.9.1 or Browse for the download graphiti ZIP file and click OK.

9. Select the Contact all update sites during install to find required software checkbox.

10. After the installation restart eclipse.

11. Then next is the HANA tools update site To add the update site:

12. Start Eclipse.

13. From the menu bar, choose Help > Install new software. The Available Software page is displayed.

14. Click Add. The Add Repository page is displayed.

15. In the Name field, enter a name for the repository.

16. In the Location field, enter https://tools.hana.ondemand.com/juno

17. Click OK.

18. Select the UI Development Toolkit for HTML5 checkbox

19. Select the Contact all update sites during install to find required software checkbox.

20. After the installation restart eclipse.

21. You must download the SAP Fiori toolkit installation file available at the SAP Developer Network site: SAP Fiori toolkit installation zip

22. Start Eclipse.

23. From the menu bar, choose Help > Install new software. The Available Software page is displayed.

24. Click Add. The Add Repository page is displayed.

25. In the Name field, enter a name for the repository.

26. In the Location field, search for the SAP Fiori toolkit ZIP Archive file

27. Click OK.

28. Select All the SAP Fiori toolkit

29. Select the Contact all update sites during install to find required software checkbox.

30. After the installation restart eclipse.

31. Start Eclipse.

32. From the menu bar, choose Help > Install new software. The Available Software page is displayed.

33. Click Add. The Add Repository page is displayed.

34. In the Name field, enter a name for the repository.

35. In the Location field, enter https://tools.hana.ondemand.com/juno

36. Click OK.

37. Select the GWPA – SAP Netweaver Gateway Productivity Accelerator

38. Select the ABAP Development Tools for SAP Netweaver

39. Select the Contact all update sites during install to find required software checkbox.

40. After the installation restart eclipse.

Eclipse Luna using SAP Fiori toolkit should now be working

To report this post you need to login first.

3 Comments

You must be Logged on to comment or reply to a post.

    1. Kenzi Sibuma Post author

      Hi Jun Wu,

      When you are in actual client sites and they have a highly secured network and will not allow internet connection, you cannot use the latest and the greatest SAP Web IDE on HCP for Fiori development which is the current available tool for production.

      For the other option to use SAP Web IDE on-premise, the authorized and highly secured laptop for development is 32-bit but SAP did not release a 32-bit version of the SAP Web IDE local installation.

      When you are doing consulting you will know that the best scenarios or best practice proposed by SAP will not always be applicable to customers, thus the only option is to use the deprecated version.

      (0) 

Leave a Reply