Skip to Content

We recently migrated our SAP Sourcing system from hosting to on-premise.

SAP Sourcing 10 SP 07 on Oracle

Operating System :- Windows

Here We have changed the UME to be configured to SAP Netweaver unlike LDAP which was there in hosting. But we have an issue like whenever a new user was created in sourcing the first name , last name and email address were not getting populated into SAP Netweaver UME.

The internal directory configuration is the setup object that allows the configuration of the authentication method to be used by internal (supplier-side) users. It can be NetWeaver UME or one of the supported LDAPs. It is necessary that the users in the UME or LDAP have the same usernames as the users in SAP Sourcing. You can achieve this by pushing the user accounts from SAP Sourcing to the UME or LDAP, or by pulling them from the UME or LDAP to SAP Sourcing. Select Push or Pull in the Edit Mode field on Attributes Mapping tab, as appropriate. We have created the directory configuration like below

RETAIN.jpg

Below were the attribute mappings

ScreenHunter_001.jpg

Resolution:-

I changed the directory configuration and changed the Directory ID like below :-

Attributes Mapping Tab

Local ID: NAME

Mapped ID: uniquename

Local ID: EMAIL

Mapped ID: email

Local ID: FIRST_NAME

Mapped ID: firstname

Local ID: LAST_NAME

Mapped ID: lastname

ScreenHunter_002.jpg

Now when I checked user admin page in netweaver it shows me that first name , last name and email id of the user created in the sourcing have been pushed to the netweaver UME. However for already created users you just have to do a minor modification and save it. It will be pushed after that.

To report this post you need to login first.

Be the first to leave a comment

You must be Logged on to comment or reply to a post.

Leave a Reply