SAP API Management Cloud Edition is now available on HANA Cloud Platform Trial. You can do a free test drive to expose your data and processes as APIs.

SAP API Management helps customer share digital assets and processes and enables developer communities to consume digital assists with ease in new channels, devices and user interfaces.

SAP API Management Cloud Edition is generally available to customers since July 2015.

How to get access?

Access to SAP API Management can be found in HCP Trial Account in Services tab under Integration category.

/wp-content/uploads/2016/02/tile_879227.png

Select “SAP API Management” service and enable it

/wp-content/uploads/2016/02/sapapimservice_879228.png

SAP API Management Cloud edition, once enabled will provide you access to an instance of API Portal and Developer Portal.

/wp-content/uploads/2016/02/sapapimservicenabled_879229.png

API Portal allows you to publish APIs in a secure and scalable manner and helps monitor and manage the APIs.You can access your API Portal by clicking on the link “Access SAP API Management API Portal

/wp-content/uploads/2016/02/apiportal_879230.png

Developer Portal allows you to explore and consume the APIs exposed via SAP API Management. You can access your Developer Portal by clicking on the link “Access SAP API Management Dev Portal

/wp-content/uploads/2016/02/devportal_879231.png

More details on SAP API Management is available in SCN community

To report this post you need to login first.

44 Comments

You must be Logged on to comment or reply to a post.

    1. Nick Warren

      Hi David,

      Was there anything that you changed on your HPC Trial before retrying? I am getting the same issue and I can’t even find a logfile that might point me in the right direction.

      Kind Regards

      Nick

      (0) 
      1. Holger Bruchelt

        Hi Nick,

        so you see the SAP API Management tile on HCP Trial as “Not Enabled”, but when you click on it nothing happens? Do you get any error messages or any other feedback?

        Regards,

        Holger.

        (0) 
          1. Holger Bruchelt

            Hi Nick,

            just FYI for others. We fixed the issue and now it should work. If others have similar problems, please leave a comment or contact me.

            Regards,

            Holger.

            (0) 
            1. Nick Warren

              Hi Holger (and others),

              Thanks for your quick support getting me sorted. It’s all working and I’ve got your first GWSAMPLE_BASIC demo up-and-running. Looking forward to further tutorials from you and your team.

              Kind Regards

              Nick

              (0) 
    1. Holger Bruchelt

      Hi Rajiv

      Sorry to hear that. Can you try two more times to activate? Sometimes it does not work on the first try. If it still does not work let me know and I will follow up.

      Holger

      (0) 
        1. Holger Bruchelt

          Hi Midhun,

          could you please try again? We were just making some changes this morning which might have affected your activation.

          Regards,

          Holger.

          (0) 
      1. Rajiv Asher

        Hello Holger,

        I continue to have same problem with activation – ‘Failed’ message. Can you please check. For account: p15789838trial.

        Thanks.

        Rajiv

        (0) 
  1. Alberto Orozco

    Hi Holger,

    I´m having the same error “failed” when I try to enable the service, can you please check for account p1942041644.

    Regards

    Alberto Orozco

    (0) 
  2. Ed ED

    Hi Holger,

    I´m having the same error “failed” when I try to enable the service, can you please check for account p1268171346

    SAP_API_MNG_FAILED.PNG.

    Regards

    Edriss

    (0) 
      1. Ed ED

        Hi Holger,

        Now SAP API management service,It’s working fine.

        But i have some issues when i open the dev portal.

        -> popup : Error in fetching resources

        -> popup : Error in fetching all packages and actions

        in the networks debug screen i see 2 requests with

        1. Status Code:500 Internal Server Error

        Operation failed due to a database issue; contact your system administrator for details


        https://devportalu34f5b50f-p1268171346trial.hanatrial.ondemand.com/odata/1.0/data.svc/Catalog.CatalogResources?&$orderby…

        https://devportalu34f5b50f-p1268171346trial.hanatrial.ondemand.com/odata/1.0/data.svc/Catalog.CatalogResources?&$orderby…

        Could you help me please ?

        Regards,

        Edriss.

        (0) 
        1. Holger Bruchelt

          Hi Edriss,

          is the API Portal working for you? I am checking with our developer colleagues to see what happening in your Developer Portal.

          Regards,

          Holger.

          (0) 
          1. Ed ED

            Hi Holger,

            do you have some news about the issues on the Api dev portal ?

            I would like consume my api service from app fiori. How can i do that without the dev portal ?

            Thanks for your return.

            Best regard.

            Edriss

            (0) 
            1. Elijah Martinez

              Hi Edriss,

              Sorry that your developer portal is still down. If you wish to consume an API service from a Fiori app without specifically going through developer portal, you can simply point the app to the API Proxy URL as your destination. If you are running the app on HCP you may create a destination within HCP cockpit, pointing directly to your API endpoint, and then point the App to that destination.

              If you wanted to generate the app in WebIDE for example, to deploy on HCP to consume from API management you could  generate a destination similar to this one:

              /wp-content/uploads/2016/07/example_destination_999500.png

              (0) 
  3. Oliver Otto

    Hi Holger,

    I am also having problems activating the Api Management Service on my Trial HCP (s0014439378trial). Could you look into this topic?

    I have tried activating it multiple times over the last few weeks without success.

    Kind regards

    Oliver

    /wp-content/uploads/2016/07/apimgmt_1004648.png

    (0) 
  4. Russ Wagner

    I am also getting the “Failed” message while trying to enable the API Management Service. Is there a solution yet?  I don’t feel comfortable posting my “s…trial” account number in this forum unless I have to.  Thanks.

    (0) 
    1. Russ Wagner

      Hi Holger:  Just got your message, but no email to send my account number to.  Do you want me to post it here, or will you send me a email to send it to.

      Thanks for the quick response.

      Russ

      (0) 
  5. Abhishek Subramanya

    Hi Folks,

                  I have added my comment some time ago but looks like it is not approved by moderators.I am facing the same issue. Can you please help me out?

    Thanks,

    Abhishek

    (0) 
    1. Elijah Martinez

      Hi Tim,

      If you have not yet done so, please try once again to Enable. A lot of work has gone into making the enablement successful, but there are always a few cases where something slips through. If you have tried Enabling your account 3 or more times already, please provide your S,P,I or D Number and we can look into what went wrong.

      If you do not feel comfortable providing it on SCN, feel free to send it to sapapimanagementinfo@sap.com via email

      (0) 
  6. Victor van Iren

    I was able to enable API Management, but when i go to the API Management portal i get the error message “There is a temporary problem in provisioning your account, please try again by clicking on Retry.” This is going on for some time now.

    Anyone had this issue before?

    (0) 
  7. Nicholas Kubiak

    I have this activated on my trial account and am able to use the endpoint but there are not any usage statistics showing up. Is this a trial limitation or am I supposed to be seeing general stats (i.e. calls, errors, etc) with/without any additional configuration? All the documentation I’ve seen implies that general stats should be available without any additional setup.

    I can ping the service via the provided API management URL so I know the service itself is working and API management is routing it correctly.

    (0) 
  8. Jan Almkvist

    Hi

    I am trying to Create an API based on SOAP but as soon as I try to add a Resource I get “Unable to register API” and [Request ID: 0ef2d71f-cf76-4818-a1bb-c543d1235f0e]
    String index out of range: 0

    Any idea?

    Jan Almkvist

     

     

    (0) 

Leave a Reply