Skip to Content
Product Information
Author's profile photo Divya Mary

Free Trial of SAP API Management on SAP Cloud Platform is available now!

SAP Cloud Platform API Management is now available on SAP Cloud Platform Trial. You can do a free test drive to expose your data and processes as APIs.

SAP API Management helps customer share digital assets and processes and enables developer communities to consume digital assists with ease in new channels, devices and user interfaces.

SAP Cloud Platform API Management is generally available to customers since July 2015.

How to get access?

Access to SAP Cloud Platform API Management can be found in SAP Cloud Platform trial in the Neo environment.

To access Neo Environment, scroll down and select Access Neo Trial

 

API Management is available under Services tab under Integration Suite category.

Select “API Management” service and enable it

Note:- The status would change to processing while service is being enabled in the background. This step might take few minutes.

SAP API Management, once enabled will provide you access to an instance of API Portal, Developer Portal, API Designer.

After SAP Cloud Platform API Management service is enabled, status would change to Enabled and links under Take Action section would be enabled. To complete on-boarding process on SAP Cloud Platform API Management, you would have to log on to API Portal. Click link Access API Portal to open API Portal in a new browser tab.

Wait while your SAP Cloud Platform API Management account is being provisioned.

API Portal allows you to publish APIs in a secure and scalable manner and helps monitor and manage the APIs. After successful activation of SAP Cloud Platform API Management – API Portal service, you would be redirected to Welcome or Landing page of API Portal.

 

 

Developer Portal allows you to explore and consume the APIs exposed via SAP API Management. You can access your Developer Portal by clicking on the link “Access Developer Portal

More details on SAP API Management is available in SCN community

Assigned tags

      47 Comments
      You must be Logged on to comment or reply to a post.
      Author's profile photo David Greengas
      David Greengas

      I saw it in the list under integration, but it failed when I tried to enable it.

      *** Update: Tried again and it suddenly worked ***

      Author's profile photo Nick Warren
      Nick Warren

      Hi David,

      Was there anything that you changed on your HPC Trial before retrying? I am getting the same issue and I can't even find a logfile that might point me in the right direction.

      Kind Regards

      Nick

      Author's profile photo Former Member
      Former Member

      Hi Nick,

      so you see the SAP API Management tile on HCP Trial as "Not Enabled", but when you click on it nothing happens? Do you get any error messages or any other feedback?

      Regards,

      Holger.

      Author's profile photo Nick Warren
      Nick Warren

      Hi Holger,

      When I click on it, it comes back (after a few seconds of Processing) as Failed.

      Thanks

      Nick

      Author's profile photo Former Member
      Former Member

      Hi Nick,

      just FYI for others. We fixed the issue and now it should work. If others have similar problems, please leave a comment or contact me.

      Regards,

      Holger.

      Author's profile photo Nick Warren
      Nick Warren

      Hi Holger (and others),

      Thanks for your quick support getting me sorted. It's all working and I've got your first GWSAMPLE_BASIC demo up-and-running. Looking forward to further tutorials from you and your team.

      Kind Regards

      Nick

      Author's profile photo Former Member
      Former Member

      Holger, I am having the same issue in my trial. And the service is not showing at all in our non-trial tenant.

      Could you have a look?

      Regards,

      Ole

      Author's profile photo Former Member
      Former Member

      Hi Holger,

      I have the same issue in my trial - enabling API management fails.

      Regards,

      Ole Andre Schistad

      Author's profile photo Former Member
      Former Member

      Hi Ole,

      can you try again? It should work now.

      Regards,

      Holger.

      Author's profile photo Former Member
      Former Member

      Hi Holger,

      I have an error 'Failed' when I try to enable 'SAP API Management' using my trial account.

      Regards.

      Rajiv

      Author's profile photo Former Member
      Former Member

      Hi Rajiv

      Sorry to hear that. Can you try two more times to activate? Sometimes it does not work on the first try. If it still does not work let me know and I will follow up.

      Holger

      Author's profile photo Midhun VP
      Midhun VP

      Hi Holger,

      I could see a similar error when I try to enable it.

      /wp-content/uploads/2016/05/2016_05_19_15_21_23_956215.jpg

      Regards, Midhun

      Author's profile photo Former Member
      Former Member

      Hi Midhun,

      could you please try again? We were just making some changes this morning which might have affected your activation.

      Regards,

      Holger.

      Author's profile photo Former Member
      Former Member

      Hello Holger,

      I continue to have same problem with activation - 'Failed' message. Can you please check. For account: p15789838trial.

      Thanks.

      Rajiv

      Author's profile photo Former Member
      Former Member

      Hi Rajiv,

      sorry to hear! We are looking into this!

      Holger.

      Author's profile photo Former Member
      Former Member

      Hi Rajiv,

      can you try again? Now it should work for you.

      Regards,

      Holger.

      Author's profile photo Alberto Orozco
      Alberto Orozco

      Hi Holger,

      I´m having the same error "failed" when I try to enable the service, can you please check for account p1942041644.

      Regards

      Alberto Orozco

      Author's profile photo Former Member
      Former Member

      Hi Alberto,

      sure, I will look into this. In the meantime: can you give it some time and try again?

      Regards,

      Holger.

      Author's profile photo Alberto Orozco
      Alberto Orozco

      Hi Holger,

      Thanks by your support. I tried again without sucess.

      Regards

      Alberto

      Author's profile photo Former Member
      Former Member

      Hi Holger,

      I´m having the same error "failed" when I try to enable the service, can you please check for account p1268171346

      SAP_API_MNG_FAILED.PNG.

      Regards

      Edriss

      Author's profile photo Former Member
      Former Member

      Hi Ed,

      can you try to enable it again? In parallel we are looking into this issue.

      Regards,

      Holger.

      Author's profile photo Former Member
      Former Member

      Holger,

      I tried to enable it again. It's not working.

      Regards,

      Edriss

      Author's profile photo Former Member
      Former Member

      Hi Holger,

      Now SAP API management service,It's working fine.

      But i have some issues when i open the dev portal.

      -> popup : Error in fetching resources

      -> popup : Error in fetching all packages and actions

      in the networks debug screen i see 2 requests with

      1. Status Code:500 Internal Server Error

      Operation failed due to a database issue; contact your system administrator for details


      https://devportalu34f5b50f-p1268171346trial.hanatrial.ondemand.com/odata/1.0/data.svc/Catalog.CatalogResources?&$orderby…

      https://devportalu34f5b50f-p1268171346trial.hanatrial.ondemand.com/odata/1.0/data.svc/Catalog.CatalogResources?&$orderby…

      Could you help me please ?

      Regards,

      Edriss.

      Author's profile photo Former Member
      Former Member

      Hi Edriss,

      is the API Portal working for you? I am checking with our developer colleagues to see what happening in your Developer Portal.

      Regards,

      Holger.

      Author's profile photo Former Member
      Former Member

      Hi Holger,

      API Portal it's working fine for me.

      Thanks you.

      Author's profile photo Former Member
      Former Member

      Hi Holger,

      do you have some news about the issues on the Api dev portal ?

      I would like consume my api service from app fiori. How can i do that without the dev portal ?

      Thanks for your return.

      Best regard.

      Edriss

      Author's profile photo Elijah Martinez
      Elijah Martinez

      Hi Edriss,

      Sorry that your developer portal is still down. If you wish to consume an API service from a Fiori app without specifically going through developer portal, you can simply point the app to the API Proxy URL as your destination. If you are running the app on HCP you may create a destination within HCP cockpit, pointing directly to your API endpoint, and then point the App to that destination.

      If you wanted to generate the app in WebIDE for example, to deploy on HCP to consume from API management you could  generate a destination similar to this one:

      /wp-content/uploads/2016/07/example_destination_999500.png

      Author's profile photo Oliver Otto
      Oliver Otto

      Hi Holger,

      I am also having problems activating the Api Management Service on my Trial HCP (s0014439378trial). Could you look into this topic?

      I have tried activating it multiple times over the last few weeks without success.

      Kind regards

      Oliver

      /wp-content/uploads/2016/07/apimgmt_1004648.png

      Author's profile photo Former Member
      Former Member

      Hi Oliver,

      sorry to hear. We will look into this and get back to you.

      Regards,

      Holger.

      Author's profile photo Russ Wagner
      Russ Wagner

      I am also getting the "Failed" message while trying to enable the API Management Service. Is there a solution yet?  I don't feel comfortable posting my "s...trial" account number in this forum unless I have to.  Thanks.

      Author's profile photo Russ Wagner
      Russ Wagner

      Hi Holger:  Just got your message, but no email to send my account number to.  Do you want me to post it here, or will you send me a email to send it to.

      Thanks for the quick response.

      Russ

      Author's profile photo Elijah Martinez
      Elijah Martinez

      Hi Russ,

      If you would like to use email instead you can send email to sapapimanagementinfo@sap.com to pass the information to the API Management team.

      Regards,

      Elijah

      Author's profile photo Former Member
      Former Member

      Hi Folks,

                   I am unable to activate API Management. Getting "Failed" error. Please can you check?

      Thanks,

      Abhishek

      Author's profile photo Peter Ng
      Peter Ng

      Hi Abhishek,

      We are looking into this issue. If you have further questions, please email us at sapapimanagementinfo@sap.com.

      regards,

      Peter

      Author's profile photo Elijah Martinez
      Elijah Martinez

      Additionally, if you can send your Trial ID# so that we can look into your specific issue, that would help.

      Author's profile photo Former Member
      Former Member

      Hi Folks,

                    I have added my comment some time ago but looks like it is not approved by moderators.I am facing the same issue. Can you please help me out?

      Thanks,

      Abhishek

      Author's profile photo Tim Drury
      Tim Drury

      I also see the Failed status when trying to enable API Management. I'm using my i# trial account.

      Author's profile photo Elijah Martinez
      Elijah Martinez

      Hi Tim,

      If you have not yet done so, please try once again to Enable. A lot of work has gone into making the enablement successful, but there are always a few cases where something slips through. If you have tried Enabling your account 3 or more times already, please provide your S,P,I or D Number and we can look into what went wrong.

      If you do not feel comfortable providing it on SCN, feel free to send it to sapapimanagementinfo@sap.com via email

      Author's profile photo Tim Drury
      Tim Drury

      Thanks, Elijah.  I sent an email.

      Author's profile photo Former Member
      Former Member

      I was able to enable API Management, but when i go to the API Management portal i get the error message "There is a temporary problem in provisioning your account, please try again by clicking on Retry." This is going on for some time now.

      Anyone had this issue before?

      Author's profile photo Nicholas Kubiak
      Nicholas Kubiak

      I have this activated on my trial account and am able to use the endpoint but there are not any usage statistics showing up. Is this a trial limitation or am I supposed to be seeing general stats (i.e. calls, errors, etc) with/without any additional configuration? All the documentation I've seen implies that general stats should be available without any additional setup.

      I can ping the service via the provided API management URL so I know the service itself is working and API management is routing it correctly.

      Author's profile photo Former Member
      Former Member

      I have the same problem, I am trying to enable the service but it just show the failed message.

      ID: p1942446142trial

       

      Thanks

      Author's profile photo Elijah Martinez
      Elijah Martinez

      All above issues should have been resolved by now. Please feel free to reach out if further incidents come up.

      Author's profile photo Jan Almkvist
      Jan Almkvist

      Hi

      I am trying to Create an API based on SOAP but as soon as I try to add a Resource I get "Unable to register API" and [Request ID: 0ef2d71f-cf76-4818-a1bb-c543d1235f0e]
      String index out of range: 0

      Any idea?

      Jan Almkvist

       

       

      Author's profile photo Liliana Sampaio
      Liliana Sampaio

      Hi all,

      I have the same problem, I am trying to enable the service but it just show the failed message.

       

      Author's profile photo Vijay Sharma
      Vijay Sharma

      I too am facing this issue. API Management service is not getting enabled.

      Author's profile photo Prashant Kumar Patnaik
      Prashant Kumar Patnaik

      How to enable API management in Web IDE Personal Edition.