Problem : You are not able to use SAP Hana Cloud Connector as suggested in the various installation guides.

Target Audience : Anyone who is trying to install SAP Hana Cloud Connector (beginners to experts alike) and facing issues with it.

Resolution/Outcome : By the end of this blog you should be able to self troubleshoot the common issues faced during installation.

Environment : Windows 10, SAP Hana Cloud Connector 2.7.0 (Developer). Relevant for other versions of Windows as well.


To find the potential problem :

Keep reading the logs in the following file in the HCC folder : …..log\ljs_trace.log

To look at the latest logs, you can delete all previous logs and save the log file before triggering go.bat

Look at the logs with the time stamps of launching the go.bat. The new logs are appended to the bottom of the file.

Capture.PNG

Problem Scenario 1: You downloaded and extracted the Hana Cloud Connector developer version (from https://tools.hana.ondemand.com/#cloud)but You keep getting the ERR_CONNECTION_REFUSED instead of the login page.

Potential Resolutions :

1). http instead of https ?

The right link is https://localhost:8443

And NOT http://localhost:8443/

Default username is “Administrator” and password is “manage”.


2). JDK 64 bit is not installed correctly ?

http://www.oracle.com/technetwork/java/javase/downloads/jdk7-downloads-1880260.html

Ensure that you install the 64 bit version and typing java -version on command promt responds after the installation. Ensure you set JAVA_HOME and PATH environment variables.

Capture.PNG

3). Visual Studio 2010 runtime libraries not installed in the correct version. (vcredist.msi) ?

The 64bit msi can be downloaded from http://www.microsoft.com/download/en/details.aspx?id=14632


4). Resolved 1, 2 & 3 but still not working ?

If you confirmed step 1, 2 and 3 for sure, just re-extract the Hana Cloud Connector again to another folder and execute go.bat


Post Resolution : You should be able to access the logon page like this as expected.

Capture.PNG


Problem Scenario 2:  The logon page turned up but when you try add your Hana Cloud Platform trial account you get a error message Configuration XML was not updated

Potential Resolution : Restart the Hana Cloud Connector

(Sorry, missed to capture the screenshot. Now, I am not able to regenerate the scenario. Do save a screenshot for me if you face the problem !)

Problem Scenario 3 : If you are working for a big company, chances are that you access internet via a proxy. In such cases, you might face connectivity issue till you setup proxy in the Hana Cloud Connector.

Potential Resolution : Setup proxy in SAP Hana Cloud Connector.

Capture.PNG

In my case these steps solved my problem. Do let me know if you faced another problem situation, I will be happy to update the blog to add your situation and solution as well.

Miscellaneous

Quite some discussion here about Scenario 1:

https://scn.sap.com/thread/3542457

Scenario 2 :

https://scn.sap.com/thread/3663713

To report this post you need to login first.

1 Comment

You must be Logged on to comment or reply to a post.

Leave a Reply