Skip to Content

Some customers are experiencing the following issue after upgrade to GRC 10.1 SP 10 and SP11:

 

Despite repository sync job is completed without any dumps the table GRACUSERCONN is not updated,

 

To solve this issue implement SAP Notes below

 

2221261 – Code changes in repository sync for performance improvement

 

2168872 – Inconsistent entries in table GRACUSER and GRACUSERCONN

 

 

2256786 – All data for Portal Users not updated in Repository Sync

 

 

IF the issue still persists follow the steps in SAP Note below:

2253834 – Repository sync collection of corrections

 

For missing user type in GRACUSERCONN please implement SAP Note below:

 

2250690 – Some Portal Users missing in Repository Sync

 

2259378 – Repository Sync issue with expired and locked users – plugin

 

Regards

 

Rafael Guimbala

To report this post you need to login first.

15 Comments

You must be Logged on to comment or reply to a post.

  1. Sabita Das

    Hi Rafael,

    As the notes are part of SP11, system doesn’t allow to implement or de-implement to implement again.

    Can you suggest a process to do that?

    Thanks,

    Sabita

    (0) 
    1. Rafael Guimbala Post author

      Hi Sabita,

      If you are already in SP 11 is not possible do implement or de-implement those notes, please open a thread with more details about the connector type and with the symptoms that you are getting,

      Thanks,

      Rafael

      (0) 
      1. Sabita Das

        Thanks Rafael,

        I saw one similar post where they said that even though they were at SP11, they had to re-implement the note, that led me to this question 🙂 The second note (and side-effect note with it) helped me resolve the issue! SAP also referred to one Master note related to sync issues and this was the only one applicable 🙂

        Many thanks!

        Regards,
        Sabita

        (0) 
  2. Inacio Jose

    Hi Rafael,

    It was applied to the notes informed and the environment continues with the same problem, have any more suggestions.

    The sync is performed to Role, but for users is not added anything in GRACUSERCONN table, even after the application of informed notes.

    We are in NW7.4 GRC AC 11 SP 11 – Oracle and AIX.

    I appreciate the help.

    My cell contact <redacted by Moderator, per SCN Rules of Engagement>

    (0) 
      1. Inacio Jose

        Hi Rafael,

        The job runs without errors, there is not error in the log of SLG1, ST22, but grauserconn table is not populated.

        Carried out a debug in GRAC_ROLEREP_USER_SYNC program and noticed strange behavior in implementing these lines 233- 234:

        Prog-grac-rolerep-user-sync.jpg

        The connector is legacy, as I said the same settings in another GRC AC NW74 in SP09 and runs normally.

        Regards

        Inacio

        (0) 
          1. Inacio Jose

            Hi Rafael,

            The note that you mentioned, had already been implemented, and continue with the problem.

            Have any more suggestions?

            Regards,

            Inacio

            (0) 

Leave a Reply