Skip to Content

All Agentry/Maximo users,

SAP Support tries to be proactive in giving resolutions out to the customer to be readily available before the need arises.

Based on the July 31, 2015 requirement to upgrade (end of extended maintenance) Agentry 6.0.X (and earlier) version to SMP 3.0, there is a need to study the new platform on how to integrate it with IBM Maximo (SAP Mobility Syclo – Maximo products). From the first analysis and integration there were incompatible libraries and deprecated Agentry functions between Maximo and SMP 3.0 (Agentry). SAP worked closely with the IBM Maximo, SAP Work Manager and SMP 3.0 developers to create a new solution and instructions on how to use LDAP in SAP’s Work Manager for Maximo 8.X and SMP 3.0.

We appreciate all the partnership given by our customers and SAP system integrator companies (Including Maximo team) as we continue to improve our products and help the user community mobilize their solution. With this new knowledge, users of IBM Maximo (LDAP authentication) can integrate their SAP Work Manager for IBM Maximo LDAP properly using SMP 3.0 (Agentry) functionality.

Please reference the official guide: SAP Note # 2237514 – Adding LDAP support to SAP Maximo Products in a Websphere 8.5.x Landscape (and their corresponding reference notes).

Best Regards,

Mark Pe
SAP Platinum Support Engineer

To report this post you need to login first.

5 Comments

You must be Logged on to comment or reply to a post.

  1. TJ Davitt

    Hi,

    Are there any updates on compatibility for SMP 3.0 Service Pack 09 or above. We are upgrading from Agentry 6.0 presently and would like to move to the latest SMP version, ideally SP11, it seems right now there is a technical limitation to how far we can go?

    Thanks,

    TJ Davitt

    (0) 
    1. Bill Froelich

      The limitation was based on the IBM thin client adapter not supporting Java 8 which is what SMP 3.0 SP9 and above use.  I would start by checking with IBM to see if they have an updated thin client that supports Java 8.  That will be the first step before considering any upgrade beyond SP08.

      –Bill

      (0) 
      1. TJ Davitt

        Thanks Bill, I appreciate the feedback. From IBMs product compatibility it seems that the WebSphere thin client should be compatible with Java 1.8 but we have raised a support ticket to confirm. As we are migrating all the way from Agentry 6.0.30 we want to make sure we are arriving at the correct technical stack. Would your recommendation be to perform a Proof of concept on the LDAP authentication before beginning development on the target SMP version?

        Best Regards,

        TJ Davitt

        (0) 
        1. Bill Froelich

          I would test an Agentry 6 implementation with the thin client you expect to use and the SAP Java 1.8 to see if it works first.  If that works then I would proceed with attempting in my Dev environment first with SP08 PLx to verify and then under a newer version.

          –Bill

          (0) 
          1. TJ Davitt

            Thanks again Bill for your help. We can attempt to upgrade as suggested, starting with Agentry 6, moving first to what we know should work, i.e. SP08 PL04 and then trialling the latest version. One final question would be if the configuration does work with Java 1.8, would it be supported by SAP?

            Best Regards,

            TJ Davitt

            (0) 

Leave a Reply