Mozilla intends to remove support for most NPAPI plugins from Firefox by the end of 2016. Firefox began this process with manual plugin activation several years ago. Other modern browsers, such as Google Chrome and Microsoft Edge, have already removed support for legacy plugins.


After the removal  the following SAP technologies will be not supported in Firefox:

• SAP GUI for HTML which is tightly dependent on Java Applet for interacting with the client. SAP is currently analyzing a replacement for the Java Applet.

• SAP Screen Personas 2.0 that runs in a browser which supports Silverlight plug-in.


Further information will be updated in SAP Note for Firefox: 990034.

Because Adobe Flash is still widely used, Flash will be supported within Firefox as an exception to the general plugin policy. More details can be found here.

To report this post you need to login first.

Be the first to leave a comment

You must be Logged on to comment or reply to a post.

Leave a Reply