Skip to Content
Personal Insights
Author's profile photo Vanessa Barth

EA-PS precisa estar no mesmo nível do SAP-APPL ou não?

Este post foi criado para facilitar o entendimento das pessoas que falam a Língua Portuguesa.

This post was created to enable the understanding of the content for people that speaks Portuguese.

O mesmo conteúdo pode ser encontrado em Inglês neste link.

The same content can be found in English in this link.

Esta publicação é útil para instalações que usam a funcionalidade PSM-FM (Administração de Orçamento).

Esta funcionalidade está disponível na transação SFW5, onde o Enterprise Extension EA-PS é ativado.

Pergunta: Quando você faz uma atualização do SAP-APPL você precisa também fazer uma atualização do EA-PS para o mesmo nível?

Minha Resposta: Não há informação dizendo que SIM, que você precisa atualizar os dois juntos, mas eu acredito que tem benefícios em fazer isso.

Se você estiver no ECC 600 e você precisa ativar as business functions de PSM-FM na transação SFW5 (exemplo PSM_FM_CI_1) isto não é possível no ECC 600 e you você precisa estar em um Release mais alto ou em um Enhancement Package. Nestes casos você deve sempre alinhar PSM-FM (pacote EA-PS) com o Financeiro/Logística (pacote SAP-APPL).

Muitas vezes quando você atualiza o SAP-APPL, você decide manter o EA-PS alinhado (como descrito na Nota da SAP 1064635) mas não para o mesmo package ou release.

Você pode estar vivenciando alguns errors ou algum comportamento incorreto do sistema para dados de Administração de Orçamento relacionados a lançamentos integrados com MM (Administração de Materiais), CO (Controlling), FI (Contabilidade Financeira), SD (Vendas e Distribuição), PM (Manutenção)dentre outros. Algumas vezes, isto pode estar relacionado ao fato que o EA-PS não está sincronizado com o SAP-APPL.

Eu já vivenciei alguns erros cuja solução foi atualizar o EA-PS para o mesmo nível do SAP-APPL (mesmo release e package), tais como:

  • Erro FI057 – Erro de sistema: atualização administração de fundos (VOBELNR, FM_DOCUMENT_CLOSE);
  • Erro FI234 – Exercícios AdO divergentes; fatura &1 &2 &3 para pagamento &4
  • Erro RE164 – Montante em aberto de documento &1 &2 é excedido por &3 % no geral
  • Erro FMUP009 – Redução EM impossível. IF incorreto c/ÁAF 30 em vez de 40 em conta EM/EF;
  • Business Functions de PSM-FM não disponíveis na transação SFW5.

Para alinhar o assunto, eu estou comentando sobre os dois pacotes (packages) abaixo:

  • SAP-APPL que inclui FI, CO, MM, SD, PM, PP dentre outros. Formalmente é chamado de Logística e Contabilidade.
  • EA-PS      que inclui PSM-FM (Administração de Orçamento)

Como pré-requisito você pode considerar o seguinte:

  • Você ativou a funcionalidade de Administração de Orçamento (Enterprise Extension EA-PS é ativado na transação SFW5, e
  • Flags “Deriv CC – Ativar derivação da classif.contábil em AdO” e/ou “Atuali – Ativar atualização na administração do orçamento” são ativados no caminho de customização IMG (na transação SPRO) -> Administração do setor público -> Administração do orçamento administração pública -> Integração/atualização real e compromisso  -> Ativar/desativar administração de orçamento.

Você pode verificar na transação SPAM as informações do seu release/package atual para o sistema em questão. Por exemplo, caso você encontre o seguinte:

SAP-APPL Package EA-PS package
SAP-APPL EHP 4  package SAPKH60402    (Logística e Contabilidade) EA-PS  ECC 600 package SAPKGPPD12  (Administração de Orçamento)

Isto é uma quebra a regra de implementação de Enhancement Packages e não está alinhado com a Nota da SAP 1064635  que tem a seguinte informação:

EhP4 SPS02 — EhP3 SPS04 — EhP2 SPS05 — SAP ERP 6.0 SPS15

Sendo assim, para estar alinhado, você precisa ter os packages da seguinte forma:

SAP-APPL Package EA-PS package
SAP-APPL EHP 4  package SAPKH60402    (Logística e Contabilidade) EA-PS    ECC 600 package SAPKGPPD15 (Administração de Orçamento)

Meu ponto é que, melhor do que estar alinhado, é atualizar os dois packages (SAP-APPL e EA-PS) de forma conjunta da seguinte forma:

SAP-APPL Package EA-PS package
SAP-APPL EHP 4  package SAPKH60402      (Logística e Contabilidade) EA-PS    EHP 4  package SAPK-60402INEAPS    (Administração de Orçamento)

Como existem novas funcionalidades e correções disponíveis em releases mais atuais, você poderá ter um sistema mais consistente se você atualizar a Administração de Orçamento (EA-PS package) em conjunto com Logística e Contabilidade (SAP-APPL). E também, depois de uma atualização (upgrade) todas as funcionalidades principais são normalmente testadas sendo assim os testes de atualização da Administração de Orçamento serão feitos de qualquer forma, já que a parte de Logística e Contabilidade são áreas integradas.

Outro exemplo que é incorreto e inconsistente é ter o seguinte (ambos no mesmo Release):

 

SAP-APPL SAPKGPPD21

EA-PS SAPKGPPD04

 

Como você pode ver, ambos estão no mesmo release ECC 600 mas não no mesmo pacote.

Neste caso, quando você tenta encontrar correções para PSM-FM (EA-PS) você pode encontrar muitas porque o pacote é muito baixo e não está alinhado com SAP-APPL. Neste caso, no mínimo, a empresa precisa avaliar trazer o pacote EA-PS 06 para o pacote 21 como no SAP-APPL.

Eu vejo esforço no lado de Basis em atualizar o EA-PS em conjunto com o SAP-APPL mas eu vejo muitos benefícios em fazer desta forma. De qualquer forma, SAP-APPL e EA-PS precisam pelo menos estar alinhados como descrito na Nota da SAP 1064635. No caso em que você precisa ativar alguma business function do PSM-FM, elas não estão disponíveis no ECC 600 mas nos EHP packages subsequentes. Neste caso, você precisa fazer upgrade do EA-PS junto com SAP-APPL para o mesmo nível, estar alinhados não é o suficiente. 

Espero que esta informação seja útil.

 

Atenciosamente,

Vanessa Barth

Assigned tags

      2 Comments
      You must be Logged on to comment or reply to a post.
      Author's profile photo Former Member
      Former Member

      What / which module license(s) is/are required to activate EA-PS?

      Author's profile photo Vanessa Barth
      Vanessa Barth
      Blog Post Author

       

      Hi Patrick,

      Funds Management comes together with the SAP ERP/ECC as an Add-On (EA-PS) that is deactivated by default. Customers activate it when they want to have Funds Management functionalities.

      Regards, Vanessa.