Skip to Content

What are the requirements for Afaria and Mobile Secure to support iOS 9?

Due to a change in iOS 9, a patch to Afaria servers will be required for iOS9

device support. Devices that are updated to iOS 9 will not be able to

communicate with un-patched Afaria servers    SAP will be providing the code

fixes in the following versions:

  • Mobile Secure 3.1 has been released
  • Afaria 7 SP4 HF19 has been released
  • Afaria 7 SP5 HF13 has been released 
  • Afaria 7 SP6  – Release date August/September 2015

We strongly suggest that you apply the appropriate patches for on premise
installations as soon as they are available to avoid any disruption.  Mobile
Secure cloud customers will not need to make any change and the updates will
already be in place.

Note: iOS 9 has made a few changes that may affect your deployment

1) When using client-first enrollment (using the SAP custom signed Afaria
app) the behavior has slightly changed in that you must “trust” the enterprise
app by going to app settings > general > profile and accept the app.

This will add an extra step in the enrollment process.  This does not affect
the client first enrollment using the SAP App Store Client.  This will not
affect customers using MDM-first enrollment through the Afaria Self-service
Portal or a custom portal or Mobile Secure cloud customers.

2) Apple has moved the capability to block access to the App Store to only be
available on Supervised devices.  Devices that are not supervised will no longer
be able to block access to the Apple App Store.

Please see the following KBA for any updates:

2178846

To report this post you need to login first.

3 Comments

You must be Logged on to comment or reply to a post.

  1. Josue Arevalo

    Hello, if a user has the iPad enrolled with Afaria and he downloads the enterprise application from Afaria for the first time, the popup will appear or not?

    Thank you very much.

    (0) 
    1. Tracy Barkley

      Josue,

      That depends on the delivery method.  If you are using the built in defined iOS Afaria application setting, or delivering with an MDM  delivery policy, no the popup will be avoided.  If it is a required or optional policy not using MDM, they will.   If you are having trouble with this, I would suggest opening a new discussion on this topic.

      Tracy

      Senior TSE

      (0) 

Leave a Reply