Skip to Content

/wp-content/uploads/2015/07/eclipse_mars_748940.png

Hi Community,

since this morning there is a new updatesite available for you:

SAP Development Tools for Eclipse – Mars Software Repository

SAP development tools landed successfully on Mars and this time the ABAP is the first guy setting his feets on the new planet. ABAP development based on Eclipse Mars is now officially supported.


Find all the news of the Eclipse Mars release on the eclipse news page:

Eclipse Mars – New and Noteworthy


But where are all the other development tools from SAP for the Mars Release?

–> Don’t worry. They will come in the next days.


Kind Regards,

Thomas.

To report this post you need to login first.

16 Comments

You must be Logged on to comment or reply to a post.

  1. Reinhard Döring

    Hi Thomas,

    I have tested ADT 2.44 with Mars. ABAP development works for me without problems.

    But when I try to edit a BOPF object, I get the following error message.

    BOPF.PNG

    Are the BOPF tools (V.21.1) already released for Mars? Or ist this a bug?

    Greetings from Munich

    Reinhard

    (0) 
    1. Shyam Balachandran

      Hi Reinhard,

      Can you give more about the backend ABAP system you are connecting to? It would be helpful if you can tell me both the SAP_BASIS version and the SAP_BS_FND version.

      Thanks and Regards,

      Shyam

      (0) 
      1. Reinhard Döring

        Hi Shyam,

        the SAP_Basis Version is 740 SP10 (SAPKB74010).

        SAP_BS_FND is 747 SP 8 (SAPK-74708INSAPBSFND).

        With ADT 2.41 on Luna and the same backend where is no problem.

        Regards

        Reinhard

        (0) 
    2. Shyam Balachandran

      Hi Reinhard,

      We have fixed the problem. Please apply the note 2195181 “Business Object not opening in AiE” for this and the problem should be solved. Let us know if you still face any issues.

      Thanks and Regards,

      Shyam

      (0) 
    1. Thomas Fiedler Post author

      Hi Henrik,

      as we are close to a new AS ABAP version 7.50 all new features that we built in the last couple of months rely on that new backend version. This new backend version is planned for Q4 this year. 

      Regards,

      Thomas.

      (0) 
  2. Reinhard Döring

    Hi Thomas,

    I have tested ADT 2.44 with Mars and want now install the Enterprise Service Development Tools.

    http://scn.sap.com/community/abap/eclipse/blog/2013/05/14/introducing-connectivity-and-integration-on-abap-development-tools-eclipse

    When installing the following error message appears:

    Install.png

    Cannot complete the install because one or more required items could not be found.

      Software being installed: SAP NetWeaver Developer Studio PI ESR-DIR Integration 8.31.160004.150731114004 (com.sap.netweaver.developerstudio.tlf.xpi.intgn.feature.group 8.31.160004.150731114004)

      Missing requirement: Enterprise Service Browser UI Plug-in 1.0.0.150108132527 (com.sap.ide.es.browser.ui 1.0.0.150108132527) requires ‘bundle com.sap.aii.util 2.0.0’ but it could not be found

      Missing requirement: Enterprise Service Browser UI Plug-in 1.0.0.150710072826 (com.sap.ide.es.browser.ui 1.0.0.150710072826) requires ‘bundle com.sap.aii.util 2.0.0’ but it could not be found

      Missing requirement: Enterprise Service Browser UI Plug-in 1.0.0.150731104004 (com.sap.ide.es.browser.ui 1.0.0.150731104004) requires ‘bundle com.sap.aii.util 2.0.0’ but it could not be found

      Missing requirement: com.sap.ide.esr.tools.core 1.0.0.150108132527 (com.sap.ide.esr.tools.core 1.0.0.150108132527) requires ‘bundle com.sap.exception.facade 2.0.0’ but it could not be found

      Missing requirement: com.sap.ide.esr.tools.core 1.0.0.150731114004 (com.sap.ide.esr.tools.core 1.0.0.150731114004) requires ‘bundle com.sap.aii.ibclient 0.0.0’ but it could not be found

      Cannot satisfy dependency:

        From: com.sap.ide.esr.tools.core 1.0.0.150710072827 (com.sap.ide.esr.tools.core 1.0.0.150710072827)

        To: bundle com.sap.ide.es.browser.ui 0.0.0

      Cannot satisfy dependency:

        From: SAP NetWeaver Developer Studio PI Design – Config Connector 7.3.1.150731104004 (com.sap.ide.xpi.dir.rep.intgn.feature.group 7.3.1.150731104004)

        To: com.sap.ide.esr.tools.core 1.0.0

      Cannot satisfy dependency:

        From: SAP NetWeaver Developer Studio PI ESR-DIR Integration 8.31.160004.150731114004 (com.sap.netweaver.developerstudio.tlf.xpi.intgn.feature.group 8.31.160004.150731114004)

        To: com.sap.ide.xpi.dir.rep.intgn.feature.group [7.3.1.150731104004]

    With Eclipse Luna there is no problem.

    Are the Enterprise Service Development Tools incompatible with Mars?

    Greetings from Munich

    Reinhard

    (0) 
  3. Shibha Jain

    Hi Thomas,

    I have heard SAP will not provide SAPUI5 development add-ons for Eclipse. SAPUI5 / Fiori Developments will only be possible via Web IDE. Is that true?

    Regards

    Shibha Jain

    (0) 
    1. Custodio de Oliveira

      Hi Shibha,

      In case you haven’t noticed I’m not Thomas ­čÖé but will try to answer anyway. The UI5 toolkit is already available for Eclipse Mars. Also, you can develop you UI5 applications on any IDE/Text Editor you like, be it Eclipse, Visual Studio, Sublime or Notepad++

      But SAP recommends you use only WebIDE for Fiori Apps. Keep in mind that Fiori is built on SAPUI5, but UI5 (SAPUI5 or OpenUI5) is not necessarily Fiori.

      Cheers,

      Custodio

      (0) 
  4. Syed Masood

    My Question to┬áThomas Fiedler. I Downloaded Mars when I try to create a structure it open Se11 instead of the window where you define the type “Like in DEV 266 on Page 22 it shows where you add the ┬ácompany code amount and so on. ┬áCan you please help me with this. what i am doing wrong.

    (0) 

Leave a Reply