Skip to Content

Short Information Summary

Based on internal discussion between the participants of the SCN Design Studio SDK Development Community we have now 2 versions of the repository:

  • Release 1.0, containing all extensions and applicable for design Studio 1.2, 1.3, 1.4
  • Release 2.0, containing the same extensions and applicable for Design Studio 1.5 and higher

The corresponding repository has now two update sites, the 1.0 update site is moved into “freeze” mode, meaning there will be no new changes on it.

The links can be taken directly from the entry page:

Component List – SCN Design Studio Community

– and this page is also available now in 2 versions).Follow the links in the header to switch between the versions.

p1.PNG

The download links are now linking to the corresponding versions:

p2.PNG

Upgrade Procedure

What you should do in case you have installed the components?


If you are on release 1.4, you have to stay on the release 1.0, the 2.0 release will be not installable on your Design Studio.


If you are already on release 1.5, you can upgrade to release 2.0 with following considerations:

  • the components will stay compatible – at least we try to keep them compatible
  • we will improve the components (eg, using better techniques the components will get Additional Property Sheets)
    • this can lead to small incompatibilities on ZTL (Scripting) functions, but those can be corrected on request.

Important

if you use the components, wait a bit until the repositories will be again in “GREEN” status! Today we made the “technical” upgrade, but the status is “YELLOW”.

p3.PNG

In case you use “preview”, you can install it and play with it.

Online Repository

In case you are using the online repository link, you will automatically get the release 2.0 on next update. The repository for release 1.0 is now in separated path.


Why this decision?

Design Studio release 1.5 is bringing new constructs which we want to use in the components (eg data binding) and by this, the components are not applicable for release 1.4 and below. This means the reason is mainly technically driven.

In addition, many “hacks” which were required for release 1.3 and 1.4 can be removed now from code, so the content will be also better prepared for the future.

Also, we want to learn more on version management and branching in GITHUB 😉

Compatibility Details

We try to keep all components compatible – but it can happen that there will be small incompatibility on the conversion. After the conversion the components which are converted into release 2.0 will get the “2.0” suffix in the description. Then, you should check your applications (validate scripts). In case there is something wrong, open an issue on github.

There is one slight change in addition (also in 1.0 release) – the “prototypes” package is now also defined as feature – if you do not need it, you can uncheck on installation.

Going Forward

As all of the participants are investing own private effort into this repository, we try to reduce any efforts in the release 1.0 – there will be no extensions, changes or new components there. BUT, for those who are using the components and will find an issue, we still have a branch and can correct this issue for you – open an issue on github and we will see what we can do.


For those who sync down the GITHUB repository

There is actually no change, the release 1.0 is now in branch “rel-1.0“, the “master” branch is the “going forward” release – for now 2.0.


Stay tuned!

More new fancy components will come soon into the release 2.0 – check up for changes!

Going Live with release 2.0

… today.

To report this post you need to login first.

Be the first to leave a comment

You must be Logged on to comment or reply to a post.

Leave a Reply