Skip to Content

The following is summary by release, of the Internet Browsers that SAP Sourcing/CLM Supports:

  1. In release 7.0 SPX we are compatible with: Internet Explorer version 6, 7, 8, 9, 10 or 11.  IE 10 and IE 11 are only supported in Compatibility View mode.
    1. As part of 7.0 SP9 we updated the warning message when users login with unsupported browsers to clarify that IE 10 (compatibility view) is also supported.
      • If users are using IE 10 in compatible view in earlier versions of 7.0 SPX there should be no problems.
    2. As part of 7.0 SP12 we updated the warning message when users login with unsupported browsers to clarify that IE 11 (compatibility view) is also supported.
      • If users are using IE 11 in compatibility view in earlier versions of 7.0 there should be no problems.
      • As part of 7.0 SP12 we also added the warning message for when users navigate to the Supplier Registration pages using an unsupported browser.
  1. In release 9.0 SPX we are compatible with: Internet Explorer version 6, 7, 8, 9, 10 or 11, Safari, Firefox, or Chrome.
    1. A warning message appears when users attempt to login or when users are navigated to the Supplier registration pages to let them know they are using a browser that is not compatible.
    2. As part of 9.0 SP14 we updated the warning message when users login with unsupported browsers to clarify that IE 10 is also supported.
      • Additionally 9.0 SP14 and SP16 address some minor rendering issues when users are using IE 10 without compatibility view.
      • If users are using IE 10 with earlier versions of 9.0 SPX that is fine but we recommend compatibility view.
    3. As part of 9.0 SP21 we updated the warning message when users login with unsupported browsers to clarify that IE 11 is also supported.
      • Additionally 9.0 SP21 and SP22 address some minor rendering issues when users are using IE11 without compatibility view mode.
      • If users are using IE 11 with earlier versions of 9.0 SPX that is fine but we recommend compatibility view.
  1. In release 10.0 SPX we are compatible with: Internet Explorer version 6, 7, 8, 9, 10 or 11, Safari, Firefox, or Chrome.  Safari iOS on the iPad is also supported.
    1. A warning message appears when users attempt to login or when users are navigated to the Supplier registration pages to let them know they are using a browser that is not compatible.
    2. As part of 10.0 SP4 we updated the warning message when users login with unsupported browsers to clarify that IE 11 is also supported.
      • Additionally 10.0 SP4 and SP6 address some minor rendering issues for when users are using IE 11 without compatibility view mode.
      • If users are using IE 11 with earlier versions of 10.0 SPX that is fine but we recommend compatibility view.

Please contact me with any questions.

Anne McClelland

Product Management

To report this post you need to login first.

17 Comments

You must be Logged on to comment or reply to a post.

  1. Rodrigues Gonzalves

    Hi Anne,

    We currently use v10.. We do have some issues on all the browsers when it comes to Userdefined toolbars. Sometimes, the toolbar does not show submenus. However, when you log off and log back in, it works most of the time. Thought it should be somehting to do with Javascript.

    Regards,

    Rodrigues.

    (0) 
    1. Anne McClelland Post author

      Hello

      Can you clarify what version of 10.0 you are using?

      I would also like to know what version of the browsers you are using.

      Could be a caching issue.

      I would recommend you log a support issue so that we can research this.

      Anne

      (0) 
      1. Bogdan Toma

        Hi Anne, Rodrigues,

        I can also confirm this is happening randomly in V10 SP5 on all browsers (Chrome, Firefox, IE – 9 & 11+compatibility). It did not happen in V9.

        It doesn’t look like a browser cache issue because it gets fixed once the user executes a logout/login. I tend to agree with Rodrigues, it being a js issue.

        Again, this is happening randomly; from our side we did not open a support ticket – SAP tends to disregard issues that are ‘random’.

        Bogdan

        (0) 
        1. Anne McClelland Post author

          Hello

          I asked around and we are not experiencing this nuance.  Can you tell me if it only happens on UserDefined Toolbars?

          In order for us to research this further we need a Support ticket logged.  It can be hard to nail down issues that inconsistently happen or are hard to determine the scenario that causes them but we can’t try if the issue isn’t logged.

          Screen shots help too.

          Keep me posted if you log it and I can follow-up.

          Anne

          (0) 
            1. Anne McClelland Post author

              If one of you can log the issue and include screenshots that would be great.  In the meantime I have put the word out to look for the issue internally.

              Anne

              (0) 
  2. Deepti Deshpande

    Hi Anne,

    we have CLM 9.0.20. External users (vendors) using IE9.

    When they try to upload/download attachments to RFx or Master agreement, they immediately get logged out. They get a pop up saying “your session no longer valid. Either because it has timed out or your account has logged in again from another session.”.

    We verified that user open only one session and as soon as select an attachment for download, this error comes. Hence they cannot download attachment at all. Same is case while uploading attachment.

    But when we try on “Intranet”, this functionality works fine with same user ID.

    Can you please suggest how can we resolve this issue?

    (0) 
      1. M. RAHAMAN

        Hi Anne,

        We have SAP Sourcing 10 SP07 and users are using IE 11. Some times they are getting “SAP Sourcing can not display page”. After second attempt it works fine. As per the blog IE 11 is supported with CLM 10 SPX. So what might be the problem here?

        Thanks,

        Mofizur

        (0) 
        1. Gary Boutin

          I dont believe this is a browser related issue. Most likley another configuration / network issue. You should work with the support team. they will need application logs and specific incident times to debug the problem.

          Regards,

          Gary

          (0) 
  3. Ritu Gupta

    Hi,

    Can some one please provide me the details of what all platform SAP Sourcing/CLM 9.0 supported. Is windows 10 compatible with that.

    Thanks,

    Ritu

    (0) 
    1. Anne McClelland Post author

      Hello Ritu

      Can you clarify what browser you are asking about?  The windows version your users are using isn’t as relevant as the browser version is.

      Anne

      (0) 
      1. Ritu Gupta

        Hi Anne,

        Thanks for your reply. Our client is planning to upgrade PC’s with Windows 10. Could you please confirm that sourcing compatibility is relevant to only browser version not with the operating system. we are on Sourcing 9.0.

        Thanks,

        Ritu

        (0) 
  4. Venelin Ganchev

    Hi,

    we are testing our version 10 of Sourcing in IE11 and we experience the issue that after login the user menus are not available. Only Setup is available. Further, if I try to follow any link in the Setup menu, nothing happens. It seems like the browser is frozen.

    I tested in IE9 and menus and links work fine. Same in Chrome. No issue there.

    Sourcing version: 10.0.09.03 build 263757:2016-06-01 15:07 EDT

    IE11 version: 11.0.9600.18378

    Any clues are appreciated.

    Thanks,

    Venelin

    (0) 
    1. Anne McClelland Post author

      Hello Venelin

      Please log a support ticket for this issue so that we can research this issue.

      Do you have Compatibility View on or off.  Try it the other way and include those results in the ticket.

      Regards,

      Anne McClelland

      SAP Sourcing / CLM Product Mgmt.

      (0) 

Leave a Reply