Skip to Content

Dear all,

I have been trying to get complete documention materials on step by step setup of  Sybase ASE Replication, more so is on errors resolutions during the setup…finally i managed to setup it successfully and soon will be sharing complete documentation with screen shots.

Works for both Sybase ASE and Oracle Databases.

Please find the updated documentation  Sybase Replication Installation Guides Updated with Step by Step setup of Sybase Replication Server.

Regards,

Dominic

To report this post you need to login first.

22 Comments

You must be Logged on to comment or reply to a post.

  1. sai pavan vallabhaneni

    Hi Dominic Kebenei

    We are trying to setup DR using sybase replication server. We are facing issue when installing SRS on Primary DB.

    Can you please let us know if you have encountered similar issue/have a solution?

    We have done the following so far:

    1. Install ECC6 EHP6 using ASE 15.7.0.132 (distributed installation, CI and ASCS on Host1, DB on Host3)

    2. Install Empty Database on Host2 (which should server the purpose of standby DB)

    3. Install SAP Replication Server Software on Host2 (by unchecking Configure replication environment in the SAP Installer)

    All the above mentioned activities are successfully completed.

    Now we are in the phase to Install SAP Replication Server Software on Host3 (Primary DB) but SAP Installer throws an error after input for Replication System Parameters is provided.

    Replication System Parameters.png

    Error:

    Replication System Parameters Error.png

    On further analysis, we observed that DR_admin and SID_maint users are missing in standbyDB (Host2) where empty DB was created followed by SRS installation (by unchecking Configure replication environment in the SAP Installer)

    /wp-content/uploads/2015/05/missing_dr_admin_707655.png

    But the SAP Installer for SAP Replication Server mentions that DR Administration user is successfully created on Host2 (standby DB).

    SAP_Installer_Finish.png

    Is this a bug? Installer mentions that DR Administration user is created where as sp_displaylogin shows that no ‘dr_admin’ user does not exist

    Awaiting your reply.

    thanks

    Sai

    (0) 
    1. Dominic Kebenei Post author

      Hi Sai,

      Kindly check if you can execute the following scripts on Standby Site within ISQL :

      isql64 -e -w999 -UDR_admin -Shost2:4909 -X

      The same on the Primary site :

      isql64 -e -w999 -UDR_admin -Shost3:4909 -X


      Then share the logs


      However ensure you do the following while installing Replication Software :


      1. On the Standby Site –  Ensure you uncheck Configure replication environment


      2. On the Primary Site  – Ensure you Check Configure replication environment



      Sometimes you might be required to Stop Application Server (stopsap r3) on  both Primary and the Standby Site.



      Regards,


      Dominic

      (0) 
      1. sai pavan vallabhaneni

        Hi Dominic,

        Thanks for the quick response.

        I was able to sucessfull run the command for Standby DB (Host 2) as the Sap Replication server is already installed (by uncheck Configure replication environment).

        Host2_dr_admin.png

        For Primary DB (Host 3), the command failed, probably because we are still in the process of installing the Sap Replication Server Software and DR_admin user still is not created.

        Host3_dr_admin.png

        From the 1st screenshot it is evident that DR_admin user exists on Standby DB.

        But when SAP Installer for installing SAP Replication Server Software on Primary DB (Host 3) tries to connect using DR_admin to Standby DB (Host 2) then installer throws the below error.

        Replication System Parameters Error.png

        Please advise.

        thanks

        Sai

        (0) 
              1. sai pavan vallabhaneni

                Hi Dominic,

                The Standby server is on host SYBSERVER2 (where Empty DB is installed followed by SRS)

                The Primary server is on host SYBSERVER3 (where ECC6 EHP6 is installed and now SAP Installer for SRS is in stuck because of the mentioned error.)

                Based on the command provided by you (isql64 -e -w999 -UDR_admin -Shost2:4909 -X) I am able to successfully login using DR_admin on Standby DB.

                But when SAP Installer on Primary DB for SRS executes, its not able to perform a Login onto SYBSERVER2 with DR_admin and pops up the error that i provided in the previous reply.

                Any idea if some customizing needs to be performed before starting the SRS installation on Primary DB?

                thanks

                Sai

                (0) 
                1. Dominic Kebenei Post author

                  Hi Sai,

                  Please try run below scripts on ISQL from the Primary Site.

                  isql64 -e -w999 -UDR_admin -SSYBSERVER2 :4909 -X


                  Once logged in please run below command:


                  sap_status path


                  then share the output.


                  NB: To test if the Primary site is able to connect to the Standby site from the Primary site.



                  Regards,


                  Dominic

                  (0) 
                  1. sai pavan vallabhaneni

                    Hi Dominic,

                    From Primary DB (Host 3) i was successfily able to conect to Standby DB (Host 2) using the command isql64 -e -w999 -UDR_admin -SSYBSERVER2:4909 -X

                    But sap_status path gives below error

                    DR_admin_error.png

                    Note: We don’t have SAP installed on the Standby DB site.

                    We are trying to setup the DR based on ‘Co-Located Replication Topology: Central Instance on a Separate Server‘ procedure from the Installation Guide ‘SAP Systems Based on the Application Server ABAP on Windows: SAP Adaptive Server Enterprise’ for NW 740.

                    thanks

                    Sai

                    (0) 
                    1. Dominic Kebenei Post author

                      Hi Sai,

                      Yes from the logs it seems the Primary and Standby site are able to communicate successfully.

                      Please try below steps then share the results:

                      1. Try re -start both the DB (Sybase Only) (primary & standby) site –

                          

                          NB: Ensure the Standby site is up before the primary site.

                      – i.e. Within ISQL – run below commands :

                        i). shutdown SYB_BACKUP

                        ii). shutdown

                      2. Start the Database – startdb

                      – This will start both the Backup server and the Replication server/DR agent

                      – Please also confirm if the connectivity between the primary and standby site is not very slow.

                      – Kindly share the screens you used to setup the Standby site so that I can check.

                      Regards,

                      Dominic

                      (0) 
  2. sai pavan vallabhaneni

    Hi Dominic,

    As suggested, I have stopped the DB on both the sides and started them again.

    Post DBs are up, i ran the SAP Installer again. I still get the same error  🙁

    1. shutdown primary DB

    shutdown the primary DB.png

    2. shutdown standby DB

    Shutdown standby DB.png

    3. start the services of Standby DB (Sybase SQLServer followed by Sybase BCKServer)

    Start the services of Standby DB.png

    4. start the services of Primary DB (Sybase SQLServer followed by Sybase BCKServer)

    Start the services of Primary DB.png

    Please provide me your mail ID so that i can send the DOC containing screens for the setup of the Standby site.

    Note:

    1.  For the Standby site we only have installed an Empty DB followed by SRS Installation (by unchecking Configure checkbox in the installer).

    2. SAP in not installed at the Standby site. SAP is installed only for the Primary DB as a distributed system. Hence CI & DB are on different servers.

    3. Incase Primary DB fails, CI should connect to the Standby DB.

    thanks

    Sai

    (0) 
    1. Maria-Cristina NORMAND

      Hello,

      As requested in your other post, please provide us the sapinst_dev log from primary site SRS installation. This is the first place where you have to check to get more information about an installation error ( check in /sapinst_instdir/GENERIC/SYB/REPENV/SETUP/*)

      Also please, from standby site:

      1) execute an ipconfig -a , and show us here the output

      2) ping SYBSERVER2 and get the IP address. Then execute “nslookup”
      against the IP address to see what name is returned.

      Thanks

      Regards,

      Cris

      (0) 
  3. sai pavan vallabhaneni

    HI,

    @Dominic: I have mailed the Docs for installation to your mail.

    @Cris: I have already looked at the sapinst_dev.log last week. But could not find much info.

    I can see in the sapinst_dev.log that login for sapsa and sapsso on SYBSERVER2 was successful where as the login for DR_admin runs into an error.

    I am unable to attach the log file, please find the log below.

    ***************************************************************************************************

    “syb_verify_jdbc_connect2: verifying login for dbuser sapsa host SYBSERVER2 port 4901 dbname SW1

    TRACE      2015-05-25 10:13:31.076 (SYBSERVER3\Administrator) [syxxcfile.cpp:85] CSyFileImpl::decideIfMoveCopyNode(const CopyMoveDestinationInfo & {m_nodeTypeForCombiCheck: …, m_path: C:/Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP/sybsql.6.log, m_realNodeType: 8}, ISyNode::CopyMoveMode_t 0x3, PSyNodeInt &) const
    Target node does not exist and (mode & ISyNode::MISSING) ==> I will copy/move.

    TRACE      2015-05-25 10:13:31.091 (SYBSERVER3\Administrator) [syxxcnode.cpp:425] CSyNodeImpl::move(const CSyPath & C:/Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP/sybsql.6.log, ISyNode::CopyMoveMode_t 0x3)
    Moved C:/Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP/sybsql.log to C:/Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP/sybsql.6.log

    INFO       2015-05-25 10:13:31.107 (SYBSERVER3\Administrator) [synxcpath.cpp:799] id=syslib.filesystem.creatingFile CSyPath::createFile()
    Creating file C:\Program Files\sapinst_instdir\BS2011\ERP606\LM\DBTOOLS\SYB\REPENV\SETUP\sybsql.log.

    TRACE      2015-05-25 10:13:31.107 (SYBSERVER3\Administrator)
    Starting “C:\Users\ADMINI~1\AppData\Local\Temp\sapinst_exe.1640.1432528457\jre\bin\java.exe -classpath “C:\Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP\sybhelper.jar;C:\Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP\sybjdbc\jconn4.jar” -Xmx256m sybsql” as current user

    TRACE      2015-05-25 10:13:31.107 (SYBSERVER3\Administrator) [synxcchapp.cpp:275] CSyChildApplicationImpl::doStart()
    Going to call CreateProcess/CreateProcessAsUser for ‘C:\Users\ADMINI~1\AppData\Local\Temp\sapinst_exe.1640.1432528457\jre\bin\java.exe’ now.

    TRACE      2015-05-25 10:13:31.107 (SYBSERVER3\Administrator) [synxcchapp.cpp:575] CSyChildApplicationImpl::doStart()
    Trying to start C:\Users\ADMINI~1\AppData\Local\Temp\sapinst_exe.1640.1432528457\jre\bin\java.exe CSySysLibCallsWrapper::syscallwrapper()->__CreateProcess__(NULL, <command line for executable C:\Users\ADMINI~1\AppData\Local\Temp\sapinst_exe.1640.1432528457\jre\bin\java.exe, NULL, NULL, TRUE, 0x420, NULL, NULL, &StartupInfo, &ProcessInfo)

    TRACE      2015-05-25 10:13:31.107 (SYBSERVER3\Administrator) [synxcchapp.cpp:653] CSyChildApplicationImpl::doStart()
    A child process has been started. Pid = 3528. Executable name: C:\Users\ADMINI~1\AppData\Local\Temp\sapinst_exe.1640.1432528457\jre\bin\java.exe

    INFO       2015-05-25 10:13:31.123 (SYBSERVER3\Administrator) [iaxxbjsmod.cpp:105] id=modlib.jslib.childAppSeeLog
    Output of C:\Users\ADMINI~1\AppData\Local\Temp\sapinst_exe.1640.1432528457\jre\bin\java.exe -classpath “C:\Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP\sybhelper.jar;C:\Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP\sybjdbc\jconn4.jar” -Xmx256m sybsql is written to the logfile sybsql.log.

    TRACE      2015-05-25 10:13:34.321 (SYBSERVER3\Administrator) [synxcpipe.cpp:172] CSyStdIOPipe::waitForOverlappedIO(int timeout)
    Syslib info about system call. OS message 109 (The pipe has been ended.

    ) after execution of system call ‘GetOverlappedResult’ with parameter ((pipe to child process)), line (133) in file (d:\depot\bas\720_rel\bc_720-2_rel\gen\optu\ntamd64\ins\sapinst\impl\src\syslib\synxcpipe.cpp).

    INFO       2015-05-25 10:13:34.336 (SYBSERVER3\Administrator) [iaxxbjsmod.cpp:105] id=modlib.jslib.childAppReturn
    Execution of the command “C:\Users\ADMINI~1\AppData\Local\Temp\sapinst_exe.1640.1432528457\jre\bin\java.exe -classpath “C:\Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP\sybhelper.jar;C:\Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP\sybjdbc\jconn4.jar” -Xmx256m sybsql” finished with return code 0. Output:
    use SW1
    quit

    TRACE      2015-05-25 10:13:34.477 (SYBSERVER3\Administrator)
    syb_verify_jdbc_connect2: return code 0

    TRACE      2015-05-25 10:13:34.477 (SYBSERVER3\Administrator)
    syb_verify_jdbc_connect2: login ok

    TRACE      2015-05-25 10:13:34.523 (SYBSERVER3\Administrator)
    syb_verify_jdbc_connect2: verifying login for dbuser sapsso host SYBSERVER3 port 4901 dbname SW1

    TRACE      2015-05-25 10:13:34.539 (SYBSERVER3\Administrator) [syxxcfile.cpp:85] CSyFileImpl::decideIfMoveCopyNode(const CopyMoveDestinationInfo & {m_nodeTypeForCombiCheck: …, m_path: C:/Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP/sybsql.7.log, m_realNodeType: 8}, ISyNode::CopyMoveMode_t 0x3, PSyNodeInt &) const
    Target node does not exist and (mode & ISyNode::MISSING) ==> I will copy/move.

    TRACE      2015-05-25 10:13:34.555 (SYBSERVER3\Administrator) [syxxcnode.cpp:425] CSyNodeImpl::move(const CSyPath & C:/Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP/sybsql.7.log, ISyNode::CopyMoveMode_t 0x3)
    Moved C:/Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP/sybsql.log to C:/Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP/sybsql.7.log

    INFO       2015-05-25 10:13:34.570 (SYBSERVER3\Administrator) [synxcpath.cpp:799] id=syslib.filesystem.creatingFile CSyPath::createFile()
    Creating file C:\Program Files\sapinst_instdir\BS2011\ERP606\LM\DBTOOLS\SYB\REPENV\SETUP\sybsql.log.

    TRACE      2015-05-25 10:13:34.586 (SYBSERVER3\Administrator)
    Starting “C:\Users\ADMINI~1\AppData\Local\Temp\sapinst_exe.1640.1432528457\jre\bin\java.exe -classpath “C:\Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP\sybhelper.jar;C:\Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP\sybjdbc\jconn4.jar” -Xmx256m sybsql” as current user

    TRACE      2015-05-25 10:13:34.586 (SYBSERVER3\Administrator) [synxcchapp.cpp:275] CSyChildApplicationImpl::doStart()
    Going to call CreateProcess/CreateProcessAsUser for ‘C:\Users\ADMINI~1\AppData\Local\Temp\sapinst_exe.1640.1432528457\jre\bin\java.exe’ now.

    TRACE      2015-05-25 10:13:34.586 (SYBSERVER3\Administrator) [synxcchapp.cpp:575] CSyChildApplicationImpl::doStart()
    Trying to start C:\Users\ADMINI~1\AppData\Local\Temp\sapinst_exe.1640.1432528457\jre\bin\java.exe CSySysLibCallsWrapper::syscallwrapper()->__CreateProcess__(NULL, <command line for executable C:\Users\ADMINI~1\AppData\Local\Temp\sapinst_exe.1640.1432528457\jre\bin\java.exe, NULL, NULL, TRUE, 0x420, NULL, NULL, &StartupInfo, &ProcessInfo)

    TRACE      2015-05-25 10:13:34.586 (SYBSERVER3\Administrator) [synxcchapp.cpp:653] CSyChildApplicationImpl::doStart()
    A child process has been started. Pid = 2896. Executable name: C:\Users\ADMINI~1\AppData\Local\Temp\sapinst_exe.1640.1432528457\jre\bin\java.exe

    INFO       2015-05-25 10:13:34.601 (SYBSERVER3\Administrator) [iaxxbjsmod.cpp:105] id=modlib.jslib.childAppSeeLog
    Output of C:\Users\ADMINI~1\AppData\Local\Temp\sapinst_exe.1640.1432528457\jre\bin\java.exe -classpath “C:\Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP\sybhelper.jar;C:\Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP\sybjdbc\jconn4.jar” -Xmx256m sybsql is written to the logfile sybsql.log.

    TRACE      2015-05-25 10:13:36.333 (SYBSERVER3\Administrator) [synxcpipe.cpp:172] CSyStdIOPipe::waitForOverlappedIO(int timeout)
    Syslib info about system call. OS message 109 (The pipe has been ended.

    ) after execution of system call ‘GetOverlappedResult’ with parameter ((pipe to child process)), line (133) in file (d:\depot\bas\720_rel\bc_720-2_rel\gen\optu\ntamd64\ins\sapinst\impl\src\syslib\synxcpipe.cpp).

    INFO       2015-05-25 10:13:36.489 (SYBSERVER3\Administrator) [iaxxbjsmod.cpp:105] id=modlib.jslib.childAppReturn
    Execution of the command “C:\Users\ADMINI~1\AppData\Local\Temp\sapinst_exe.1640.1432528457\jre\bin\java.exe -classpath “C:\Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP\sybhelper.jar;C:\Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP\sybjdbc\jconn4.jar” -Xmx256m sybsql” finished with return code 0. Output:
    use SW1
    quit

    TRACE      2015-05-25 10:13:36.489 (SYBSERVER3\Administrator)
    syb_verify_jdbc_connect2: return code 0

    TRACE      2015-05-25 10:13:36.489 (SYBSERVER3\Administrator)
    syb_verify_jdbc_connect2: login ok

    TRACE      2015-05-25 10:13:36.520 (SYBSERVER3\Administrator)
    syb_verify_jdbc_connect2: verifying login for dbuser sapsso host SYBSERVER2 port 4901 dbname SW1

    TRACE      2015-05-25 10:13:36.536 (SYBSERVER3\Administrator) [syxxcfile.cpp:85] CSyFileImpl::decideIfMoveCopyNode(const CopyMoveDestinationInfo & {m_nodeTypeForCombiCheck: …, m_path: C:/Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP/sybsql.8.log, m_realNodeType: 8}, ISyNode::CopyMoveMode_t 0x3, PSyNodeInt &) const
    Target node does not exist and (mode & ISyNode::MISSING) ==> I will copy/move.

    TRACE      2015-05-25 10:13:36.536 (SYBSERVER3\Administrator) [syxxcnode.cpp:425] CSyNodeImpl::move(const CSyPath & C:/Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP/sybsql.8.log, ISyNode::CopyMoveMode_t 0x3)
    Moved C:/Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP/sybsql.log to C:/Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP/sybsql.8.log

    INFO       2015-05-25 10:13:36.551 (SYBSERVER3\Administrator) [synxcpath.cpp:799] id=syslib.filesystem.creatingFile CSyPath::createFile()
    Creating file C:\Program Files\sapinst_instdir\BS2011\ERP606\LM\DBTOOLS\SYB\REPENV\SETUP\sybsql.log.

    TRACE      2015-05-25 10:13:36.551 (SYBSERVER3\Administrator)
    Starting “C:\Users\ADMINI~1\AppData\Local\Temp\sapinst_exe.1640.1432528457\jre\bin\java.exe -classpath “C:\Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP\sybhelper.jar;C:\Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP\sybjdbc\jconn4.jar” -Xmx256m sybsql” as current user

    TRACE      2015-05-25 10:13:36.551 (SYBSERVER3\Administrator) [synxcchapp.cpp:275] CSyChildApplicationImpl::doStart()
    Going to call CreateProcess/CreateProcessAsUser for ‘C:\Users\ADMINI~1\AppData\Local\Temp\sapinst_exe.1640.1432528457\jre\bin\java.exe’ now.

    TRACE      2015-05-25 10:13:36.551 (SYBSERVER3\Administrator) [synxcchapp.cpp:575] CSyChildApplicationImpl::doStart()
    Trying to start C:\Users\ADMINI~1\AppData\Local\Temp\sapinst_exe.1640.1432528457\jre\bin\java.exe CSySysLibCallsWrapper::syscallwrapper()->__CreateProcess__(NULL, <command line for executable C:\Users\ADMINI~1\AppData\Local\Temp\sapinst_exe.1640.1432528457\jre\bin\java.exe, NULL, NULL, TRUE, 0x420, NULL, NULL, &StartupInfo, &ProcessInfo)

    TRACE      2015-05-25 10:13:36.551 (SYBSERVER3\Administrator) [synxcchapp.cpp:653] CSyChildApplicationImpl::doStart()
    A child process has been started. Pid = 2216. Executable name: C:\Users\ADMINI~1\AppData\Local\Temp\sapinst_exe.1640.1432528457\jre\bin\java.exe

    INFO       2015-05-25 10:13:36.567 (SYBSERVER3\Administrator) [iaxxbjsmod.cpp:105] id=modlib.jslib.childAppSeeLog
    Output of C:\Users\ADMINI~1\AppData\Local\Temp\sapinst_exe.1640.1432528457\jre\bin\java.exe -classpath “C:\Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP\sybhelper.jar;C:\Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP\sybjdbc\jconn4.jar” -Xmx256m sybsql is written to the logfile sybsql.log.

    TRACE      2015-05-25 10:13:38.689 (SYBSERVER3\Administrator) [synxcpipe.cpp:172] CSyStdIOPipe::waitForOverlappedIO(int timeout)
    Syslib info about system call. OS message 109 (The pipe has been ended.

    ) after execution of system call ‘GetOverlappedResult’ with parameter ((pipe to child process)), line (133) in file (d:\depot\bas\720_rel\bc_720-2_rel\gen\optu\ntamd64\ins\sapinst\impl\src\syslib\synxcpipe.cpp).

    INFO       2015-05-25 10:13:38.720 (SYBSERVER3\Administrator) [iaxxbjsmod.cpp:105] id=modlib.jslib.childAppReturn
    Execution of the command “C:\Users\ADMINI~1\AppData\Local\Temp\sapinst_exe.1640.1432528457\jre\bin\java.exe -classpath “C:\Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP\sybhelper.jar;C:\Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP\sybjdbc\jconn4.jar” -Xmx256m sybsql” finished with return code 0. Output:
    use SW1
    quit

    TRACE      2015-05-25 10:13:38.720 (SYBSERVER3\Administrator)
    syb_verify_jdbc_connect2: return code 0

    TRACE      2015-05-25 10:13:38.720 (SYBSERVER3\Administrator)
    syb_verify_jdbc_connect2: login ok

    TRACE      2015-05-25 10:13:38.720 (SYBSERVER3\Administrator)
    syb_dialog_conf_hosts: ASE on host SYBSERVER3 is not prepared yet

    TRACE      2015-05-25 10:13:38.751 (SYBSERVER3\Administrator)
    syb_verify_jdbc_connect2: verifying login for dbuser DR_admin host SYBSERVER2 port 4901 dbname SW1

    TRACE      2015-05-25 10:13:38.767 (SYBSERVER3\Administrator) [syxxcfile.cpp:85] CSyFileImpl::decideIfMoveCopyNode(const CopyMoveDestinationInfo & {m_nodeTypeForCombiCheck: …, m_path: C:/Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP/sybsql.9.log, m_realNodeType: 8}, ISyNode::CopyMoveMode_t 0x3, PSyNodeInt &) const
    Target node does not exist and (mode & ISyNode::MISSING) ==> I will copy/move.

    TRACE      2015-05-25 10:13:38.767 (SYBSERVER3\Administrator) [syxxcnode.cpp:425] CSyNodeImpl::move(const CSyPath & C:/Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP/sybsql.9.log, ISyNode::CopyMoveMode_t 0x3)
    Moved C:/Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP/sybsql.log to C:/Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP/sybsql.9.log

    INFO       2015-05-25 10:13:38.798 (SYBSERVER3\Administrator) [synxcpath.cpp:799] id=syslib.filesystem.creatingFile CSyPath::createFile()
    Creating file C:\Program Files\sapinst_instdir\BS2011\ERP606\LM\DBTOOLS\SYB\REPENV\SETUP\sybsql.log.

    TRACE      2015-05-25 10:13:38.798 (SYBSERVER3\Administrator)
    Starting “C:\Users\ADMINI~1\AppData\Local\Temp\sapinst_exe.1640.1432528457\jre\bin\java.exe -classpath “C:\Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP\sybhelper.jar;C:\Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP\sybjdbc\jconn4.jar” -Xmx256m sybsql” as current user

    TRACE      2015-05-25 10:13:38.813 (SYBSERVER3\Administrator) [synxcchapp.cpp:275] CSyChildApplicationImpl::doStart()
    Going to call CreateProcess/CreateProcessAsUser for ‘C:\Users\ADMINI~1\AppData\Local\Temp\sapinst_exe.1640.1432528457\jre\bin\java.exe’ now.

    TRACE      2015-05-25 10:13:38.813 (SYBSERVER3\Administrator) [synxcchapp.cpp:575] CSyChildApplicationImpl::doStart()
    Trying to start C:\Users\ADMINI~1\AppData\Local\Temp\sapinst_exe.1640.1432528457\jre\bin\java.exe CSySysLibCallsWrapper::syscallwrapper()->__CreateProcess__(NULL, <command line for executable C:\Users\ADMINI~1\AppData\Local\Temp\sapinst_exe.1640.1432528457\jre\bin\java.exe, NULL, NULL, TRUE, 0x420, NULL, NULL, &StartupInfo, &ProcessInfo)

    TRACE      2015-05-25 10:13:38.813 (SYBSERVER3\Administrator) [synxcchapp.cpp:653] CSyChildApplicationImpl::doStart()
    A child process has been started. Pid = 2952. Executable name: C:\Users\ADMINI~1\AppData\Local\Temp\sapinst_exe.1640.1432528457\jre\bin\java.exe

    INFO       2015-05-25 10:13:38.813 (SYBSERVER3\Administrator) [iaxxbjsmod.cpp:105] id=modlib.jslib.childAppSeeLog
    Output of C:\Users\ADMINI~1\AppData\Local\Temp\sapinst_exe.1640.1432528457\jre\bin\java.exe -classpath “C:\Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP\sybhelper.jar;C:\Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP\sybjdbc\jconn4.jar” -Xmx256m sybsql is written to the logfile sybsql.log.

    TRACE      2015-05-25 10:13:40.015 (SYBSERVER3\Administrator) [synxcpipe.cpp:172] CSyStdOutErrPipe::onUnderflow(void * buf, int maxBytes, int timeout)
    Syslib info about system call. OS message 109 (The pipe has been ended.

    ) after execution of system call ‘ReadFile’ with parameter ((CSySysLibCallsWrapper::syscallwrapper()->__read__ end of child process output pipe)), line (385) in file (d:\depot\bas\720_rel\bc_720-2_rel\gen\optu\ntamd64\ins\sapinst\impl\src\syslib\synxcpipe.cpp).

    WARNING    2015-05-25 10:13:40.030 (SYBSERVER3\Administrator) [iaxxbjsmod.cpp:105] id=modlib.jslib.childAppReturn
    Execution of the command “C:\Users\ADMINI~1\AppData\Local\Temp\sapinst_exe.1640.1432528457\jre\bin\java.exe -classpath “C:\Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP\sybhelper.jar;C:\Program Files/sapinst_instdir/BS2011/ERP606/LM/DBTOOLS/SYB/REPENV/SETUP\sybjdbc\jconn4.jar” -Xmx256m sybsql” finished with return code 1. Output:
    java.sql.SQLException: JZ00L: Login failed.  Examine the SQLWarnings chained to this exception for the reason(s).
    at com.sybase.jdbc4.jdbc.ErrorMessage.raiseError(ErrorMessage.java:768)
    at com.sybase.jdbc4.tds.Tds.processLoginAckToken(Tds.java:5356)
    at com.sybase.jdbc4.tds.Tds.doLogin(Tds.java:725)
    at com.sybase.jdbc4.tds.Tds.login(Tds.java:579)
    at com.sybase.jdbc4.jdbc.SybConnection.tryLogin(SybConnection.java:422)
    at com.sybase.jdbc4.jdbc.SybConnection.handleHAFailover(SybConnection.java:3335)
    at com.sybase.jdbc4.jdbc.SybConnection.<init>(SybConnection.java:348)
    at com.sybase.jdbc4.jdbc.SybConnection.<init>(SybConnection.java:253)
    at com.sybase.jdbc4.jdbc.SybDriver.connect(SybDriver.java:232)
    at java.sql.DriverManager.getConnection(DriverManager.java:582)
    at java.sql.DriverManager.getConnection(DriverManager.java:185)
    at sybsql.main(sybsql.java:14)

    TRACE      2015-05-25 10:13:40.046 (SYBSERVER3\Administrator)
    syb_verify_jdbc_connect2: return code 1

    TRACE      2015-05-25 10:13:40.046 (SYBSERVER3\Administrator) [csistepexecute.cpp:1459]
    Function setMessageIdOfExceptionMessage: osmod.generic.message

    TRACE      2015-05-25 10:13:40.139 (SYBSERVER3\Administrator) [iaxxgenimp.cpp:638]  CGuiEngineImp::showMessageBox()

    Unable to connect to standby database as user DR_admin.
    The standby environment needs to be set up first before replication configuration can be done.

    TRACE      2015-05-25 10:13:40.139 (SYBSERVER3\Administrator) [iaxxgenimp.cpp:1035] CGuiEngineImp::acceptAnswerForBlockingRequest
    Waiting for an answer from GUI”

    ***************************************************************************************************

    please findf the screen capture for ipconfig, ping and nslookup

    Ipconfig

    /wp-content/uploads/2015/05/ipconfig_710389.png

    /wp-content/uploads/2015/05/ping_710411.png

    /wp-content/uploads/2015/05/nslookup_710412.png

    please advise.

    thanks

    Sai

    (0) 
  4. sai pavan vallabhaneni

    Hi Dominic,

    The issue is resolved.

    During the installation of SRS on Stand by DB, I have provided the path of profile directory of Primary DB. As a result of this, DR_admin user for Standby DB got created in Primary DB (I know it sounds crazy).

    I have uninstalled the SRS on Standby DB and reinstalled SRS using the path of profile directory on Standby DB (Only Empty DB is installed at the time when SRS is installed on Standby DB).

    I am able to successfully login using DR_admin on to Standby DB. I have resumed the SRS installation on Primary DB and I no longer get the issue with DR_admin.

    thanks

    Sai

    (0) 
  5. Abhijeet Siras

    Hi Dominic,

    I gone through your blog it is very nice.

    While doing DR on our side we are getting following error.

    Kindly suggest.

    ValidateLocalDREnv – Short Description – Verify that the local environment is setup and ready for disaster recovery replication setup to run.

    ValidateLocalDREnv – Failing Command Error Message – MUMBAI – Adaptive Server Enterprise – User ‘QAS_maint’ does not have ‘delete any table’ permission for database ‘master’.

    MUMBAI – Adaptive Server Enterprise – User ‘QAS_maint’ does not have ‘identity_insert any table’ permission for database ‘master’.

    MUMBAI – Adaptive Server Enterprise – User ‘QAS_maint’ does not have ‘identity_update any table’ permission for database ‘master’.

    MUMBAI – Adaptive Server Enterprise – User ‘QAS_maint’ does not have ‘insert any table’ permission for database ‘master’.

    MUMBAI – Adaptive Server Enterprise – User ‘QAS_maint’ does not have ‘select any table’ permission for database ‘master’.

    MUMBAI – Adaptive Server Enterprise – User ‘QAS_maint’ does not have ‘update any table’ permission for database ‘master’.

    MUMBAI – Adaptive Server Enterprise – User ‘QAS_maint’ does not have ‘execute any function’ permission for database ‘master’.

    MUMBAI – Adaptive Server Enterprise – User ‘QAS_maint’ does not have ‘execute any procedure’ permission for database ‘master’.

    MUMBAI – Adaptive Server Enterprise – User ‘QAS_maint’ does not have ‘delete any table’ permission for database ‘QAS’.

    MUMBAI – Adaptive Server Enterprise – User ‘QAS_maint’ does not have ‘identity_insert any table’ permission for database ‘QAS’.

    MUMBAI – Adaptive Server Enterprise – User ‘QAS_maint’ does not have ‘identity_update any table’ permission for database ‘QAS’.

    MUMBAI – Adaptive Server Enterprise – User ‘QAS_maint’ does not have ‘insert any table’ permission for database ‘QAS’.

    MUMBAI – Adaptive Server Enterprise – User ‘QAS_maint’ does not have ‘select any table’ permission for database ‘QAS’.

    MUMBAI – Adaptive Server Enterprise – User ‘QAS_maint’ does not have ‘update any table’ permission for database ‘QAS’.

    MUMBAI – Adaptive Server Enterprise – User ‘QAS_maint’ does not have ‘execute any function’ permission for database ‘QAS’.

    MUMBAI – Adaptive Server Enterprise – User ‘QAS_maint’ does not have ‘execute any procedure’ permission for database ‘QAS’.

    ValidateLocalDREnv – Hostname – PRDDRSRV

    SetupReplicationTask  Hostname                     

         QASSRV                                                                                           

    Regards,

    Abhijit

    (0) 
  6. Sampath Kumar

    Dear  Dominic Kebenei,

    I need your help.

    I our organisation we are planning to do DR site setup. Our SAP server is running in Sybase database. Please can you share step by step documents to me (sampathkumars1986@gmail.com)

    Thanks & Regards,
    Sampath Kumar S

    (0) 
  7. Raghunandan Kanugo

    When I click on the link for the document, it says as below:

     

    Sorry! This document is not publicly available.

    The owner has set this document to private.

    You will not be able to read it unless the owner changes it to public on their uploads page, or sends you a direct link.

    Can you share it as public please

     

    (0) 

Leave a Reply