Skip to Content

Prerequisites to upgrade to ORACLE 12c

1. Your DB should have minimum release Oracle Database 10.2.0.5 or higher to upgrade to Oracle Database  12c, any other release less than Oracle Database 10.2.0.5 cannot be directly upgraded to Oracle Database 12c


2. Only Oracle Database 12c Release 1 (12.1.0.2) is supported for SAP. Release 12.1.0.1 is not supported for SAP.


3. Additional Restriction for SAP NetWeaver AS-JAVA , For SAP products based on SAP NetWeaver 7.2x, 7.3x for AS-JAVA and AS-ABAP+JAVA (Java Stack and Double Stack) only Oracle Instant Client version 11.2.0.4 is currently supported. If you upgrade your Oracle Database to 12c or if you install a new SAP system with Oracle Database 12c, you must not upgrade to or install Oracle Instant Client version 12.1.0.2.


4. In-Memory Option is currently not yet supported for SAP


5. Multitenant Option is currently not yet supported for SAP.


6. ILM/ADO Functionality is currently not yet supported for SAP


7. Free Extended Support for Instant Client version 11.2.0.4 will end in January 2016


8. Create a new OS group oinstall


9. Create a new user oracle at OS level with same groups as assigned to user ora and migrate the DB to oracle user. Reference SAP note:  1915317 – Migrating Software Owner to ‘oracle’.


10. It is recommended to install the current version of SAP BR*Tools Release 7.40 before upgrading the database to 12c.


11. SAP LVM is currently not supported in an Oracle 12c based SAP NetWeaver environment. Certification pending. SAP note 2133079


12. SAP MDM is currently not supported in an Oracle 12c based SAP NetWeaver environment. Certification pending. SAP note 2133079


Upgrade checklist


1. Migrate the Oracle software from user ora to user oracle.


2. Install the Oracle database software version 12.1.0.2, including the recommended patches. For more information, see Installation of Oracle Database Software


3. If your Oracle instant client is lower than 11.2.0.4, install the version of the Oracle instant client that is currently recommended for Oracle 12c, which you can find in SAP Note 819829. When upgrading from Oracle 11g to 12c, you can perform this step before starting the actual database upgrade.


4. Update BR*Tools to the version recommended for Oracle 12c, which is BR*Tools 7.40.When upgrading from Oracle 11g to 12c, you can perform this step before starting the actual database upgrade.


5. Make sure that you have installed the SAP kernel supported with Oracle 12.1.0.2 and that you have a supported version of your operating system. In addition, make sure that you have installed the required support packages for the SAP kernel supported for Oracle 12c. For AS Java or AS ABAP + Java based systems, see also SAP Note 1777021. For more information, check the SAP requirements for your application or product in the Product Availability Matrix (PAM) at support.sap.com/pam. 6. Oracle Database 12c Release 1 (12.1) is only released and certified for SAP products running with SAP BASIS 7.00 and above, and SAP kernel release 7.21 EXT and above. Oracle 12.1 is only released and certified for Oracle client software version 11.2.0.4 or higher. 7. Configure secure storage in file system (SSFS) for ABAP, otherwise the SAP System cannot start because it cannot connect to the database. In addition, consider the dependencies on the SAP kernel version. When upgrading from Oracle 11g to 12c, you can perform this step before starting the actual database upgrade.

To report this post you need to login first.

2 Comments

You must be Logged on to comment or reply to a post.

  1. Naveen Garg Post author

    Hi Fidel,

    Document is not complete yet and will be referenced in other documents based on the further documents being added.

    However in my point of view if one single window gives users end to end view then that is helpful for larger public which gives them real experience and help in planning the activities on their side.

    Naveen

    (0) 

Comments are closed.