Skip to Content

Introduction

So perhaps like me you couldn’t help yourself and updated your local Java Run-time Environment to Update 40 of Java 8. That runtime is central to your loading of the development and configuration tools for PI. And just like me, you’ve probably tried really hard to not update the JRE but for whatever reason, some other dependent application on your computer required it and you had not choice.

This blog describes what happens when you do, due to changes to the Java security requirements as of Java 8 Update 20.

Symptom

Apart from the funky new blue colour of the Java logo, you have run into a problem where the ESR or ID would not open. The following screenshot is likely what you saw;

scnJavaError.jpg

You click on the link; Security level settings in the Java Control Panel and find out that


Starting with Java 8 Update 20, the Medium security level has been removed from the Java Control Panel. Only High and Very High levels are available.

Perhaps like me you smacked yourself in head thinking what a fantastic way to start the day.

Resolution

But don’t fear! Launch the Java Control Panel.

scnJavaCP.jpg

Navigate to the Security tab and click on the ‘Edit Site List’ – this will allow you to add the URL from where your are launching your ESR and ID from.

scnJavaFQDN.jpg

Really important to ensure that you fully type in the address. Wildcard prefixed address do not work. Eg, http://*.mydomain.com/ has no positive impact. (Which seemed ok in earlier versions with Medium Security enabled).

Once done relaunch ESR and ID and then continue on your merry way.

To report this post you need to login first.

2 Comments

You must be Logged on to comment or reply to a post.

Leave a Reply