Brief of Issue

Its not a frequent issue but can happen sometimes. Suppose we are adding an additional attribute in an existing infoobject which is in use heavily in lot of data models (for example Customer, Vendor, Business Partner or Material) & we accidentally make that attribute as time dependent instead of setting it as navigational and activate the object. Since newly added attribute is the first time dependent attribute in that master data a new table will be generated in background Q for time dependent attributes & additionally new fields will be added in transformation DATETO & DATEFROM. After activating the infoobject you realized that it wasn’t supposed to be time dependent. Then one can have hard time changing that attribute as time-independent.

Reverting it back to time independent & re-activation can lead to errors and leave the infoobject inactive.


Since M view is already altered & Q table is added causing failure of activation of infoobject-

1_S.jpg


In following part of the document I shall explain the steps to be taken to set the situation right.



Step 1

Open M view /BI*/M<Infoobject> in SE11 and click on “Where Used” button-

2S.jpg


/wp-content/uploads/2015/02/3s_653735.jpg

Step 2

Open each structure & table in edit mode in SE11 and check if there is any reference for M view of <Infoobject> in Foreign Keys-

/wp-content/uploads/2015/02/4s_653736.jpg

/wp-content/uploads/2015/02/5s_653737.jpg

Following deletion of foreign keys, re-activate the views/tables/structures.

Step 3

Once step 2 is completed successfully for all views/tables/structures found in where used list of M view, affected infoobject can be re-activated successfully.

Step 4

Foreign Keys can be added back in all the views/tables/structures based on this infoobject.

References:

OSS Note 134923 / 96295.

To report this post you need to login first.

Be the first to leave a comment

You must be Logged on to comment or reply to a post.

Leave a Reply