Skip to Content

I seem to make the same mistake every time there are updates, so this time I am documenting it.

I first always go to Installations & Upgrades at support.sap.com/swdc , but if you have Design Studio 1.x already installed, I don’t recommend it:

/wp-content/uploads/2014/11/1afig_594145.jpg

As of tonight there is no data available

Then I checked Support Packages & Patches – success!

/wp-content/uploads/2014/11/1figwhereisit_594158.jpg

There is a 64 bit and 32 bit version available.

/wp-content/uploads/2014/11/2update_594159.jpg

After downloading, I am prompted for an update and click next

/wp-content/uploads/2014/11/3success_594160.jpg

Success!

/wp-content/uploads/2014/11/4plugins_594161.jpg

As before, the plug-ins need to be re-installed, which prompts for a restart.

/wp-content/uploads/2014/11/5jumpto_594162.jpg

For fun I try out the report-to-report interface, with a BEx query that already has this set up on the back end.

The product availability matrix is also updated here for 1.4: https://websmp107.sap-ag.de/~sapidb/012002523100018972812014E/PAM_Additional_Info.pdf

The release note is not released externally yet however: SBOP Design Studio 1.4, note 2044609

The SAP 1.4 official tutorials are already available:

Design Studio 1.4: What’s new in SAP BusinessObjects Design Studio 1.4

Design Studio 1.4: Manipulate a Crosstab using a Context Menu

Design Studio 1.4: Create a Global Script Function

Design Studio 1.4: Create an RRI Jump Target

So time to check things out

To report this post you need to login first.

5 Comments

You must be Logged on to comment or reply to a post.

  1. karthik kumar

    Hi Tammy,

    I have upgraded DS 1.4 to DS 1.5.

    After Plugins are migrated it prompted for restart.

    DS1.5.jpg

    After restart the DS shows the following error.Attaching the Log as well.

    Please advise accordingly.

    Log:-

    eclipse.buildId=@qualifier@

    java.version=1.7.0_76

    java.vendor=SAP AG

    BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US

    Framework arguments:  BusinessObjects Design Studio

    Command-line arguments:  -os win32 -ws win32 -arch x86_64

    BusinessObjects Design Studio

    !ENTRY org.eclipse.equinox.ds 1 0 2015-11-19 12:11:31.479

    !MESSAGE Could not bind a reference of component

    com.sap.ip.bi.base.application.DeclaredServiceActivator. The

    reference is: Reference[name = IActivatorBase, interface =

    com.sap.ip.bi.base.bundle.IActivatorBase, policy = dynamic,

    cardinality = 0..n, target = null, bind = addRICActivator, unbind

    = removeRICActivator]

    !ENTRY org.eclipse.equinox.p2.publisher.eclipse 4 0 2015-11-19

    12:12:02.753

    !MESSAGE Unable to acquire PluginConverter service during

    generation for: C:\Program Files\SAP BusinessObjects\Design

    Studio\plugins

    \com.sap.ip.bi.external.ngdbc.wrapper_2.27.0.20150209121159.

    !ENTRY org.eclipse.equinox.p2.publisher.eclipse 4 0 2015-11-19

    12:12:04.024

    !MESSAGE Unable to acquire PluginConverter service during

    generation for: C:\Program Files\SAP BusinessObjects\Design

    Studio\plugins

    \org.eclipse.core.runtime.compatibility.registry_3.5.200.v20130514

    -1256.

    !ENTRY org.eclipse.equinox.p2.publisher.eclipse 4 0 2015-11-19

    12:12:04.183

    !MESSAGE Unable to acquire PluginConverter service during

    generation for: C:\Program Files\SAP BusinessObjects\Design

    Studio\plugins

    \org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.200.v20140116

    -2212.

    !ENTRY org.eclipse.equinox.p2.publisher.eclipse 4 0 2015-11-19

    12:12:05.195

    !MESSAGE Unable to acquire PluginConverter service during

    generation for: C:\Program Files\SAP BusinessObjects\Design

    Studio\plugins

    \com.sap.ip.bi.external.ngdbc.wrapper_2.27.0.20150209121159.

    !ENTRY org.eclipse.equinox.p2.publisher.eclipse 4 0 2015-11-19

    12:12:05.211

    !MESSAGE Unable to acquire PluginConverter service during

    generation for: C:\Program Files\SAP BusinessObjects\Design

    Studio\plugins

    \org.eclipse.core.runtime.compatibility.registry_3.5.200.v20130514

    -1256.

    !ENTRY org.eclipse.equinox.p2.publisher.eclipse 4 0 2015-11-19

    12:12:05.216

    !MESSAGE Unable to acquire PluginConverter service during

    generation for: C:\Program Files\SAP BusinessObjects\Design

    Studio\plugins

    \org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.200.v20140116

    -2212.

    !ENTRY org.eclipse.equinox.p2.publisher.eclipse 4 0 2015-11-19

    12:12:05.513

    !MESSAGE Unable to acquire PluginConverter service during

    generation for: C:\Program Files\SAP BusinessObjects\Design

    Studio\plugins

    \com.sap.ip.bi.external.ngdbc.wrapper_2.27.0.20150209121159.

    !ENTRY org.eclipse.equinox.p2.publisher.eclipse 4 0 2015-11-19

    12:12:05.531

    !MESSAGE Unable to acquire PluginConverter service during

    generation for: C:\Program Files\SAP BusinessObjects\Design

    Studio\plugins

    \org.eclipse.core.runtime.compatibility.registry_3.5.200.v20130514

    -1256.

    !ENTRY org.eclipse.equinox.p2.publisher.eclipse 4 0 2015-11-19

    12:12:05.536

    !MESSAGE Unable to acquire PluginConverter service during

    generation for: C:\Program Files\SAP BusinessObjects\Design

    Studio\plugins

    \org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.200.v20140116

    -2212.

    (0) 

Leave a Reply