Skip to Content
Author's profile photo Ajay Venkatesh

SAP HANA Text Join Issue/Resolution

This blog is to address a common problem related to a “Text Join” in SAP HANA graphical modelling (SAP HANA version SP08 & below).

For Example, in the following example the text join has been setup correctly, marking ‘SPRAS’ as a language column.

Blog1.png

And also the Default Language is set to “English

Blog2.png

Problem:

The model which has the text-join will get activated successfully but in some cases the data-preview will provide ‘NULL’ values for the test description

Blog3.png

Though the text description table has values for ‘English


Blog4.png

Resolution:

The text join only recognizes the single character representation in the language column. So the value in the “SPRAS” column needs to be ‘E’ instead of ‘EN’ and ‘D’ instead of ‘DE’, etc.

Blog5.png

Once we make this change of “EN” to “E”, “DE” to “D” etc , we notice that the data-preview has the correct text description.

Blog6.png

Assigned tags

      4 Comments
      You must be Logged on to comment or reply to a post.
      Author's profile photo Ramkumar S
      Ramkumar S

      Nice article!

      Author's profile photo Former Member
      Former Member

      Good Doc Ajay.

      Author's profile photo sudhanshu sharma
      sudhanshu sharma

      Hi,

       

      I'm having 'E' only but still facing same problem. please advise.

      Thank you

      Author's profile photo Former Member
      Former Member

      when i m trying to choose spars language, there is no spars language option.