Skip to Content

The internet has been buzzing with news about the latest Microsoft Internet Explorer security hole, which was patched today (see Microsoft blog post, Out-of-Band Release to Address Microsoft Security Advisory 2963983). The bug affected multiple browser versions, from the obsolete Internet Explorer 6.0 to the latest Internet Explorer 11, causing even the United States government to recommend alternative browsers (see United States Computer Emergency Readiness Team note, Microsoft Internet Explorer Use-After-Free Vulnerability Guidance). Microsoft even took the extraordinary step of patching Windows XP, which is technically no longer under patch support.

Two years ago, SAP analytics customers couldn’t move to the then-latest Internet Explorer 9.0 due to SAP’s lack of support and compatibility issues. Nine months after IE9 was officially released, customers were still waiting for SAP to support it (see ASUG News article, Waiting on SAP, User Communities Fix SAP BusinessObjects Browser Woes).


Today, SAP delivers much more prompt platform support for browsers, databases, and operating systems. Support for Internet Explorer 11- which is Microsoft’s latest browser for Windows 7 and Windows 8/8.1- is already available in SAP BusinessObjects Enterprise XI 3.1 Service Pack 7 (SP7) and higher, SAP BusinessObjects Business Intelligence 4.0 Support Pack 9 (SP9) and higher, and SAP BusinessObjects Business Intelligence 4.1 Support Pack 3 (SP3) and higher. These versions also support Java 7, which is significant if your organization depends on Web Intelligence.

With this most recent security issue, even the latest Internet Explorer 11 was affected. But as a general rule, later browser versions have more security features than their predecessors, whether the vendor is Microsoft, Mozilla, Google or Apple. If your organization’s security officers are leading the charge to move up from earlier browsers such as Internet Explorer 9, it’s worth creating a project plan to patch up to these latest releases of the SAP business intelligence platform.

To report this post you need to login first.

3 Comments

You must be Logged on to comment or reply to a post.

  1. Lee Lewis

    Thanks Mark,  wish we could say the same for SAP Enterprise Portal where we host our BI content.  We are on 7.3.1 SP7, pretty current, but lots of erratic display problems. 

    Seems the solution is in SP9 or greater.  We have tried SP 11 and while IE11 is ok, there are other issues introduced in BW that now SAP says are fixed in SP12…. Argh.

    Now we are just going to move to 7.4 SP8 hoping that SAP portal can keep pace with browser innovations… or maybe move to Chrome as the browser standard and uninstall IE altogether!

    (0) 
  2. Dallas Marks Post author

    Microsoft is ending support for IE 8, 9, and 10 on January 12, 2016 (see Microsoft announcement). All SAP BusinessObjects customers should verify that they are on SAP BusinessObjects Business Intelligence 4.1 SP3 or higher (BI 4.1 SP7 is the most recent support pack) for Internet Explorer 11 support, especially now that that SAP BusinessObjects Enterprise XI 3.1 and SAP BusinessObjects Business Intelligence 4.0 are also out of mainstream support (as of December 31, 2015).

    (0) 

Leave a Reply