Skip to Content

Dear Followers,

Over the past weeks we are seeing many incidents being opened by BI Java customers which upgraded their portal systems to Netweaver 7.30 SPS 09, 10 and 11, NW 7.31 SPS 09, 10 and 11 and NW 7.40 SPS 04, 05 and 06.

The cause for the issue is a missing .jar file (urbrowser) on EP-BASIS SCA, because of a regression caused by SAP Note 1972506.

Our development team has already delivered two notes with the corrections for this:

1995970 – Missing urbrowser.jar caused an exception com.sapportals.portal.useragent.UserAgentSetException
2000082 – Runtime Exception when trying to add new user agent string

Please refer to these notes on which patch contains the corrections for the relevant NW Portal version you are using.

We hope with these new patches the issue is completely solved now.

Kind Regards,
Marcio

To report this post you need to login first.

9 Comments

You must be Logged on to comment or reply to a post.

    1. Marcio Evaldt Post author

      Hi Anton,

      As per the note which caused the issue (1972506), SPS 11 and 12 for 7.30 and 7.31 should not be affected by this. In any case, if you have this issue in any of these SPs, I am going to inform development for evaluation.

      Best Regards,
      Marcio

      (0) 
    2. Marcio Evaldt Post author

      SPS 11 for 7.30 and 7.31 also affected by the issue. SPS 6 for 7.40, too. Original Post updated and fixes for those SPS levels already released.

      (0) 
  1. Claus-Peter Paffrath

    Hi Marcio,

    for the Patch you mentioned (in my case 7.40 SP6) there are some SCA dependencies mentioned. But one -Java Support Pacacke Manager 7.40 001 is not available at this time.

    So my question: it is a must for this patch to resolve all dependencies or it is possible to deploy only this patch with SUM?

    We have a critical timeframe reqarding a presentation…

    Thanks and Regards

    Peter

    (0) 
    1. Marcio Evaldt Post author

      Hello Peter,

      Could you please let me know on which SPS level and what BI Java patches do you have at this moment? At first you just need to deploy this single patch (see KBA 1906520 for an alternative), but let me confirm after having your system info.

      Cheers,
      Marcio

      (0) 
  2. Claus-Peter Paffrath

    Hi Marcio,

    thank you for your quick response.

    The system is a new installed SAP BW 7.4 SR1 (SPS05) on HANA, in April we have deployed SPS06. All Components are on:

    1000.740.6.0

    Is that enough information?

    Thanks and best Regards

    Peter

    (0) 
    1. Marcio Evaldt Post author

      Hi Peter,

      Yes, thanks. In this case just deploy the PORTAL BASIS 7.40 SPS06 patch 1 on your system as per SAP Note 1995970 to solve this issue. This is enough.

      Kind Regards,
      Marcio

      (0) 
  3. Claus-Peter Paffrath

    Hi Marcio,

    many thanks, deployed -> ok. Presentation at customer site tomorrow: solved 🙂 .

    Hopefully I can assist regarding other problems in future.

    Best Regards

    Peter

    (0) 

Leave a Reply