Skip to Content
Author's profile photo ILIAN Grigorov

Compile Error in hidden module: modMainRoutines

The error message Compile Error in hidden module: modMainRoutines is given when you try to export your EWA reports

from your Solution Manager system -> Microsoft Word.

I get this error with Solution Manager 7.0 EHP1 SP29 (Nov.2012), and SAP GUI 730, patch 7.

Windows 7 (64bit), Microsoft Office 2010 (64bit)

Reason:

As far as I discovered the problem is in the VBA Macros in the .dot file Earlywatch_Alert_xxxxx__xxxxx_xxxxx.dot in your

C:\Users\<USER>\AppData\Roaming\Microsoft\Templates.

This Macros is not able to run on 64bit Microsoft Office and you cannot correct it, because it is password protected.

(My be you don’t have to correct it because your solman will overwrite it every time you download a new EWA report)

(You have to correct the code in the solman system 🙂 )

Solution:

I shall write again after we upgrade to Solution Manager 7.1.

I could not find this problem in the SAP Notes either.

Until then – install 32bit Microsoft Office.

If you have any other solutions , please share!

Regards!

SmallUpdate

-=13.02.2015=-

I recently saw a post here Re: SOFFICEINTEGRATION205 – Error occurred while reading object property

to check note  1442028. It explains the incompatibility between the 32bit GUI and 64bit Office.

I am not very sure shall it SAPGUI 64bit solve this very problem…..

Also checked note with similar problem “1552461 – Excel: Compile error in hidden module: modEV”

and the solution there is quite short and clear: “Install Office 2010 (32Bit) instead of office 2010 (64bit).”

Assigned tags

      2 Comments
      You must be Logged on to comment or reply to a post.
      Author's profile photo Former Member
      Former Member

      HI ILIAN,

      i know that this topic is really old but did you resolve this issue ?

      we have the same problem with solman 7.1.

      best reards

      Author's profile photo ILIAN Grigorov
      ILIAN Grigorov
      Blog Post Author

      Hi Pawel.

      Right now I am upgrading to Solution Manager 7.1

      One of the first things I tested, was this, and it does not work again 🙁

      They have to rewrite the macros which executes in Word. I have not tried with GUI 7.40 , but I don't hink it is relevant

      Regards