Skip to Content

Error:

Due to security related changes made to the client software (owned by Oracle), we now have a new error/bug which occurs when launching the PI Integration Builder.

This will effect anyone using the new Java release version 1.7.0_51 (and any subsequent releases). The error thrown is:

“The new version of Java does not allow users to run the applications
that are not signed (Unsigned), Self signed (not signed by trusted
authority) and the applications that are missing permission attributes.”

There is also a related Warning message which anyone using the Java release 1.7.0_45 will encounter, although you will be able to access the Enterprise Services Repository (ESR). The exact warning:

“This application will be blocked in a future Java security update

because the JAR file manifest does not contain the Permissions

attribute.  Please contact the Publisher for more information”.

Background:

See this URL for further details on the background to this change – New security requirements for RIAs in 7u51 (January 2014)

Solution:

SAP have created note 1959264 Java Applet Security Warnings for PI Dev Tools, to fix this issue. The fixes will be available shortly, for the last 3 SP’s of each PI release. Fixes can be provided for older SP’s as required.

Workaround:

A workaround is provided in this URL: Why are Java applications blocked by your security settings with the latest Java?

Another workaround is to use a Java version lower than the 1.7.0_51 release.

To report this post you need to login first.

9 Comments

You must be Logged on to comment or reply to a post.

  1. Jörg Thiesmann

    Hello Mark,

    your blog was published slightly before the note was updated with some fixes. Does this mean we still have to wait for a final correction or is the one available in the note already final? If so, could you please update your blog to avoid confusion?

    Thanks for informing us of this fix,

    Jörg

    (0) 
    1. Mark Smyth Post author

      Hi Jörg,

      The note is still a work in progress. We are still testing/validating some of the fixes for this issue. But some fixes, for some SP’s and releases are currently available. We will be providing fixes for the 3 most recent SP releases, for each PI release. These should be available within the next week.

      Fixes for older SP releases will be provided on request. The note will be updated with the fixes as and when they become available.

      Regards
      Mark

      (0) 
      1. Jörg Thiesmann

        Hello Mark,

        our system is on version 7.31, SP7. In the note I find patches for 7.30 SP7, SP8 and SP9, but from version 7.31 only SP5 and SP12. (How can there be an SP12 patch?) Which one would be the right one for our system? Is the 7.30 version compatible to 7.31?

        Best regards,

        Jörg

        (0) 
        1. Mark Smyth Post author

          Hi Jörg,

          Sorry for the delay in getting back to you. I definitely replied to this a few days ago but it doesn’t seem to have posted. Anyhow…

          – The 7.30 versions are not compatible with 7.31. Don’t deploy these on your 7.31 system.

          – There are a lot of fixes required for this issue, covering several PI Software Components, all PI releases and several SP’s. So it is taking a little longer than usual to get the fixes validated and released. The fixes for 7.31 SP07 are still going through the validation process and will take at least 1 more week before these are released.

          – You can see SP12 in the note because this is the SP that the fix is fully integrated into. Although it is not yet released, the fix will be available in SP12 PL0. All previous SP’s will require a patch for this issue.

          Regards

          Mark

          (0) 
          1. Jörg Thiesmann

            Hi Mark,

            are those patches still planned to be delivered? I work in an environment where policies don’t allow us to go back to an older Java version. We currently tuned down Java security, but the security department only accepted that as an ad interim solution and is expecting a date when this is going to be fixed. Would you recommend me to wait for the patch or rather perform an SP upgrade such that the available patches (SP9) can be applied?

            Regards,

            Jörg

            (0) 
            1. Mark Smyth Post author

              Hi Jörg,

              I have checked with the developer again and the fix for SP07 is now at an advanced stage. It should be available within the next week.

              Regards
              Mark

              (0) 
              1. Jörg Thiesmann

                Hi Mark,

                I could just test them successfully in production system (SP07). Just in time before OS security would reset our Java security setting to “high”. Thanks again for your support!

                Jörg

                (0) 

Leave a Reply