Skip to Content

SAP NetWeaver BW Powered by SAP HANA: Three things to know when using the BW modeling tools in Eclipse

The BW modeling tools provide a new development environment editing BW metadata objects. The development environment is based on the SAP HANA studio and will be available as an own perspective in it.

The BW modeling tools support the tasks of BW modelers with a light and user-friendly Eclipse UI. Integration with ABAP Development Tools and SAP HANA
modeling empowers the datawarehouse modeler to combine SAP HANA views and BW metadata objects within the same modeling environment.

  1. For information about installation and the prerequisites for installation, go to http://service.sap.com/installnw74  -> Installation – Clients.
    Please read note 1954169 first and follow the client installation instructions as described in that note (http://service.sap.com/sap/support/notes/1954169)
    Assign the missing authority for resources related to BW Modeling Tools in the BW backend. Please see note 1969032 for details http://service.sap.com/sap/support/notes/1969032
  2. With SAP Netweaver BW 7.4 SP5 new editors are available to define CompositeProviders and OpenODSViews.
  3. For other BW InfoProviders, you can use the SAP GUI-based maintenance interfaces that are integrated in the BW modeling tools

 

Further information how to create

a) an OpenODSView can be found in https://scn.sap.com/docs/DOC-50504

b) a new CompositeProvider (SAP BW 7.4 SP5 based)  .can be found in https://scn.sap.com/docs/DOC-52329

To report this post you need to login first.

22 Comments

You must be Logged on to comment or reply to a post.

  1. Naveen Kumar Ketha

    Thanks for the update Stefan. can you please update on the future roadmap of BW modelling tools. Is everything moving away from GUI to this new eclipse tool. I think its good to have one tool for all BW modelling.

    (0) 
  2. sidharth mishra

    Hi Stefan,

    I understand we can create Composite providers using Eclipse.

    But i wanted to know is it possible to create other infoobjects as well from Eclipse now?

    I am on SP7.

    Best regards,

    Sidharth mishra

    (0) 
    1. Stefan Hoffmann Post author

      Hello Sidharth,

      you can always call the already existing InfoObject editor in Eclipse as all the other native GUI editors. As mentioned above, our next editor will be the QueryDesigner which will be available. We are currently defining the roadmap for the next wave, so once this is finalized we will publish it on our BW page.

      Regards

      Stefan

      (0) 
      1. Des Gallagher

        Hi Stefan,

        Is the roadmap of what will be in the next wave of Eclipse in terms of BW modeling available yet? If not do you have an approx planned date for this?

        Thanks and happy Easter !

        Des

        (0) 
        1. Stefan Hoffmann Post author

          Hello Des,

          as written above, the next Eclipse based editor will be the Query Designer.

          We have some ideas regarding the next editors, but it’s too early to communicate things. The stratetegy is to develop new, modern, easy to use editors which offer additional value for the mixed case scenarios (BW on HANA & HANA native datamarts).

          Promised. As soon as I know more I’ll let you know.

          Regards

          Stefan

          (0) 
    1. Stefan Hoffmann Post author

      Hello,

      Just double click on an InfoCube in the Eclipse environment for example and the native InfoCube maintenance transaction will open within the Eclipse environment.

      Regards

      Stefan

      (0) 
  3. sidharth mishra

    Hi Stefan,

    I installed the studio with BW Development Tools.

    But from where can i create new infoobjects (like DSO,Infocubes.etc.)?

    If i right click on an Infoarea i get options to create new Composite provider and Open ODS View.

    BWEclipse.png

    (0) 
    1. Dinesh Anblazahan

      Hi Mishra,

                 The modelling in eclipse is possible only for composite provider and Open ODS object.But you can invlove the ABAP screen in eclipse and cretae infoobjects ,cubes or any BW objects.To do that double click on any cube that is visible under project explorer,then in the commnad filed type RSA1 or any transaction code and work further on.EClipse_modelling.PNG
      Thanks & Regards

        A.Dinesh

      (0) 
      1. sidharth mishra

        Hi Dinesh,

        Thanks for the information.

        I currently face an issue when i try to open any BW infoobject.

        The error is

        Caused by: org.eclipse.ui.PartInitException: Unable to open editor, unknown editor ID: com.sap.adt.sapgui.ui.editors.WinGuiEditor

        Have you faced a similar issue.

        I am on rev 70, SAP GUI 7.3.

        Best regards,

        Sidharth Mishra

        (0) 
        1. Dinesh Anblazahan

          Hi Sidharth,

               Did you follow the note 1954169 correctly? i feel this issue is due to uncompatible version across different component.

          You just double check the note and cross verify have you followed all steps correctly.

          Thanks & Regards

          A.Dinesh

          (0) 
  4. Martin Maruskin

    Hi Stefan,

    I read in some SAP NOte that I need to have few plug-ins into My SAP HANA Studio in order to developed objects like CompositeProviders and OpenODSViews.

    I tried to search on service.sap.com/swdc for those plugins but I haven’t succeeded so far.

    Any idea why there from where to download them ?

    PS: why plugin to HANA Studio are not available on same site where SAP HANA is:

    SAP | HANA Developer Edition

    thanks,

    m./

    (0) 
    1. sidharth mishra

      hi Martin,

      Please follow the note 1954169.

      It lists down the steps and by following it you will have all the plugins installed.

      I dont think we have the plugins available individually.

      Best regards,

      Sidharth Mishra

      (0) 
  5. Balaji S

    Hi All,

    I am trying to install the BW Modeler perspective in HANA Studio and I am getting the below error. I am using rev80 studio and I am using the the below link to download the features

    https://tools.hana.ondemand.com/luna

    https://tools.hana.ondemand.com/kepler/


    I installed the below features before installing ABAP Development tools


    Feature Name

    Feature ID

    EMF Model Query

    org.eclipse.emf.query

    Mylyn Commons

    org.eclipse.mylyn.commons

    Mylyn Task-Focused Interface

    org.eclipse.mylyn.context_feature

    I could install ABAP Development tools without any issue. Once done when I choose Modelling tools for SAP BW on HANA from the available software list and click next I get this error.

    BWT.png

    Cannot complete the install because of a conflicting dependency.

      Software being installed: BW DataStore Object (Developer Edition) 1.6.1 (com.sap.bw.feature.adso.devedition.feature.group 1.6.1)

      Software currently installed: SAP HANA Studio Database Development 1.80.3 (com.sap.ndb.studio.dbdev.feature.feature.group 1.80.3)

      Software currently installed: SAP HANA Studio (Base) 1.80.3 (com.sap.ndb.studio.product.base 1.80.3)

      Only one of the following can be installed at once:

        SAP HANA Studio – Product Feature 1.80.3 (com.sap.ndb.studio.feature.feature.jar 1.80.3)

        SAP HANA Studio – Product Feature 2.0.7 (com.sap.ndb.studio.feature.feature.jar 2.0.7)

      Only one of the following can be installed at once:

        SAP HANA Studio – Base Model 1.80.3 (com.sap.ndb.studio.model.base 1.80.3)

        SAP HANA Studio – Base Model 2.0.7 (com.sap.ndb.studio.model.base 2.0.7)

      Cannot satisfy dependency:

        From: BW Controller Form Model 1.6.1 (com.sap.bw.controller.form 1.6.1)

        To: bundle com.sap.ndb.studio.model.base 1.82.0

      Cannot satisfy dependency:

        From: BW DataStore Object (Developer Edition) 1.6.1 (com.sap.bw.feature.adso.devedition.feature.group 1.6.1)

        To: com.sap.bw.feature.adso.feature.group [1.6.1]

      Cannot satisfy dependency:

        From: BW DataStore Object 1.6.1 (com.sap.bw.feature.adso.feature.group 1.6.1)

        To: com.sap.bw.feature.base.feature.group [1.6.1]

      Cannot satisfy dependency:

        From: BW Modeling Tools Base 1.6.1 (com.sap.bw.feature.base.feature.group 1.6.1)

        To: com.sap.bw.controller.form [1.6.1]

      Cannot satisfy dependency:

        From: SAP HANA Studio – AFL Connector Feature 1.80.3 (com.sap.ndb.studio.aflconnector.feature.feature.group 1.80.3)

        To: com.sap.ndb.studio.foundation.feature.feature.group 1.0.0

      Cannot satisfy dependency:

        From: SAP HANA Studio Database Development 1.80.3 (com.sap.ndb.studio.dbdev.feature.feature.group 1.80.3)

        To: com.sap.ndb.studio.aflconnector.feature.feature.group 1.0.0

      Cannot satisfy dependency:

        From: SAP HANA Studio – Product Feature 1.80.3 (com.sap.ndb.studio.feature.feature.group 1.80.3)

        To: com.sap.ndb.studio.feature.feature.jar [1.80.3]

      Cannot satisfy dependency:

        From: SAP HANA Studio – Product Feature 2.0.7 (com.sap.ndb.studio.feature.feature.group 2.0.7)

        To: com.sap.ndb.studio.feature.feature.jar [2.0.7]

      Cannot satisfy dependency:

        From: SAP HANA Studio – Foundation 1.80.3 (com.sap.ndb.studio.foundation.feature.feature.group 1.80.3)

        To: com.sap.ndb.studio.model.base [1.80.3]

      Cannot satisfy dependency:

        From: SAP HANA Studio – Foundation 2.0.7 (com.sap.ndb.studio.foundation.feature.feature.group 2.0.7)

        To: com.sap.ndb.studio.feature.feature.group 2.0.7

      Cannot satisfy dependency:

        From: SAP HANA Studio (Base) 1.80.3 (com.sap.ndb.studio.product.base 1.80.3)

        To: com.sap.ndb.studio.feature.feature.group [1.80.3]

    I believe some of you have already got similar error and have got it fixed. Strangely I had installed and working on this while we were on rev70 and I had 32bit Studio on my old laptop. But this doesnt work on my new laptop which is 64bit and has 64bit studio.

    Also I have tried the steps in 1954169 – BWMT – Installation details


    I have even tried downloading the BW Modeler package from SWDC and used the unzipped files as repository and tried installing still the same error.


    Can some one please advise whats wrong?


    Regards,

    B

    (0) 
    1. Aneesh Kumar R

      Hi Balaji,

      I see that you are trying to consume BWMT 1.6.1

      Can you please use HANA Studio Rev 84 or 85 and ADT 2.36.1

      Please let me know if this does not work

      Thank you

      Aneesh Kumar

      (0) 
      1. Akshay Bhandari

        Hello Aneesh,

        We have installed HANA Studio Rev 84. But still we are facing the same issue..

        ==================================================================

           Cannot complete the install because one or more required items could not be found.

          Software being installed: BW CompositeProvider 1.8.9 (com.sap.bw.feature.hcpr.feature.group 1.8.9)

          Missing requirement: BW Connectivity 1.8.9 (com.sap.bw.connectivity 1.8.9) requires ‘bundle com.sap.adt.compatibility 2.24.0’ but it could not be found

          Cannot satisfy dependency:

          From: BW Editor Base 1.8.9 (com.sap.bw.editor.ui 1.8.9)

          To: bundle com.sap.bw.connectivity 1.1.0

          Cannot satisfy dependency:

          From: BW Modeling Tools Base 1.8.9 (com.sap.bw.feature.base.feature.group 1.8.9)

          To: com.sap.bw.editor.ui [1.8.9]

          Cannot satisfy dependency:

          From: BW CompositeProvider 1.8.9 (com.sap.bw.feature.hcpr.feature.group 1.8.9)

          To: com.sap.bw.feature.base.feature.group [1.8.9]

        ==================================================================

        Can you please help us out.

        Many Thanks

        Regards

        Akshay

        (0) 
        1. Rainer Schaefer

          Hello Akshay,

          1.) The HANA Studio revision is very old. I would recommend to install the latest version of the SAP HANA Studio 2 (Rev 110). The latest version of the SAP HANA Studio can operate with an older SAP HANA database revision like revision 84. So, there is no need to update the HANA database

          2.) Install the latest version of ABAP Development Tools (version 2.54)  and BW Modeling Tools (version 1.12). Details can be found in the release information note of BW Modeling Tools version 1.12: 2233558.

          Videos on how to install and update the BW Modeling Tools can be found here: http://scn.sap.com/docs/DOC-64470

          Kind regards,

          Rainer

          (0) 
  6. Christophe Posson

    Hi Stefan,

    I am looking for proof that you can use the BW modeling perspective in HANA Studio without the need of a direct database connection to the HANA database itself.
    In other words, can you use the BW modeling tools to connect to the BW back-end application server only and not give the developers access to the HANA Database directly (so no access in the Administrator perspective, Modeling perspective and so on..)

    Reason I am asking is that our basis team is not convinced that we will not mess up the  HANA database once we have access to the BW modeling tools 🙂

    Can you help me out with this?

    Many thanks!

    Kind regards,
    Christophe

    (0) 
    1. Dominik Kacprzak

      Hi,

      Do you have DB/HANA user id for developers? Can you log in to HANA with your BW user? I think they are created separately.
      Other point is that Basis team can setup authorizations for users giving access here and there.

      Regards,
      Dominik

      (1) 
  7. Dominik Kacprzak

    Hi,

    What about SSO for 64 BIT version of HANA Studio/Eclipse? Current dll for SSO is 32 bit.
    Is there any way of migrating or creating shadow DLL with 32 and 64 bit?

    Regards,
    Dominik

    (0) 

Leave a Reply