1. send one mail to IC inbox for example using outlook:

/wp-content/uploads/2013/12/clipboard1_348664.png

2. go to SWEL to check if there is one entry for the mail you just sent

/wp-content/uploads/2013/12/clipboard2_348710.png

3. go to tcode SWI1, you will find two entries for the mail you just sent, choose entry with Status = READY.

/wp-content/uploads/2013/12/clipboard3_348711.png

set a breakpoint in the method below, then execute the selected entry.

/wp-content/uploads/2013/12/clipboard4_348712.png

4. in debugger change the content of ls_rfc_dest-rfcdest to “NONE”.

/wp-content/uploads/2013/12/clipboard5_348713.png

5. go to SM58, you will find one entry for background execution in step4.

/wp-content/uploads/2013/12/clipboard6_348714.png

if you could not find any entry, please check whether you have marked Block Sending in your debugger setting.

/wp-content/uploads/2013/12/clipboard7_348715.png

Once “Debug LUW” is clicked, a new debugger will pop up. Now you can debug the workflow execution.

/wp-content/uploads/2013/12/clipboard8_348716.png

Once you finished debugging, you can go back to SWI1 and three background steps have already been marked as COMPLETED.

/wp-content/uploads/2013/12/clipboard9_348718.png

and the mail item could be found in IC inbox now.

/wp-content/uploads/2013/12/clipboard10_348719.png

To report this post you need to login first.

1 Comment

You must be Logged on to comment or reply to a post.

  1. Faisal PC

    Hi Jerry,

    This is really helpful. I was searching for the same. However, I get the following message when I click on execute after selecting the work item in SWI1.

    No administrator found for the task”

    Could you please advice.

    Thanks,

    Faisal

    (0) 

Leave a Reply