Skip to Content

Goto OANR & provide the Number range Interval

/wp-content/uploads/2013/12/22_348270.png

Now provide the Document type

Goto SPRO–>IMG–>SAP Netweaver–>Application server–>Basis Services–>Archive link–>Print list Customizing–>Edit Document types.

/wp-content/uploads/2013/12/23_348271.png

Check the document class set to JPG or not.

Now to link the Employee photo In IT0002

Goto SPRO–>IMG–>Personnel Management–>Personnel Administration–>Tools–>Optical Archiving–>Set up Optical Archiving in HR

/wp-content/uploads/2013/12/24_348275.png

Now define Content server ID

Goto SPRO–>IMG–>SAP Netweaver–>Basis services–>Archive link–>Basic Customizing–>Define Content Repositories  or Use T-code OACO

/wp-content/uploads/2013/12/25_348276.png

Created Custom Content Repository ZH instead of std A2

/wp-content/uploads/2013/12/26_348277.png

Now click on Edit links in the same navigation

/wp-content/uploads/2013/12/27_348278.png

/wp-content/uploads/2013/12/28_348279.png

Link the Content Repository ID ‘ZH’ here.

From Easy access menu Goto T-code OAAD

/wp-content/uploads/2013/12/10_343110.png

click on Store & Assign

provide Business Object: PREL

            Document Type: HRICOLFOTO

/wp-content/uploads/2013/12/13_343111.png

click on Create button.

now provide Personnel Number & click continue button

/wp-content/uploads/2013/12/14_343130.png

Now the select the employee photograph from the file location & click on open.

/wp-content/uploads/2013/12/15_343131.png

click on Allow to proceed further

/wp-content/uploads/2013/12/16_343132.png

Now we get a confirmation message as

/wp-content/uploads/2013/12/17_343136.png

/wp-content/uploads/2013/12/18_343137.png

Now open PA30 for the employee number & check

/wp-content/uploads/2013/12/19_343138.png

This is how we are going to upload & check. Hope I made it very simple & clear

Kindly let me know if anything I missed or need to be improvised.. let me know ur valuable thoughts…

Cheers

Pradyp

To report this post you need to login first.

19 Comments

You must be Logged on to comment or reply to a post.

  1. MIthun k

    Hi Pradyp,

    Good work done 🙂 ….just a suggestion after uploading the photo the same is getting displayed in PA30 for which there is a prerequisite the Header configuration needs to be done in prior to the upload.

    In the header configuration the photo must be added …. 😎

    Regards,

    Mithun K

    (0) 
      1. Nanny S

        Dear Pradyp,

        Can you please help photo upload is not visible in infotype 0002. It is visible under extras.

        All above steps has been configured it is working in one client 210 but not in another client 310.

        Please help.

        Regards,

        Meenakshi

        (0) 
        1. Pradyp Parakala Post author

          Hi Meena

          Are you trying to view photo’s in IT0002 in R/3 or ESS? Normally for uploading the employee pic’s we use IT0002 whilst we can’t see them.. check with Header modifications once to get them in IT0002, The pics ur uploading through OAAD or OA_UPLOAD_AND LINK will make the pics appears in ESS Personal data.

          Kindly come with screen shots

          Cheers 😉

          Pradyp

          (0) 
          1. Nanny S

            Dear Pradyp,

            Header modification is same as 01 75 PERNR PIC is used. My requirement is only to show employee pic in inotype 0002, as it is working fine for client 210, employee pic updated in infotype 0002. But for client 310 it is uploaded successfully but it is not visible in screen infotype 002 in pa30 or pa20 but you can see under extra the photo.

            Please suggest.

            Regards,

            Meenakshi

            (0) 
            1. Pradyp Parakala Post author

              Dear Meena

              Can u confirm me that the Repository’s are also transported to that 310 client. If else then ask ur basis team to move the request & check once again. If u have access then u can do it from T-code OAC0 & select ur repository & transport it. It will be gr8 if u can come up with screenshots.

              Cheers 😉

              Pradyp

              (0) 
                1. Pradyp Parakala Post author

                  Dear Meena

                  As u can notice u have not maintained Document Area type, that’s the reason why its not showing the pics. kindly check the below screen shot

                  /wp-content/uploads/2014/03/6_401996.png

                  It’s always advisable to copy the std Content repository A2 & create ur own custom repository & make the amendments.

                  Hope this solves ur Issue

                  Cheers 😉

                  Pradyp

                  (0) 
                  1. Nanny S

                    No. it should be blank and it is working fine as i said in one client. please suggest what can be the other reason.

                    photo uploaded successfully in infotype 0002 but not visible in screen.

                    (0) 

Leave a Reply