Skip to Content

Hi all,

First of all I apologize for my English and clarify that this one is a personal experience that I solved in a certain way and that I am sharing in case it might help someone.

Finally, after many headaches I opened a message to SAP who referred me to Note 1376876 and confirmed my assumption with the following text:

–It is required that all components in a SAP BusinessObjects system be at the same maintenance level. For example, SAP BusinessObjects server, client, and web components must be at the same maintenance level. If you update one component of your SAP BusinessObjects system, you must also update the other components. If you uninstall a update for one component in your system, you must uninstall the same update for the other components.

In any case I think the steps I followed could be an interesting collection of things to consider in any possible problems during Webi installation.

Symptom

After installing Dashboard 4.1, Webi 4.0 SP6 has stopped working. The WebIRiechClient process is created in the Task Manager when double clicking on the shortcut icon but it disappears after a few seconds.

Reproducing the Issue

1.Webi Rich Client (BI Platform  4.0 SP6) is working correctly.
2.We install Dashboard 4.1.
3.Webi 4.0 doesn’t launch.

Resolution

1.We uninstall Dashboard 4.1.
2.Webi 4.0 works correctly.
3.We install Dashboard 4.0 SP6.
4.Webi 4.0 and Dashboard 4.0 work correctly.

Things I checked…

After installing Dashboard 4.1, Webi stopped working. I was working with Webi 4.0 SP4 and the error continued even after upgrading to SP5 or SP6.

The first thing I did was check the Product Availability Matrix (PAM). Software (Operating System, Web Browser, Office, Java….) and hardware requirements can be checked in the following link:

https://websmp202.sap-ag.de/~form/sapnet?_SHORTKEY=01100035870000735547&_SCENARIO=01100035870000000202&

After confirming that all requirements were satisfied (Windows 7 64 bit, Server 2008, Explorer 9, Office 2010 SP2, Java 7), I removed the Windows firewall and McAfee antivirus in case they might be creating a conflict, and then ran the CCleaner.

Also (from Control panel\Programs\Programs and features) I uninstalled other versions of Java leaving only the last one and I uninstalled patches SP4 and SP5 leaving only the Platform 4.0 and the SP6 patch.

I thought maybe it had become corrupted and decided to uninstall the platform and SP6 and then reinstall. This time directly installing BI Platform 4.0 SP6 (during the installation I had a problem with the 260 characters path length that I solved by decompressing directly in C:).

But the problem remained the same: the process appeared in the Task Manager but it disappeared after a few seconds.

I saw several traces in the folder C:\Program Files (x86)\SAP BusinessObjects\SAP BusinessObjects Enterprise XI 4.0\logging:

/wp-content/uploads/2013/10/logging_310088.jpg

The last trace showed this one:

/wp-content/uploads/2013/10/trace_310084.jpg

The Msiexec.exe file is mentioned. It is the Windows Installer Component. A Windows process that is used to install, repair and remove programs included in the Windows installation package. And the following error:

LanguagePackInfo regkey LanguagePackInfoDir not exist or with an empty value

I decided to uninstall all BO programs (Platform and Dashboard). I deleted the folder “SAP Business Objects” (it contained traces of errors and something else). I reinstalled Platform 4.0 SP6. And Webi finally worked.

When reinstalling Dashboard, Webi 4.1 stopped working so I concluded that both versions were incompatible. Uninstalling Dashboard 4.1, Webi worked gain. And installing Dashboard 4.0 SP6 ran both!

los dos.jpg

Other things to do…

  • Run a trace (see Note 1861180).
  • Open a Support Message to SAP so that it can be properly investigated.
  • For further information on SAP BusinessObjects Web Intelligence 4.0: http://help.sap.com/bowebi40

Best regards,

Carlos

To report this post you need to login first.

8 Comments

You must be Logged on to comment or reply to a post.

  1. Peter Chen

    Thanks for posting this….I just scratched my head for one afternoon, having exactly the same issue: after installing Dashboard 4.1, Webi 4.0 stopped working….

    Uninstalled all of the BI4.0 client tools except Dashboard 4.1, Webi rich client refused to work.

    I am going to uninstall dashboard 4.1….reinstall client tools to 4.0.

    Thanks again.

    (0) 

Leave a Reply