Skip to Content

Hi everyone,

Here you’ll find the community maintained B1DE version.

The source code is hosted on Sourceforge: SAP Business One Development Environment

Note that no changes were done to it, other than the strictly necessary for it to compile under the new DLLs.

You can download the installers using the links below.

Download Change Log
For SAP Business One 9.2 SAPBusinessOneSDK.dll is used now instead of the SAPbouiCOM and SAPbobsCOM.
For SAP Business One 9.1
For SAP Business One 9.0

Pedro Magueija

To report this post you need to login first.

52 Comments

You must be Logged on to comment or reply to a post.

  1. Paulo Henrique Eli

    Good initiative. How is an open project and versioned, we could add some more features.
    Has a future.


    Regards,

    Paulo Henrique
    SAP Business One Add-On Certification

    WordPress LinkedIn

    (0) 
  2. Luis Raposo

    Hi Pedro,

    Thank you very much for this tool.

    Was looking for this to SAP Business One 9.0. Since I only had this for version 8.82.

    Great share.

    Best Regards,

    Luis Raposo

    (0) 
    1. Pedro Magueija Post author

      Hi Michael,

      As soon as possible a new version will be compiled against SAP Business One 9.1.

      I’ll post a message here as soon as it’s done. I’d expect that in the first week of October I’ll get some time to do it.

      And thanks for keeping the interest in the tool alive.

      Cheers.


      Best regards,

      Pedro Magueija

      View Pedro Magueija's profile on LinkedIn

      (0) 
  3. Radhia Henouz

    Hello thank u so much for the link

    in the b1 9.1 version, after the setup i keep getting the error oUDO.CODE invalid column when I try to open new project

    and in the version 9.0 there is no hana db connection how can I do please helppp

    BEST REGARDS

    (0) 
    1. Pedro Magueija Post author

      Hi Radhia,

      For the issue in 9.1 please open a ticket in the sourceforge and include a small description of how to reproduce the error. I’ll have a look as soon as I can.

      For the second issue, that’s true, there is no HANA connection since that requires the HANA dll’s which I don’t have. I’m assuming that at some point SAP will merge the code, but until then there isn’t much I can do.


      Best regards,

      Pedro Magueija

      View Pedro Magueija's profile on LinkedIn

      (0) 
      1. Andrew Brooker

        Hi Pedro

        Is it possible to create addons using the B1DE 2.2 for SAP Business One for  Hana ?

        or so I need to switch to the SAP studio ?

        I have visual studio 2013 loaded

        Thanks for any help you can give

        Regards Andy

        (0) 
        1. Pedro Magueija Post author

          Hi Andy,

          I haven’t tried to use B1DE with HANA, but I think it should work. B1DE is based on the SDK so it should be compatible. However I can’t be 100% sure until I try.

          Note that queries that may be performed by the addon must be “compatible” with HANA’s SQL syntax which in some cases is different from MSSQL (e.g.: ISNULL vs IFNULL).

          As for the switch to SAP Studio, I can only say that you should try it and if you prefer it then you should use it. It does seem that SAP is “pushing” for the use of this tool so we might as well start using it.

          Let me know if you need more assistance.

          Good luck.


          Best regards,

          Pedro Magueija

          View Pedro Magueija's profile on LinkedIn

          (0) 
          1. Andrew Brooker

            Hi Pedro

            I am having problems getting my code to run under Hana, in debug mode it only runs a few lines

            So I am now trying  SAP studio

            Thanks for your help

            Regards Andy

            (0) 
  4. Radhia Henouz

    Hi Pedro

    I really apprecciate your help .. ,

    I’m trying to create Addon installer coded in c#, I followed all the steps int this  video every thing is going well until I try to install it I got a weired error “connot create an existing file ” Please tell me if it’s because of c# or to the project ..

    I even tried to create an other simple project but I keep having this error message

    your help is very apprecciated

    BEST REGARDS

    Radhia

    (0) 
      1. Ankush Bhugul

        Hi Pedro

        I have installed B1DE V2.2 but instead of SAP B1 AddOnInstaller.NET  it shows C# B1 AddOn Wizard in VS2010 which is different form tutorial by Bryan Gomez please help me on this.

        Thanks & Regards

        Vijay

        (0) 
        1. Pedro Magueija Post author

          Hi Vijay,

          The installers are only available for VB. It should be fine since you don’t need to code in order to create an installer.


          Best regards,

          Pedro Magueija

          View Pedro Magueija's profile on LinkedIn

          (0) 
            1. Pedro Magueija Post author

              Hi Vijay,

              Are you sure you are looking in the right place? Normally the VB project templates do not show C# project templates.

              /wp-content/uploads/2015/02/template_635854.png


              Best regards,

              Pedro Magueija

              View Pedro Magueija's profile on LinkedIn

              (0) 
  5. Kenneth Matheus

    hi pedro;

    i have this problem trying to running the EventLogger on SAP B1 9.1 , on a windows server 2012, sql server 2012 and i have installed VS2012 and VS2010.

    /wp-content/uploads/2015/06/falla_730753.png

    (0) 
  6. Pieterjan Spoelders

    Thought I’d also add a comment.

    Been using these tools for a while now and they’ve proven very handy.

    Thanks for providing them to us in a handy package and saving us a lot of hassle!

    (0) 
  7. HT HIEW

    Hi Pedro,

    There is an upcoming project that requires me to develop an add-on to the SAP B1.

    I have the experience to develop C# .NET / Sharepoint and Java solutions but is lacking any knowledge in SAP.

    The add-on is a simple one that it only provides a button to get a popup window to search centralised data from a remote DB. The user can pull selected data to B1 from the search result.

    Is B1DE + Visual Studio 2010 sufficient for me to develop the add on?

    How should I test the add on without SAP B1 installed in my local development server?

    (0) 
    1. Pedro Magueija Post author

      Hi Hiew,

      B1DE will help you get started, but I would recommend that you also read through the documentation installed with the SDK and have a quick look at the samples also in the SDK directory.

      You can use VS2010 without any problem.

      As for testing your add-on without B1 it is possible, but it depends how the application is designed. And using B1DE this becomes harder.

      I’d recommend that you get a version of SAP B1 and install it in order to develop add-ons.


      Best regards,

      Pedro Magueija

      View Pedro Magueija's profile on LinkedIn

      (0) 
      1. HT HIEW

        Hi Mr. Magueija,

        Thank you for your prompt reply.

        Your information is helping a lot.

        Is it a must to become partner or customer of SAP in order to receive a license key/ user ID so I can install a copy of B1 at my local dev host?

        Would appreciate if you can point me to a direction where I can get the development tools.

        I came across with this: http://www.smartcloudpt.pt/saphana/Pages/Welcome.aspx    and I am thinking it is probably affordable to sign up for 1~2 months for self learning and training before deciding to purchase a B1 license. However when I look further, the cloud dev environment still requires a S User ID which I totally don’t have at the moment.

        (0) 
        1. Pedro Magueija Post author

          Hi Hiew,

          Yes I believe this (become a partner or customer) is a prerequisite to get a license. You’ll then have access to license request and other learning assets.

          In any case I’d recommend you contact an sales representative and ask for more information or go here: SAP Partners

          Good luck.


          Best regards,

          Pedro Magueija

          View Pedro Magueija's profile on LinkedIn

          (0) 
  8. Michael Hall

    Pedro,

    As many others have said, thank you for taking the time to continue this project!  I do have one question for you.  Is there any support, or planned support for VS2015?  This is the only version that my company has and they are somewhat disinclined to purchase an older version for the inclusion of a single tool.  Also, if this is not on the horizon, would there be a possibility of another user contributing this migration?

    Thank you very much for your help and for your continued support of this tool.

    Regards,

    Michael L. Hall

    (0) 
    1. Pedro Magueija Post author

      Hi Michael,

      I personally use B1DE with VS2015 (Community Edition) so I can say it works in that IDE.

      You won’t need to purchase an older version.


      During installation change the VS edition to VS2015 and the directory to the corresponding installation directory of VS. (edition VS2015 is 14.0)

      There is one extra step that must be performed after installing.

      Go to “<installation directory of B1DE>\SAP Business One AddOn Wizard\project templates”, inside there are multiple VSXXXX folders. Last one should be 2010, copy and paste it into the same directory and rename it to VS2015.

      Of course that if you encounter any other issue, you can report it at the sourceforge location and I’ll do my best to have it fixed.

      Regarding contribution, I’d be most happy if someone would be willing to contribute. 🙂

      Hope this helps you.


      Best regards,

      Pedro Magueija

      View Pedro Magueija's profile on LinkedIn

      (0) 
      1. Michael Hall

        Pedro,

        Good afternoon (Houston time).  Thank you very much for your response.  I’m going to attempt the install this evening.  I will let you know if I have any problems.

        Regarding contributing to the project, I have no problem with this at all.  Let me know what I can do to assist you.

        Our company is currently going through the steps to become partners, and I feel that this would be a wonderful way for us to give back to the SAP development community.

        Again, thank you for your help and I look forward to working with you in the future.

        Michael L. Hall

        (0) 
        1. Pedro Magueija Post author

          Hi Michael,

          You can find as well on sourceforge a version that supports VS2015 out of the box, in the Files->Nightly build.

          Good luck.


          Best regards,

          Pedro Magueija

          View Pedro Magueija's profile on LinkedIn

          (0) 
  9. Michael Hall

    Good evening Pedro,

    Excellent for on the B1DE.  I have downloaded the source and I am currently making a 9.0 version (the one we run) that installs for 2015.  I will let you know when this is complete and see if you want to check it in or offer it as a download. 

    Again, thank you for your continued support on this product.  It is developers such as yourself that really make this work.

    Michael

    (0) 
    1. Pedro Magueija Post author

      Hi Michael,

      Yes, I was delaying it until there were some requests for it.

      I’ll make sure to release it until the end of this week, and announce it here.

      Cheers.


      Best regards,

      Pedro Magueija

      View Pedro Magueija's profile on LinkedIn

      (0) 
  10. Sebastian Pereira Cendan

    Hi Pedro, I have installed the VS Express 2012, also I have installed the BO Studio and B1DE, both for B192, but the templates doesn´t appear in my VS. I just reinstalled but not fix the problem. Do you know what can I do?

    Muito obirgado!

     

    (0) 
    1. Pedro Magueija Post author

      Hi Tichaona,

       

      It should work out of the box with VS2015, but check if the following is the case in your system:

       

      Hi Michael,

      I personally use B1DE with VS2015 (Community Edition) so I can say it works in that IDE.

      You won’t need to purchase an older version.

      During installation change the VS edition to VS2015 and the directory to the corresponding installation directory of VS. (edition VS2015 is 14.0)

      There is one extra step that must be performed after installing.

      Go to “<installation directory of B1DE>\SAP Business One AddOn Wizard\project templates”, inside there are multiple VSXXXX folders. Last one should be 2010, copy and paste it into the same directory and rename it to VS2015.

      Of course that if you encounter any other issue, you can report it at the sourceforge location and I’ll do my best to have it fixed.

      Regarding contribution, I’d be most happy if someone would be willing to contribute. 🙂

      Hope this helps you.

      Pedro Magueija

      (0) 
  11. Panagiotis Vangelatos

    Hello everybody,

    I have a question about B1DE project. The project is open source or closed source? If the project is open source, where I will find the source code?

    Sincerely,
    Vangelatos Panagiotis

    (0) 
  12. Ngoc Nguyen Thanh

    Hi Pedro Magueija,

    I have installed B1DE 9.2. But I cant find SAP B1 AddOnInstaller.NET wizard in visual studio 2013.
    Can you help me solve ?

    Thanks.
    NgocNT 

     

    (0) 

Leave a Reply