Skip to Content

Overview:

In addition to the comprehensive documentation of Software Provisioning Manager 1.0 composed by Boris, here on SCN, this post strives to bring out the difference between the two offered variants of SWPM and to help you decide which SWPM variant is to be used for provisioning desired SAP Product/Release.

Background:

Software Provisioning Manager provides the latest SAPInst version for provisioning various SAP Products among all the possible releases available.

Following two variants of Software Provisioning Manager are offered:


  • 70SWPM10SPXX*.SAR => Software Provisioning Manager 1.0 SPXX for NetWeaver 7.0x
  • SWPM10SPXX*.SAR => Software Provisioning Manager 1.0 SPXX for NetWeaver higher than 7.0x

So, what is possibly the reason behind having two variants of SWPM?

As we understand that SAP Solutions/Products (well, most of them) are based on SAP NetWeaver Platform and the major NetWeaver platforms are 7.0, 7.3, 7.4 etc (Along with the combined EHPs i.e. 7.0x/7.3x and 7.1/7.2 in case of PI / Solution Manager), so this is the driving factor in nutshell.

70SWPM10SPXX*.SAR is for Products Based on SAP NetWeaver 7.0 Platform

SWPM10SPXX*.SAR is for Products Based on Platform other than NetWeaver 7.0 i.e. NetWeaver 7.1/ 7.2/ 7.3/ 7.4 & HANA

Objective:

Many a times I myself I have faced the challenge to correctly determine the SWPM variant in order to provision particular SAP Product/Release. I also observed here in SAP NetWeaver Administrator many a times there are lots of queries regrading the SWPM Version, Link to the SWPM Download Media, Unable to find particular SAP Product in SWPM and likewise.

So I thought I would write this blog with that intention, to provide a handy reference so as to determine the correct SWPM variant  for provisioning particular SAP Product/Release.

I myself have found this very useful, so as to avoid the gap of determining the required SWPM variant and speeding up the Provisioning process.

Featured:

Software Provisioning Manager 1.0 is offered in two variants:

  • 70SWPM10SPXX*.SAR => Software Provisioning Manager 1.0 SP XX for NW 7.0x
  • SWPM10SPXX*.SAR=> Software Provisioning Manager 1.0 SP XX for NW higher than 7.0x

70SWPM10SPXX*.SAR offers provisioning of following SAP Products/Releases =>

  • SAP Netweaver 7.03 (AS ABAP)
  • SAP Netweaver 7.02 (PI, Mobile, AS ABAP/JAVA etc)
  • SAP Netweaver 7.01 SR1 (PI, Mobile, AS ABAP/JAVA etc)
  • SAP Netweaver 7.0 SR3 (PI, Mobile, AS ABAP/JAVA etc)
  • SAP BS 7i 2011 (CRM 7.02 ABAP, ERP 6.06 ABAP, SCM 7.02 ABAP, SRM 7.02 ABAP)
  • SAP BS 7i 2010 (CRM 7.01 ABAP/JAVA, ERP 6.05 ABAP/JAVA, SCM 7.01 ABAP, SRM 7.01 ABAP/JAVA)
  • SAP BS 7 SR1 (CRM 7 ABAP/JAVA, ERP 6.04 ABAP/JAVA, SCM 7.0 ABAP/JAVA, SRM 7.0 ABAP/JAVA)
  • SAP BS 2005 (CRM 5 SR3 ABAP/JAVA, ERP 6 SR3 ABAP/JAVA, SCM 5 SR3 ABAP/JAVA, SRM 5 SR3 ABAP/JAVA)
  • Additional Products (CRM 2007 ABAP/JAVA, SCM 5.1 ABAP/JAVA)
  • Solution Manger 7.1 SR1
  • Solution Manager 7.01 SR1
  • Dual Stack Spilt
  • System Rename

/wp-content/uploads/2013/08/save_377015.jpg

Figure 1 – 70SWPM10SPXX*.SAR (SWPM 1.0 for NW 7.0x)


SWPM10SPXX*.SAR offers provisioning of following SAP Products/Releases =>

  • SAP Netweaver 7.4 SR1 (AS ABAP/JAVA, PI)
  • SAP Netweaver 7.4 (AS ABAP/JAVA, PI etc)
  • SAP Netweaver 7.31 (AS ABAP/JAVA, PI etc)
  • SAP Netweaver 7.3 (AS ABAP/JAVA, PI etc)
  • SAP Netweaver CE 7.2 (JAVA)
  • SAP Netweaver CE 7.11 (JAVA)
  • SAP Netweaver CE 7.1 (JAVA)
  • SAP Netweaver PI/Mobile/Banking 7.11 (AS ABAP/JAVA, PI, etc)
  • SAP Netweaver PI/Mobile/Banking 7.1 (AS ABAP/JAVA, PI, etc)
  • SAP BS powered by SAP HANA (CRM 7.02 ABAP on HANA, ERP 6.06 ABAP on HANA, SCM 7.02 ABAP on HANA)
  • SAP BS 7i 2013 (CRM 7.03 ABAP, CRM 7.03 JAVA, ERP 6.07 ABAP, ERP 6.07 JAVA, SCM 7.03 ABAP, SRM 7.03 ABAP, SRM 7.03 JAVA)
  • SAP BS 7i 2011 Java (CRM 7.02 JAVA on NW 7.4 , CRM 7.02 JAVA on NW 7.31, CRM 7.02 JAVA on NW 7.3, ERP 6.06 JAVA on NW 7.4, ERP 6.06 JAVA on NW 7.31, ERP 6.06 JAVA on NW 7.3, SRM 7.02 JAVA on NW 7.4, SRM 7.02 JAVA on NW 7.31 & SRM 7.02 JAVA on NW 7.3)
  • SAP BS 7i 2010 Java (CRM 7.01 JAVA on NW 7.4, CRM 7.01 JAVA on NW 7.31, CRM 7.01 JAVA on NW 7.3, ERP 6.05 JAVA on NW 7.4, ERP 6.05 JAVA on NW 7.31, ERP 6.05 JAVA on NW 7.3, SRM 7.01 JAVA on NW 7.4, SRM 7.01 JAVA on NW 7.31 & SRM 7.01 JAVA on NW 7.3)
  • SAP BS 7 SR1 Java (CRM 7 JAVA on NW 7.4, CRM 7 JAVA on NW 7.31, CRM 7 JAVA on NW 7.3, ERP 6.04 JAVA on NW 7.4, ERP 6.04 JAVA on NW 7.31, ERP 6.04 JAVA on NW 7.3, SCM 7 JAVA on NW 7.31, SCM 7 JAVA on NW 7.3, SRM 7 JAVA on NW 7.4, SRM 7 JAVA on NW 7.31 & SRM 7 JAVA on NW 7.3)
  • SAP Solution Manager 7.1 powered by SAP HANA (AS ABAP & JAVA)
  • Dual Stack Spilt
  • System Rename

/wp-content/uploads/2013/08/save_377015.jpg

Figure 2 – SWPM10SPXX*.SAR (SWPM 1.0 for NW higher than 7.0x)

The classification of particular SAP Product/Release to the SWPM variant is intended to change over time as the latest version of SWPM will provide the support for latest products, versions and supported platforms.

It is always recommended to use the latest version of SWPM Tool.

I have used following SWPM Versions (SWPM Support Pack & Patch) for the above information and I will try my best to keep it up to date as in when new SAP Product Release happens:


  • 70SWPM10SP04_4-20009701.sar => SWPM 1.0 SP04 for NW 7.0x (January 2014)
  • SWPM10SP04_4-20009701.SAR => SWPM 1.0 SP04 for NW higher than 7.0x (January 2014)


With this I leave it to you to for your suggestions & feedback.


Best Regards,

Akshay


To report this post you need to login first.

27 Comments

You must be Logged on to comment or reply to a post.

  1. Daniele Dutra

    Very nicely explained!

    Some info about this was recently (I think) also added to the Info Page of the download link of SWPM (in /sltoolset -> SWPM -> download).

    But here we have many more details plus screehsots, thanks! 🙂

    (0) 
  2. Masanori Serizawa

    Hi Akshay Gupta

    Please teach me

    Now Use SAP NetWeaver 7.0 Support Release2

    We Are Planning systemcopy

    Can use SWPM?

    ECC6.0
    SAP BASIS 700 Level0015
    SAP ABA 700 Level0015

    Regards
    Serizawa

    (0) 
    1. Akshay Gupta Post author

      Hi,

      You want me to teach you System Copy 😯 ?

      I believe not, well to answer you, yes you can use SWPM for performing system copy.

      Use 70SWPM* one, the latest being 70SWPM10SP04_4-20009701.sar. Use this SWPM package for performing Homogeneous System Copy under option: SAP Installation Master => SAP NetWeaver 7.0 => Software Life-Cycle Options => System Copy.

      You specified you are on SAP Netweaver 7.0 SR2. I think SWPM minimum supported is SR3, you will also see that in SWPM. You might have to upgrade to SPs corressponding to SR3 then first.

      Please check with SAP. If SWPM is not supported in your case you will have to use Installation master from the archives SAP mentions to you.

      Regards,

      Akshay

      (0) 
    1. Akshay Gupta Post author

      Jack, the reason why you do not see NW2004 in either of the SWPM is because SWPM Idea was conceived after NW 2004.

      It all began with NW 7.0 which to gently put is NW2004s.

      So i guess to do any of what you want for NW2004, you must use the proprietary tool i.e. SAPinst or SAPup or whatsoever for your particular case. You should find that in downloads “Archive”.

      Hope that makes sense!

      Regards,

      Akshay

      (0) 
      1. Priya Bharath

        I only see archive section under the

        (SUPPORT PACKAGES AND PATCHES)

        But not under Installation and Upgrades section, where can I find that?

        (0) 
        1. Akshay Gupta Post author

          Replying a lot later, apologies!

          I think I know the reason why. Since you are looking for NW 2004 which is release prior to NW 7.0 (2004s), this is a quite an old version. SAP must have decided to stop putting the Installation media for it anymore, but continued to make the support packs available in the archives section.

          Similar to an analogy of the old sports car model not being manufactured anymore since more latest models are available now, but the parts and pieces for the old model may still be existent (until to a certain point of time though)…

          I looked up to the PAM for NW 2004, and its mainstream maintenance ended way back 5 years and extended one around 2 years back. Hope that is why, you are not able to find it.

          Just curious, why you would want to insist on installing that old NW Flavor?

          NW04.JPG

          Regards,

          Akshay

          (0) 
          1. Priya Bharath

            well actually the reason is that.. we are going to be doing OS/DB migration. So thinking of installing the same version with the different DB and then do the upgrade to ehp7

            (0) 
  3. Manikanta P

    Hi Akshay,

    Nice blog.

    I want to install ecc6.0 with ehp5.which swpm is suitable for me.

    Because when i try to install 7.4 am unable to give kernel version 740 path.

    Manikanta P.

    (0) 
      1. Manikanta P

        Hi Nicolas,

        Thanks for your reply.But when install SAP it does’t allow me to give 740 kernel unit.its asks only 720.And also am unable to find 720 kernel in SMP.

        My requirement is :

        SAP ECC 6.0 EHP5

        OS windows server 2008 sr2

        Database is ASE.

        (0) 
  4. Joshua Lacroix

    I don’t get it.

    I want to install a ERP6/EHP6 server with a system copy option.

    This is based on NW stack 7.31

    Why would I use the old tool for NW7.0 products???

    (0) 
    1. Daniele Dutra

      Hi Joshua,

      That is sort of a naming confusion. ERP6 with EHP6 can be thought of intended to run based on NW 7.03 and not 7.31. Technically they are the same thing, you will indeed see stack 731 if you check the components, but from a non-technical perspective that is supposed to be NW 7.03.

      On a second note, don’t think of 70SWPM as an “old tool”. This version of SWPM is as up to date as the one for 7.1 and higher products.

      Hope this helps to clarify.

      Regards,

      Daniele

      (0) 
      1. Joshua Lacroix

        I should probably reply back, since my comments and the research I’ve done yes, I’ve come to terms with using 70SWPM and no longer calling an old tool since I see its up to date with latest SP’s.

        Ive used it, worked fine for what I needed, although, when refreshing my SQL, it executed as I had 2005 installed and not sql 2012, anywho, I fixed all that.

        works good! learnt something new

        (0) 
  5. Sankara Bavirisetti

    Hello All,

    I would like to install SAP S4 simple finance 1503 , which swpm suits? I have tried withce maintenance  planner and down loaded 1503 archives plus swpm 1.0 sp17   . In fact , I don’t have options to install 1503 with downloaded swpm ? Can you help.

    (0) 

Leave a Reply