Skip to Content
Author's profile photo Felipe Fonseca

Problems using Batch Input in SU01/SU10

Hi folks,

 

I have seen several cases in which problems occurs when using an eCATT script or a batch input recording with transactions SU01 or SU10, especially after an upgrade of the system to NetWeaver Release 7.3 or higher…

 

The most common errors occur within programs SAPLSUID_MAINTENANCE or SAPLPRGN_TREE, where you notice particular inconsistencies, such as the absence of Screen fields that used to appear, causing errors with your script.

 

The cause to this problem is changes in the User Maintenance infrastructure, as you can see within the below link:

 

Identity Management, see the Infrastructure Changes in User Maintenance feature, within AS ABAP section.

I have published a knowledge base article (1864062) to address the topics related to this change. You can find there further details on how to overcome this situation, by using transaction codes SU01_OLD and SU10_OLD respectively.

Please feel free to share your experiences on this matter.

Assigned tags

      5 Comments
      You must be Logged on to comment or reply to a post.
      Author's profile photo Martin Voros
      Martin Voros

      Hi,

      has anyone figured out how to do role assignment in SU01 in BI with new screens? I recently had to recreate BI for SU01 but role table seems to be using fancy table control that is not visible in BI session. We used SU10 for role assignment. I am just curious.

      Cheers

      Author's profile photo Former Member
      Former Member

      Ignore

      Kind regards

      David

      Author's profile photo Former Member
      Former Member

      Hi,

      I too face this issue. My question is, if I write a new CATT script, will I get the same issue in future, when any upgrade?

      My production client is locked. Is there a way to bypass the error without disturbing the Production client settings, like through input file?

      Any help will be appreciated...

      Author's profile photo Felipe Fonseca
      Felipe Fonseca
      Blog Post Author

      Hi Srinivasan,

      You'll experience this situation as soon as you upgrade to NetWeaver Release 7.3.

      Regards,

      Felipe Fonseca

      Author's profile photo Former Member
      Former Member

      The problem is quite old now but still exisists. Do you have any solution or workaround for that? SU10_OLD can't be used any more.