Skip to Content

Welcome at the SAP on IBM i (almost 😉 weekly update! This time I’d like to make you aware of an important step in the support of Java based SAP products.

SAP JVM 4.1 available for all platforms

Silently, SAP note 1495160 (SMP login required for this and all other notes) has been converted from a letter of intent into an announcement. It reports that SAP JVM 4.1 is now available for all planned platforms, which, of course, also includes IBM i. Over time this will be the only supported JVM with SAP Web Application Server 6.40 and SAP NetWeaver 7.0.

We had the experience of a VM switch already, from the proprietary Classic VM to the overall IBM J9 (named IT4J on IBM i). Support of SAP JVM now is just a consequent step towards deeper integration of SAP on IBM i into the platform family at SAP: We share the same architecture, parametrization, documentaion, tools, support cycles…

SAP JVM is in certain respect to be treated like a part of the SAP kernel. Therefore,  proper integration into kernel logistics and the respective peculiarities of IBM i had to be taken into account. For this, SAP note 1563545 is intended to be the central point of information being referenced from all other places of documentation.

 

Stay tuned…

As the development team intends to maintain a consistent format, editions of the series will continue to be published on my name. Set feeds accordingly if you are interested in following the series.

To report this post you need to login first.

Be the first to leave a comment

You must be Logged on to comment or reply to a post.

Leave a Reply