Skip to Content

Have you ever wanted developing Java EE applications for the SAP NetWeaver platform using just an ordinary Eclipse IDE? Until now you were bound to the SAP NetWeaver Developer Studio – even when developing standard applications. This dependency is now broken with the introduction of the SAP NetWeaver Server Adapter for Eclipse.

The SAP NetWeaver Server Adapter for Eclipse is a tiny set of Eclipse plug-ins that integrates the SAP NetWeaver Application Server into the development tools provided by the Eclipse WTP project. All standard features for Java EE development provided by Eclipse WTP are now available for SAP NetWeaver without the need of any other SAP proprietary tools.

The currently supported releases of the SAP NetWeaver platform are:

  • SAP NetWeaver CE/PI 7.1
  • EHP1 for SAP NetWeaver CE/PI 7.1
  • SAP NetWeaver CE 7.2

The server adapter is installable on all latest releases of Eclipse, including:

  • Eclipse Europa
  • Eclipse Ganymede
  • Eclipse Galileo

It is planned that future releases of SAP NetWeaver and Eclipse will be supported, too.

The SAP NetWeaver Server Adapter for Eclipse is currently under active development. Although it already has a good set of features introduced and wide supportability martix, there is more useful features to come soon from our backlog. Your feedback certainly matters and you can see your influence on the project soon – we release new version at least every month!

You may try the server adapter right now in your favourite Eclipse installation, or in a fresh new Eclipse IDE for Java EE Developers, by following the easy installation steps. More details on the project’s scope are available on the wiki page

Enjoy the Java EE development for the SAP NetWeaver platform in an open environment!

To report this post you need to login first.

2 Comments

You must be Logged on to comment or reply to a post.

Leave a Reply